Foros del Web » Programas, Hardware y Redes » Ofimática »

VBA - Excel - Aplicar formula BuscarV

Estas en el tema de VBA - Excel - Aplicar formula BuscarV en el foro de Ofimática en Foros del Web. Hola amigos!!! Necesito aplicar esta formula en una celda Código: =BUSCARV($B5;'H:\[DATABASE.xls]DataBase Deuda'!$A$3:$I$1754;6;FALSO) He grabado una macro haciéndolo paso por paso y me da esta formula ...
  #1 (permalink)  
Antiguo 10/03/2009, 04:22
 
Fecha de Ingreso: marzo-2007
Mensajes: 538
Antigüedad: 7 años, 5 meses
Puntos: 0
VBA - Excel - Aplicar formula BuscarV

Hola amigos!!!

Necesito aplicar esta formula en una celda
Código:
=BUSCARV($B5;'H:\[DATABASE.xls]DataBase Deuda'!$A$3:$I$1754;6;FALSO)
He grabado una macro haciéndolo paso por paso y me da esta formula en la macro:
Código:
    ActiveCell.FormulaR1C1 = _
        "=VLOOKUP(RC[-17],'[Base de datos.xls]DataBase Deuda'!R3C1:R1754C9,6,FALSE)"
alguien me la puede explicar?
no entiendo RC[-17] y R3C1:R1754C9...

Luego me surge otro problema y es que B5 es un numero pero guardado como texto, como puedo hacerlo para que no me de error?
y no puedo convertirlo a numero porque tengo codigos 13 y 013, por lo que no es lo mismo... como lo hago?

Gracias!!!
  #2 (permalink)  
Antiguo 10/03/2009, 05:18
 
Fecha de Ingreso: marzo-2007
Mensajes: 538
Antigüedad: 7 años, 5 meses
Puntos: 0
Respuesta: VBA - Excel - Aplicar formula BuscarV

Tengo una primera solucion y es que la formula aplicada no me da ningún error excepto con los valores 13 y 013.
Finalmente he puesto este codigo
Código:
Dim a As String
a = Trim(Range("B" & intFilaToCopy).Value)
ActiveCell.FormulaR1C1 = "=VLOOKUP(" & a & ",'[Base de datos.xls]DataBase Deuda'!R3C1:R1754C9,6,FALSE)"
pero no me funciona bien con los valores que he comentado.
Para el valor 13 me devuelve DIA, pero para el 013 me tendria que devolver EROSKI, que puedo hacer?

Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:22.
SEO by vBSEO 3.3.2