Foros del Web » Creando para Internet » Diseño web »

Ayuda, primera vez que valido en la w3c, no entiendo los errores

Estas en el tema de Ayuda, primera vez que valido en la w3c, no entiendo los errores en el foro de Diseño web en Foros del Web. Holas a todos , primera vez que valido con el validador de la extension para firefox web developer... y me salen 4 errores en mi ...
  #1 (permalink)  
Antiguo 21/11/2007, 00:42
 
Fecha de Ingreso: febrero-2007
Mensajes: 70
Antigüedad: 10 años, 9 meses
Puntos: 1
Ayuda, primera vez que valido en la w3c, no entiendo los errores

Holas a todos , primera vez que valido con el validador de la extension para firefox web developer... y me salen 4 errores en mi html... los coloco acá por que yo no los entiendo...
-------------------------------------------------------------------------------------
This page is not Valid HTML 4.01 Transitional!
Result: Failed validation, 4 Errors
Modified: (undefined)
Server: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Size: (undefined)
Content-Type: text/html
Encoding: iso-8859-1
Doctype: HTML 4.01 Transitional
Root Element: HTML

ERROR 01:

Line 6, Column 63: document type does not allow element "LINK" here.
…="stylesheet" type='text/css' href='css/estiloal.css' />

The element named above was found in a context where it is not allowed. This could mean that you have incorrectly nested elements -- such as a "style" element in the "body" section instead of inside "head" -- or two elements that overlap (which is not allowed).

One common cause for this error is the use of XHTML syntax in HTML documents. Due to HTML's rules of implicitly closed elements, this error can create cascading effects. For instance, using XHTML's "self-closing" tags for "meta" and "link" in the "head" section of a HTML document may cause the parser to infer the end of the "head" section and the beginning of the "body" section (where "link" and "meta" are not allowed; hence the reported error).

ERROR 02:

Line 11, Column 6: end tag for element "HEAD" which is not open.
</head>

The Validator found an end tag for the above element, but that element is not currently open. This is often caused by a leftover end tag from an element that was removed during editing, or by an implicitly closed element (if you have an error related to an element being used where it is not allowed, this is almost certainly the case). In the latter case this error will disappear as soon as you fix the original problem.

If this error occurred in a script section of your document, you should probably read this FAQ entry.

ERROR 3:

Line 12, Column 18: document type does not allow element "BODY" here.
<body id="general">

The element named above was found in a context where it is not allowed. This could mean that you have incorrectly nested elements -- such as a "style" element in the "body" section instead of inside "head" -- or two elements that overlap (which is not allowed).

One common cause for this error is the use of XHTML syntax in HTML documents. Due to HTML's rules of implicitly closed elements, this error can create cascading effects. For instance, using XHTML's "self-closing" tags for "meta" and "link" in the "head" section of a HTML document may cause the parser to infer the end of the "head" section and the beginning of the "body" section (where "link" and "meta" are not allowed; hence the reported error).


De ahí tengo 11 warnings que siempre son por cerrar de esta forma

ontent="text/html; charset=iso-8859-1" />
…="stylesheet" type='text/css' href='css/estiloal.css' />
…type="text" id="comentario" size="50" maxlength="200" />


y todos los warnings son de ese tipo... es primera vez que valido y no entiendo que pasa... si alguien me explica un poco estaré muy agradecido..

de antemano gracias y saludos
  #2 (permalink)  
Antiguo 21/11/2007, 06:04
 
Fecha de Ingreso: noviembre-2007
Mensajes: 1
Antigüedad: 10 años
Puntos: 0
Re: Ayuda, primera vez que valido en la w3c, no entiendo los errores

Principalmente los errores que te marca es porque no abres y cierras correctamente las etiquetas; para abrirlas es "<" y para cerrarlas "/>" (sin las comillas obviamente). Si quieres pon todo el código de tu página aquí para analizarlo. También hay errores de orden.
  #3 (permalink)  
Antiguo 21/11/2007, 06:54
 
Fecha de Ingreso: diciembre-2003
Mensajes: 1.583
Antigüedad: 14 años
Puntos: 13
Re: Ayuda, primera vez que valido en la w3c, no entiendo los errores

Cita:
De ahí tengo 11 warnings que siempre son por cerrar de esta forma

ontent="text/html; charset=iso-8859-1" />
…="stylesheet" type='text/css' href='css/estiloal.css' />
…type="text" id="comentario" size="50" maxlength="200" />
Esa forma de cerrar que pones ahí se usa para XHTML. Tú estás usando HTML, por lo que deberías cerrar así:

Código HTML:
De ahí tengo 11 warnings que siempre son por cerrar de esta forma

ontent="text/html; charset=iso-8859-1">
…="stylesheet" type='text/css' href='css/estiloal.css'>
…type="text" id="comentario" size="50" maxlength="200">
El resto de los errores que te aparecen probablemente se deban a lo anterior.
__________________
El conocimiento es libre: Movimiento por la Devolución
  #4 (permalink)  
Antiguo 21/11/2007, 10:26
hq1
 
Fecha de Ingreso: abril-2007
Ubicación: Madrid, España
Mensajes: 107
Antigüedad: 10 años, 7 meses
Puntos: 0
Re: Ayuda, primera vez que valido en la w3c, no entiendo los errores

Mira la primera línea de tu archivo html, ahí se encuentra la definición del tipo de documento. Por lo que te sale, parece que has definido un tipo HTML, pero parece que intentas usar un tipo XHML, intenta que en esa definición ponga una de estas 2 cosas:

Código:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
ó
Código:
 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
¡¡Pero sólo una de las 2!!
Aparte, aunque no creo que sea, los errores parecen decir que te falta la sentencia <head> inmediatamente después de <HTML>, pero ya te digo que no creo que sea eso, sobre todo porque estás desarrollando con DW.
__________________
Proyecto de revista digital:

www.elcampamentobase.es
  #5 (permalink)  
Antiguo 21/11/2007, 12:48
 
Fecha de Ingreso: febrero-2007
Mensajes: 70
Antigüedad: 10 años, 9 meses
Puntos: 1
Re: Ayuda, primera vez que valido en la w3c, no entiendo los errores

Wow chicos... se pasaron... realmente muy agradecido...

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

con eso arreglé casi todo .. igual tenía una mezcla entre xhtml y html 4.01... no tenia idea la verdad.. es primera vez que valido la página...

ahora solo tengo un error y ni un warning... el resto los arreglé todos... este es el error que queda:

This page is not Valid XHTML 1.0 Transitional!
Result:Failed validation, 1 Error
Server:Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Size:(undefined)
Content-Type:text/html
Encoding:iso-8859-1
Doctype:XHTML 1.0 Transitional
Root Element:html
Root Namespace:http://www.w3.org/1999/xhtml

Line 66, Column 21: there is no attribute "onClick".

<button onClick="fajax()" type="button" class="btnform">Publicar</button></

You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.


Ese es el error que queda... trate cambiando a estrict, pero me da el mismo error... alguna idea??? y muchas gracias
  #6 (permalink)  
Antiguo 21/11/2007, 13:01
Avatar de webosiris
Moderador egiptólogo
 
Fecha de Ingreso: febrero-2002
Ubicación: Luxor, Egipto
Mensajes: 10.727
Antigüedad: 15 años, 9 meses
Puntos: 997
Re: Ayuda, primera vez que valido en la w3c, no entiendo los errores

en xhtml los atributos van siempre con minúscula... cambia onClick por onclick
__________________
Pasamos tus PSD a HTML

Pobre del que lo sabe todo, porque no tiene nada más que aprender ni razón para vivir. -
  #7 (permalink)  
Antiguo 22/11/2007, 00:21
 
Fecha de Ingreso: febrero-2007
Mensajes: 70
Antigüedad: 10 años, 9 meses
Puntos: 1
Re: Ayuda, primera vez que valido en la w3c, no entiendo los errores

exelente pude validar todo... exepto algo que creo no tiene solución

el estandar dice que al implementar una tabla, el <tfoot> debe ir inmediatamente despues del <thead> y antes del <tbody>, de esa forma valida

mi problema surgio en el momento en que yo pinto en el <tfoot> una suma total de los datos mostrados en la tabla.... y al ponerlo antes del <tbody> el valor del nomero no sale ya que a esas alturas la variable no tiene ni un valor ya que se genera en el tbody... asi que esa pagina no validao por tener ese error

pero el resto valido todo..

muchas gracias y saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:01.