Foros del Web » Creando para Internet » Diseño web »

Cerrar capas no me funciona en explorer si en netscape

Estas en el tema de Cerrar capas no me funciona en explorer si en netscape en el foro de Diseño web en Foros del Web. Hola, tengo un problema con las capas y el javascript. Funciona perfectamente en Moxilla Firefos (3.0.3), pero no me funciona en Internet Explorer (7.0). Sencillamente ...
  #1 (permalink)  
Antiguo 05/11/2008, 04:28
 
Fecha de Ingreso: noviembre-2008
Mensajes: 9
Antigüedad: 9 años, 1 mes
Puntos: 0
Exclamación Cerrar capas no me funciona en explorer si en netscape

Hola, tengo un problema con las capas y el javascript.
Funciona perfectamente en Moxilla Firefos (3.0.3), pero no me funciona en Internet Explorer (7.0).
Sencillamente se trata de abrir una capa al cargar la pagina con un texto que pone cerrar, pero no hay forma, en explorer no me lo cierra.
os adjunto el ejemplo:

http://www.kkuet.com/temp/pruebas3.htm

y el código:

---------------------------------------------

<script language=JavaScript>
function cierra1()
{
document.getElementById('Layer1').style.visibility = "hidden";
}
</script>


<body>
PRUEBA
<!--Aqui ponemos la Capa que contendra el SWF Flotante-->

<DIV id="Layer1" STYLE="position: absolute; top:5px; left:100px; width:305px; height:315px; z-index=1;background-color: #FFFFCC; layer-background-color: #FFFFCC; border: 1px none #000000;">
<div align="center">
<embed name="animacion" src="fondos1.swf" loop="false" menu="false" quality="best" wmode="transparent" bgcolor="#0000FF" swLiveConnect="true"
width="270" height="315"
type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"> <br>
<a href="javascript:cierra1();">CERRAR</a></div>
</DIV>

</body>

Muchas gracias de antemano a todos.

Última edición por kkuet; 05/11/2008 a las 05:48
  #2 (permalink)  
Antiguo 05/11/2008, 09:03
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Respuesta: Cerrar capas no me funciona en explorer si en netscape

Yo lo probé y funciona sin problemas, aunque hay que tener en cuenta que visibility: "hidden" sigue ocupando espacio, es mejor display: "none", pero esa ya es otra historia, el caso es que funciona.

Deduciendo lo que puede ser, ¿no estarás haciendo pruebas en local y tu nivel de seguridad no está permitiendo que se ejecute Javascript?.

EDITO: Ya veo que no funciona en el enlace que pusiste, hay que tener en cuenta que tu HTML está mal estructurado, además que el estilo CSS está que tratas de aplicar al embed está mal.
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.

Última edición por David; 05/11/2008 a las 09:10
  #3 (permalink)  
Antiguo 05/11/2008, 11:01
 
Fecha de Ingreso: noviembre-2008
Mensajes: 9
Antigüedad: 9 años, 1 mes
Puntos: 0
Respuesta: Cerrar capas no me funciona en explorer si en netscape

Gracias David por la respuesta pero entonces?
Cual seria la estructura correcta?

Porque ese ejemplo es bien simple y como te digo en el Firefox me funciona bien, simplemente en el explorer pues no me va.

Un cordial saludo
  #4 (permalink)  
Antiguo 05/11/2008, 11:13
 
Fecha de Ingreso: noviembre-2008
Mensajes: 9
Antigüedad: 9 años, 1 mes
Puntos: 0
Respuesta: Cerrar capas no me funciona en explorer si en netscape

He probado lo de display none y asi me funciona.

Gracias nuevamente y salu2
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:07.