Foros del Web » Creando para Internet » Diseño web »

Envio de parametros en require PHP

Estas en el tema de Envio de parametros en require PHP en el foro de Diseño web en Foros del Web. Hola a todos Mi error aparecio cuando hice un require a un archivo y trate de enviarle parametros, he buscado informacion en la web pero ...
  #1 (permalink)  
Antiguo 11/05/2009, 18:02
 
Fecha de Ingreso: julio-2008
Mensajes: 9
Antigüedad: 9 años, 4 meses
Puntos: 0
Envio de parametros en require PHP

Hola a todos

Mi error aparecio cuando hice un require a un archivo y trate de enviarle parametros, he buscado informacion en la web pero no he encontrado nada que me sirva, aqui les envio mi sintaxis:

require("logo/display.php?width=150&height=100&relative=1&id_ca= ".$id);

si hago la llamada sin incluir los parametros funciona correctamente, pero el problema es que necesito enviarle esos parametros. Si alguien puede ayudarme con eso se lo agradeceria muchisimo.
  #2 (permalink)  
Antiguo 12/05/2009, 04:07
Avatar de AnesGy  
Fecha de Ingreso: mayo-2009
Mensajes: 518
Antigüedad: 8 años, 7 meses
Puntos: 19
Respuesta: Envio de parametros en require PHP

Cambialo por esto:

Código PHP:
$width=150;
$height=100;
$relative=1;
$id_ca$id;
require(
"logo/display.php"); 
Y si no funciona cambia require por include (en el include funciona seguro).

Si sigue sin funcionar (lo cual me parecería raro), en el archivo display.php pon, después de la primera etiqueta <?php

Código PHP:
global $width$height$relative$id_ca
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:48.