Foros del Web » Creando para Internet » Diseño web »

Error al ejecutar un JSP

Estas en el tema de Error al ejecutar un JSP en el foro de Diseño web en Foros del Web. Hola: Tengo un problema y no se como solucionarlo, tengo instalado el Tomcat en mi equipo W2000, en principio esta bien configurado, los html de ...
  #1 (permalink)  
Antiguo 20/08/2002, 06:27
 
Fecha de Ingreso: junio-2002
Mensajes: 5
Antigüedad: 14 años, 3 meses
Puntos: 0
Error al ejecutar un JSP

Hola:

Tengo un problema y no se como solucionarlo, tengo instalado el Tomcat en mi equipo W2000, en principio esta bien configurado, los html de ejemplo me van de maravilla, pero cuando voy a ejecutar un JSP me salta un error, exactamente este:

type Exception report

message Internal Server Error

description The server encountered an internal error (Internal Server Error) that prevented it from fulfilling this request.

Si alguien me pudiera ayudar se lo agradeceria, un saludo.

Patxi
  #2 (permalink)  
Antiguo 21/08/2002, 00:05
Avatar de hugo777  
Fecha de Ingreso: enero-2002
Ubicación: Lima, Perú
Mensajes: 757
Antigüedad: 14 años, 8 meses
Puntos: 1
Re: Error al ejecutar un JSP

Hola, no se entiende muy claro el error, podrías especificar algo más de información ... como por ejemplo el JSP que tienes o exactamente toda la cadena de error que obtienes tanto en el browser como en el Tomcat ...

  #3 (permalink)  
Antiguo 21/08/2002, 02:20
 
Fecha de Ingreso: junio-2002
Mensajes: 5
Antigüedad: 14 años, 3 meses
Puntos: 0
Re: Error al ejecutar un JSP

Te explico todo el procedimiento:

He instalado el jdk en el directorio D:\jdk, después he instalado el tomcat en el directorio D:\tomcat.
Despues he creado las variables de entorno:
JAVA_HOME
D:\jdk
TOMCAT_HOME
D:\tomcat
He creado la variable de entorno:
Nombre: CLASSPATH
Valor:D:\jdk\lib

Pero sigue sin funcionar el JSP, me ejecuta bien los html pero en cuanto llego a los ejemplos de JSP que te da el Tomcat por defecto me sale el error, exactamente es:
Error 500
Error Interno del Servidor

java.lang.NoClassDefFoundError: sun/tools/javac/Main

exactamente te doy las lineas en las que da error:
at org.apache.catalina.valves.ErrorDispatcherValve.in voke(ErrorDispatcherValve.java:170)
at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:170)

Muchas gracias por tu ayuda, me gustaría que me ayudaras un poco más ya que me urge bastante sacar esto adelante.
Muchas gracias.
Patxi
  #4 (permalink)  
Antiguo 21/08/2002, 04:48
 
Fecha de Ingreso: junio-2002
Mensajes: 5
Antigüedad: 14 años, 3 meses
Puntos: 0
Re: Error al ejecutar un JSP

Muchas gracias ya lo he solucionado el problema radicaba en la versión del JDK que tenia instalada en mi equipo, ya que no era la adecuada, ahora me funciona correctamente y se ejecutan muy bien los JSPs.
No obstante te doy las gracias de corazón.

Patxi
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:06.