Foros del Web » Creando para Internet » Diseño web »

error al validar web

Estas en el tema de error al validar web en el foro de Diseño web en Foros del Web. Hola, primero gracias pues en estos foros los novatos encontramos la solucion a muchos de los problemas que tenemos, pero este no lo encuentro.. (espero ...
  #1 (permalink)  
Antiguo 21/10/2009, 15:58
 
Fecha de Ingreso: agosto-2008
Mensajes: 29
Antigüedad: 9 años, 3 meses
Puntos: 0
error al validar web

Hola, primero gracias pues en estos foros los novatos encontramos la solucion a muchos de los problemas que tenemos, pero este no lo encuentro.. (espero poder aportar algo algun dia ..).
Al tema, estoi intentand ovalidad la web y me da un monton de errores que no se como solucionarlos
este es el error...

Código:
XML Parsing Error

    * Line 39, column 40: XML Parsing Error: EntityRef: expecting ';'

       <li> <a href="index.php?pag=Inicio&lang=eusk" ><span class="l" ></span><span cl

    * Line 39, column > 80: XML Parsing Error: EntityRef: expecting ';'

      …sk" ><span class="l" ></span><span class="r" ></span><span class="t" >Sarrera…

    * Line 39, column > 80: XML Parsing Error: EntityRef: expecting ';'

      …sk" ><span class="l" ></span><span class="r" ></span><span class="t" >Sarrera…

    * Line 39, column > 80: XML Parsing Error: EntityRef: expecting ';'

      …sk" ><span class="l" ></span><span class="r" ></span><span class="t" >Sarrera…

    * Line 39, column > 80: XML Parsing Error: EntityRef: expecting ';'

      …sk" ><span class="l" ></span><span class="r" ></span><span class="t" >Sarrera…

    * Line 39, column > 80: XML Parsing Error: EntityRef: expecting ';'

      …sk" ><span class="l" ></span><span class="r" ></span><span class="t" >Sarrera…

    * Line 59, column 61: XML Parsing Error: EntityRef: expecting ';'

      …ent"><a href="index.php?lang=eusk&pag=Pastas&id=" >Euskara</a> | <a href="ind

    * Line 59, column 71: XML Parsing Error: EntityRef: expecting ';'
ect ect... pero no se cual es el error?

alguien????
  #2 (permalink)  
Antiguo 21/10/2009, 18:45
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Respuesta: error al validar web

Que en lugar de & debe ser &amp;
De lo contrario el parser espera que lo que sigue sea una entidad.

Saludos.
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #3 (permalink)  
Antiguo 22/10/2009, 01:32
 
Fecha de Ingreso: agosto-2008
Mensajes: 29
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: error al validar web

is si pongo &amp en php me pasara la variable igual?
  #4 (permalink)  
Antiguo 22/10/2009, 01:39
 
Fecha de Ingreso: agosto-2008
Mensajes: 29
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: error al validar web

me sige dando los siguientes errores

#

…<a href="index.php?pag=Inicio&amplang=eusk" class="active" ><span class="l"><

# Line 39, column > 80: XML Parsing Error: EntityRef: expecting ';'

…=eusk" class="active" ><span class="l"></span><span class="r" ></span><span c…

# Line 39, column > 80: XML Parsing Error: EntityRef: expecting ';'

…=eusk" class="active" ><span class="l"></span><span class="r" ></span><span c…
  #5 (permalink)  
Antiguo 22/10/2009, 01:48
Avatar de seoista  
Fecha de Ingreso: septiembre-2003
Ubicación: Pues leyéndote
Mensajes: 1.076
Antigüedad: 14 años, 3 meses
Puntos: 57
Respuesta: error al validar web

Hola mikelatx.

Tienes que ponerle el punto y coma (;) al final, como te ha dicho:

Cita:
Iniciado por David Ver Mensaje
Que en lugar de & debe ser &amp;

Saludos.
Saludos.
__________________
· Lo poco que sé, lo he aprendido de AQUÍ ·
· No contesto por M.P. ·
  #6 (permalink)  
Antiguo 22/10/2009, 14:25
 
Fecha de Ingreso: agosto-2008
Mensajes: 29
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: error al validar web

Que tengo que poner despues de la direccion del enlace ;?
algo hasi????

<a href="index.php?pag=Inicio&amplang=eusk"; class="active" ><span class="l"><
  #7 (permalink)  
Antiguo 22/10/2009, 14:31
Avatar de David
Moderador
 
Fecha de Ingreso: abril-2005
Ubicación: In this planet
Mensajes: 15.711
Antigüedad: 12 años, 7 meses
Puntos: 833
Respuesta: error al validar web

Es &amp; tal cual.
?pag=inicio&amp;lang=....
__________________
Por favor, antes de preguntar, revisa la Guía para realizar preguntas.
  #8 (permalink)  
Antiguo 23/10/2009, 08:21
 
Fecha de Ingreso: agosto-2008
Mensajes: 29
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: error al validar web

Gracias lo probare... por ahora lo esolucionado de otra manera, haber que os parece...
como el error salia cuando ponia en un link mas de una variable lo e reducido todas las variables a una...

index.php?var=jh-hkjh-kjh-kjh-kj

luego la pomo con $_GET y la divido con la funcion explode..

Que os parece, parece que funciona y me lo valida...

Gracias.. de todos modos intentare la solucion que me comentas..
  #9 (permalink)  
Antiguo 23/10/2009, 10:32
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: error al validar web

mikelatx: no tienes nada que probar, vamos, que lo estabas escribiendo mal. El símbolo and (&) se reemplaza por la entidad &amp;, vamos, empezando por el propio and y terminado en punto y coma, que es lo que te faltaba.
No te compliques la vida, que sólo es que lo tenías mal escrito. Te lo están "gritando" hace rato.
& = &amp;
__________________
Visita mi nueva web idplus.org
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:51.