Foros del Web » Creando para Internet » Diseño web »

Extraño comportamiento con Explorer...

Estas en el tema de Extraño comportamiento con Explorer... en el foro de Diseño web en Foros del Web. Hola, tengo mucho tiempo trabajando con web, pero hoy un cliente me ha llamado, su website esta completamente "roto" a nivel de layout, pero solo ...
  #1 (permalink)  
Antiguo 23/09/2009, 11:08
Avatar de asinox  
Fecha de Ingreso: enero-2002
Ubicación: Santo Domingo
Mensajes: 2.712
Antigüedad: 15 años, 10 meses
Puntos: 6
Extraño comportamiento con Explorer...

Hola, tengo mucho tiempo trabajando con web, pero hoy un cliente me ha llamado, su website esta completamente "roto" a nivel de layout, pero solo en Internet Explorer, lo curioso es que he restaurado los archivos tales como CSS, html, etc, todos archivos estaticos y continua roto.

No se a que atribuirle el problema, mi copia local esta completamente bien, y esos archivos los he subido otra vez...

entonces , pregunto.. ¿prodria tener el hosting algun problema y esto afectar el layout solo para explorer? (me rio de esta pregunta), pero es que en verdad, no se que pensar, ni que solucionar...

Alguna idea?

Saludos
__________________
www.dataautos.com
  #2 (permalink)  
Antiguo 23/09/2009, 11:44
Avatar de asinox  
Fecha de Ingreso: enero-2002
Ubicación: Santo Domingo
Mensajes: 2.712
Antigüedad: 15 años, 10 meses
Puntos: 6
Respuesta: Extraño comportamiento con Explorer...

Lo he resuelto y confirmo que IE no sirve
__________________
www.dataautos.com
  #3 (permalink)  
Antiguo 23/09/2009, 20:51
Avatar de nemesis866  
Fecha de Ingreso: julio-2009
Ubicación: Jalisco, Mexico
Mensajes: 642
Antigüedad: 8 años, 5 meses
Puntos: 19
Respuesta: Extraño comportamiento con Explorer...

hola asinox, seria bueno que compartieras la forma en que lo solucionaste

Saludos
__________________
Cursos de programación web
Articulos de programación Web
Twitter.- @paulo_866
  #4 (permalink)  
Antiguo 24/09/2009, 01:34
Avatar de asinox  
Fecha de Ingreso: enero-2002
Ubicación: Santo Domingo
Mensajes: 2.712
Antigüedad: 15 años, 10 meses
Puntos: 6
Respuesta: Extraño comportamiento con Explorer...

Hola nemesis866, en verdad, primeramente fue un fallo mio como programador php no hacer un echo bien seguro (??), en caso es que , genero las imagenes dinamicamente al momento de publicar las noticias, a estas imagenes, les agrato como valor de title y alt el titulo de la noticia.

Mi cliente al crear la noticia, puso doble comillas en el titular, ejemplo: Esto es "una noticia importante...

al momento de ese titular ser parte de los valores de la imagen
Código:
<img src="ruta/a/imagen.jpg" alt= "Esto es "una noticia importante" ">
Fijate en las comillas internas.... explorer simplemente explota, mientras que FF, Opera, Safari, Chrome, mi Iphone renderizan todo bien...pero IE...tiene que caerse...

Saludos
__________________
www.dataautos.com
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:04.