Foros del Web » Creando para Internet » Diseño web »

firefox no hace el $_POST desde un iframe

Estas en el tema de firefox no hace el $_POST desde un iframe en el foro de Diseño web en Foros del Web. hola, este es primer post....as iq espero q salga bien y pueda explicarme bien mi problema es el sigueine: tengo una pagina php y adentro ...
  #1 (permalink)  
Antiguo 01/09/2009, 08:39
 
Fecha de Ingreso: septiembre-2009
Mensajes: 3
Antigüedad: 8 años, 3 meses
Puntos: 0
firefox no hace el $_POST desde un iframe

hola, este es primer post....as iq espero q salga bien y pueda explicarme bien
mi problema es el sigueine: tengo una pagina php y adentro de sta tengo un iframe con un formulario adentro con target :top y tambien tengo un imput un campo oculto y un boton. eltema es q al enviar el formulario para arriba, el Firefox no me ahce el post del campo oculta, mientras q lo he provado con el opera chrome y tambien con ei y me anda bien.... el problema es solo con el firefox........
bueno.. espero alguna ayuda....muchas gracias .....
aca deljo el codigo

<form id="form1" name="form1" method="post" action="nue.php" target="_top">
<input type="text" style="width:140px;" name="inputString" value="" id="inputString" onkeyup="lookup(this.value);" onblur="fill();" onchange="fill(this.value);" />

<input type="hidden" name="idclienteee" id="idclienteee"/>
<label>
<input type="submit" name="button" id="button" value="aceptar" />
</label>
</form>
/////////////////////////////////////////////////////////////////////////////////////////////
el hidden no tiene value xq se lo cargo con un script.
///////////////////////////////////////////////////////////////////
el tema es q en nue.php q es donde esta el iframe con el formulario
puse:
if(isset($_POST['idclienteee']))
{
$_SESSION["idcliente"]=$_POST['idclienteee'];
var_dump($_SESSION["idcliente"]);
}
para poder ver q trae..
y en el firefox me tira string(0) "" mientras q en los demas navegadores anda bien..........
gracias nuevamente............
  #2 (permalink)  
Antiguo 02/09/2009, 02:00
Avatar de abimaelrc
Colaborador
 
Fecha de Ingreso: mayo-2009
Ubicación: En el planeta de Puerto Rico
Mensajes: 14.728
Antigüedad: 8 años, 6 meses
Puntos: 1512
Respuesta: firefox no hace el $_POST desde un iframe

Te sugiero actualizar tu firefox ya que la versiones nuevas si soportan bien los iframe.
__________________
Verifica antes de preguntar.
Los verdaderos amigos se hieren con la verdad, para no perderlos con la mentira. - Eugenio Maria de Hostos
  #3 (permalink)  
Antiguo 02/09/2009, 06:52
 
Fecha de Ingreso: septiembre-2009
Mensajes: 3
Antigüedad: 8 años, 3 meses
Puntos: 0
Sonrisa Respuesta: firefox no hace el $_POST desde un iframe

hola... muchas gracais por responder.... con respecto al firefox, te comento q ya lo actualice a la ultima, a la primera, a la del medio y nada.........
sigui provando con el codigo y me di cuenta q el problema creo q esta con el script q le da el valor al hidden. por q como dije arriba el campo idden no tiene value xq se lo asigna un script. prove con poner un value con cualquier valor al idden y si me lo levanta el mozilla del otro lado...........
asi q creo q ahi esta el punto............ cuando le asigno el value al campo idden por el script, el mozilla no levanta el valor en el post, mientras q en los otros navegadores si......... seguire investigando........ se agradace cualquier aporte....
  #4 (permalink)  
Antiguo 02/09/2009, 08:57
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 6 meses
Puntos: 2122
Respuesta: firefox no hace el $_POST desde un iframe

Tema trasladado desde PHP
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:46.