Foros del Web » Creando para Internet » Diseño web »

[IE7] Método POST no funciona

Estas en el tema de [IE7] Método POST no funciona en el foro de Diseño web en Foros del Web. Hola, hola amiguitos. Mi consulta en este caso es la siguiente, tenga un conjunto de páginas estructuradas de la siguiente forma: Uso javascript del lado ...
  #1 (permalink)  
Antiguo 29/05/2008, 13:16
Avatar de alapaco  
Fecha de Ingreso: septiembre-2003
Ubicación: Caballito - Buenos Aires - Argentina - América del Sur - Planeta Tierra - Sistema Solar - Vía Láctea
Mensajes: 216
Antigüedad: 14 años, 3 meses
Puntos: 5
Exclamación [IE7] Método POST no funciona

Hola, hola amiguitos.

Mi consulta en este caso es la siguiente, tenga un conjunto de páginas estructuradas de la siguiente forma:

Uso javascript del lado del cliente y php del lado del servidor.

La página A tiene el formulario (con method=post) con los campos donde el usuario carga los datos, este formulario llama a un javascript que valida algunas cosas y submitea el formulario de la página A hacia la página B dentro de un iframe dentro de la misma página A.
El problema surge cuando la página B quiere procesar el formulario submiteado, ya que el arreglo $_POST viene vacío...

Si esta misma acción la realizo con el Firefox o con el IE6 anda sin problemas.
Si esta misma acción la realizo con el IE7 pero con method=get anda sin problemas.

Alguien tiene alguna idea que puede ser lo que está fallando ??

Desde ya muchas gracias.

PD: Si algún admin considera que este thread va en otro subforo que mueva el thread, please.
__________________
__________________
Álvaro Lapacó
  #2 (permalink)  
Antiguo 29/05/2008, 13:44
 
Fecha de Ingreso: mayo-2008
Mensajes: 2
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: [IE7] Método POST no funciona

Resumiendo no funciona en IE7 pero si en IE6 y Firefox.

Cabe aclarar que el servidor es un Apache y que este asunto de las variables por POST en IE7 no funciona solo en las carpetas protegidas con SSPI.

<Directory "E:/WebServer/Development/Intranet">
AuthName "Intraweb XXXX - Desarrollo"
AuthType SSPI
SSPIAuth On
SSPIAuthoritative On
SSPIUsernameCase lower
SSPIPerRequestAuth Off
SSPIOmitDomain Off
SSPIOfferBasic On
SSPIBasicPreferred On
require valid-user
</Directory>


Esta es la porción de configuración del HTTPD.CONF que protege a partir de esa carpeta, obteniendo las credenciales de sus visitantes.

Necesitamos de su ayuda! GRACIAS!
  #3 (permalink)  
Antiguo 30/05/2008, 13:39
Avatar de alapaco  
Fecha de Ingreso: septiembre-2003
Ubicación: Caballito - Buenos Aires - Argentina - América del Sur - Planeta Tierra - Sistema Solar - Vía Láctea
Mensajes: 216
Antigüedad: 14 años, 3 meses
Puntos: 5
Respuesta: [IE7] Método POST no funciona

A nadie le pasó nada parecido nunca ???
Que extraño..
__________________
__________________
Álvaro Lapacó
  #4 (permalink)  
Antiguo 02/06/2008, 10:00
 
Fecha de Ingreso: mayo-2008
Mensajes: 2
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: [IE7] Método POST no funciona

Habrá algún gurú que se digne a contestar algo? Se ofrece recompensaaaa!
  #5 (permalink)  
Antiguo 04/06/2008, 09:01
Avatar de alapaco  
Fecha de Ingreso: septiembre-2003
Ubicación: Caballito - Buenos Aires - Argentina - América del Sur - Planeta Tierra - Sistema Solar - Vía Láctea
Mensajes: 216
Antigüedad: 14 años, 3 meses
Puntos: 5
Respuesta: [IE7] Método POST no funciona

Bueno, algún moderador que cierre el tema entonces....que le den su merecido velatorio al menos..
__________________
__________________
Álvaro Lapacó
  #6 (permalink)  
Antiguo 04/06/2008, 11:13
Avatar de alapaco  
Fecha de Ingreso: septiembre-2003
Ubicación: Caballito - Buenos Aires - Argentina - América del Sur - Planeta Tierra - Sistema Solar - Vía Láctea
Mensajes: 216
Antigüedad: 14 años, 3 meses
Puntos: 5
Respuesta: [IE7] Método POST no funciona

Bueno, configurando el parámetro KeepAlive a 3 (segundos) se "solucionó", es decir si la acción (submitear el form) se hace cada 3 o mas segundos anda bien...sino sigue fallando, pero bueno, algo es algo..
__________________
__________________
Álvaro Lapacó
  #7 (permalink)  
Antiguo 11/01/2009, 11:57
 
Fecha de Ingreso: enero-2009
Mensajes: 1
Antigüedad: 8 años, 11 meses
Puntos: 0
Respuesta: [IE7] Método POST no funciona

Proba de bajar la variable que posteas de esta manera, te paso un ejemplo

$actionqty=$_POST['actionqty'];
$photoqty=$_POST['photoqty'];
$flashqty=$_POST['flashqty'];

SAludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 2 personas




La zona horaria es GMT -6. Ahora son las 19:45.