Foros del Web » Creando para Internet » Diseño web »

Mi blog no funciona bien con firefox

Estas en el tema de Mi blog no funciona bien con firefox en el foro de Diseño web en Foros del Web. Hola a todo el mundo. Mi problema es el siguiente. Tengo un blog en blogspot. antes con firefox funcionaba correctamente. despues de cortar y pegar ...
  #1 (permalink)  
Antiguo 16/10/2007, 04:08
 
Fecha de Ingreso: octubre-2007
Ubicación: barcelona
Mensajes: 13
Antigüedad: 10 años, 2 meses
Puntos: 0
Mi blog no funciona bien con firefox

Hola a todo el mundo.

Mi problema es el siguiente. Tengo un blog en blogspot. antes con firefox funcionaba correctamente.

despues de cortar y pegar algunos trozos de codigo para ir poniendo el blog a mi gusto y tal no se ve correctamente en el firefox. sin embargo en el explorer 6/7 se ve correctamente.

alguioen le ha pasado? le tengo de poner algun tag para compatibilidad con el firefox?

el blog en cuestion es:

http://omniusopina.blogspot.com

PD: he ido a http://validator.w3.org/ y me encuentra 159 errores de codigo. me dice las linias y tal. pero voy a mi codigo (el codigo de la plantilla) y no coincide.

HELP PLEASE!!
  #2 (permalink)  
Antiguo 16/10/2007, 11:59
Avatar de Daniel Ulczyk
Moderador
 
Fecha de Ingreso: febrero-2005
Ubicación: Buenos Aires
Mensajes: 9.175
Antigüedad: 12 años, 9 meses
Puntos: 2072
Re: Mi blog no funciona bien con firefox

Cita:
PD: he ido a http://validator.w3.org/ y me encuentra 159 errores de codigo. me dice las linias y tal. pero voy a mi codigo (el codigo de la plantilla) y no coincide.
Antes que nada, que esto no te llame la atención.
Ningún documento de blogspot valida ante los estándares de W3C (hablando del marcado en HTML, por supuesto).
De hecho y a diferencia de los sitios que orgullosamente muestran el logo XHTML 1.1 Valid! la comunidad de blogspot que se preocupa del buen marcado ya utiliza logos del tipo "este-sitio-no-valida-html". Cosa que implementaré a la brevedad yo también.
Finalmente, y si bien no comparto el diseño basado en tablas; lo que he notado (que no puede objetársele a Blogspot) es que tenés el marcado desbalanceado. Esto es, por ejemplo, en las líneas 132 y 141 tenés un <tr> sin su correspondiente < /tr> el tag no cierra en ningún lado. En las líneas 395 y 396 tenés un "sospechoso" < /tr> seguido de un < /td>. De esta forma, un navegador como Firefox no interpreta como vos deseás el marcado y tira hacia la derecha buena parte de una tabla. En mi opinión, es más sencillo empezar de nuevo o tomar otro layout que remediar lo que ha quedado luego de "tu cortar y pegar".
__________________
—Somos lo que hacemos repetidamente. La excelencia, entonces, no es un acto sino un hábito. (Aristóteles dixit)
  #3 (permalink)  
Antiguo 16/10/2007, 15:21
 
Fecha de Ingreso: octubre-2007
Ubicación: barcelona
Mensajes: 13
Antigüedad: 10 años, 2 meses
Puntos: 0
Re: Mi blog no funciona bien con firefox

Muchas gracias Daniel Ulczyz. repasare el codigo a ver si con eso se solucona.
te agradezco mucho tu ayuda.
un saludo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:39.