Foros del Web » Creando para Internet » Diseño web »

Mi pagina web no inserta registros

Estas en el tema de Mi pagina web no inserta registros en el foro de Diseño web en Foros del Web. Hola!! Tengo un problema de base de datos con mi sitio web al momento de subirlo en mi servidor con el IIS , resulta que ...
  #1 (permalink)  
Antiguo 16/11/2007, 12:03
 
Fecha de Ingreso: noviembre-2007
Mensajes: 2
Antigüedad: 10 años, 1 mes
Puntos: 0
Mi pagina web no inserta registros

Hola!!

Tengo un problema de base de datos con mi sitio web al momento de subirlo en mi servidor con el IIS , resulta que trabajo con c#, asp.net 2.0 y base de datos con Informix, en mi máquina de pruebas todo funciona correctamente puedo hacer cualquier tipo de instruccion SQL sobre mi base de datos, el problema es cuanto cargo la página en el servidor ya que no me hace instrucciones de tipo INSERT en mi base de datos, solmente SELECT o UPDATE y lo peor de todo es q no me manda ningun tipo de error, solamente no guarda los datos .

En mi servidor tengo instalado el driver IBM INFORMIX 3.82 32 BIT y en mi máquina de pruebas utilizo el driver Informix-CLI 2.5 (32 bit) para generar mis cadenas de conexión en las páginas, antes esto no me causaba error y era indiferente ahora q tengo este problema he intentado por cambiar la cadena de conexión antes de pasarlo al IIS.

Máquina de pruebas:
ejemplo: string connectionString = "Dsn=conacad;Driver={Informix-CLI 2.5 (32 bit)};uid=infoconacad;pwd=conacad00;db=conacad_act as;host=10.16.12.15";

En el servidor:
string connectionString = "Dsn=conacad;Driver={IBM INFORMIX 3.82 32 BIT };uid=infoconacad;pwd=conacad00;db=conacad_actas;h ost=10.16.12.15";

Pero aun asi me sigue causando el mismo problema : no inserta registros en la base de datos cuanto se carga la pagina en el servidor web, solo hace instrucciones de tipo UPDATE o SELECT

Tambien he verificado las propiedades de mi directorio virtual y tengo habilitadas las opciones de lectura y escritura y en Permisos de ejecución tengo seleccionado: Sec. comandos y ejecutables.

Si alguien pudiera ayudarme se lo agradeceriaa muchismo en verdad le he estado buscando por todas partes y no encuentro razón.

Muchas gracias de antemano.
  #2 (permalink)  
Antiguo 16/11/2007, 12:50
 
Fecha de Ingreso: noviembre-2007
Mensajes: 2
Antigüedad: 10 años, 1 mes
Puntos: 0
Re: Mi pagina web no inserta registros

me avisas si pudiste tmb tengo un problema parecido
  #3 (permalink)  
Antiguo 17/11/2007, 21:55
 
Fecha de Ingreso: febrero-2007
Mensajes: 232
Antigüedad: 10 años, 10 meses
Puntos: 0
Re: Mi pagina web no inserta registros

Los permisos de lectura y escritura los tienes asignados al usuario IUSR???

Quita el permiso de ejecutar ejecutables si no te hace falta ya que es bastante arriesgado habilitarlo.
  #4 (permalink)  
Antiguo 25/02/2008, 09:47
 
Fecha de Ingreso: febrero-2008
Mensajes: 2
Antigüedad: 9 años, 9 meses
Puntos: 0
Re: Mi pagina web no inserta registros

Hola! sigo con el problema... el problema es con el formato de fechas.

Informix acepta datos de tipo date en el formato mmddyyyy, pero por medio de un driver puedo configurar desde un modulo llamado SETNET32 la propiedad del OBDC "dbdate=dmy4" lo cual indica que el formato será dd/mm/yyyy.

Cuando jecuto la aplicacion en mi servidor de pruebas, el emulador web que trae el visual studio 2005, respeta las configuraciones del SETNET 32 (es un modulo de configuracion obdc para informix) y puedo realizar cualquier operación con la base de datos correctamente.

Cuando cargo mi aplicación en el servidor Web, ya no funciona, solo puedo insertar fechas en el formato mmddyyyy. Pareciera que el IIS no respetara la configuración del SETNET32.

Si alguien pudiera ayudarme, se lo agradeceria mucho. Por lo menos una orientación por donde buscar.
  #5 (permalink)  
Antiguo 25/02/2008, 12:04
 
Fecha de Ingreso: febrero-2008
Mensajes: 2
Antigüedad: 9 años, 9 meses
Puntos: 0
Re: Mi pagina web no inserta registros

Encontre la solución!!

Para quien pueda servirle.

Solo fue necesario establecer en el Herramientas administrativas>Origenes de datos (ODBC)> DNS de sistema>"nombre del DSN">Configurar>Environment LO SIGUIENTE:
//Si usas SCO
Client Locale = es_es.8859-1 // es el locale del terminal que lo visualiza
Database Locale = es_es.8859-1 //es el locale de la base de datos, es decir
como estan grabados los datos.
y habilitar la opción "Use Server Database Locale"

Encontre que hay una utilidad de Informix que se llama glfiles y genera un fichero llamado lc11.txt, que indica los locales que peude utilizar el Informix, se invoca de la siguiente manera #gfiles.

Este link me ayudo mucho, se los dejo por si necesitan dar un viztazo:

http://www.iiug.org/forums/iiug-esp/index.cgi/noframes/read/252
Estos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:26.