Foros del Web » Creando para Internet » Diseño web »

no me funciona rewriterule en segundo nivel de archivos :S

Estas en el tema de no me funciona rewriterule en segundo nivel de archivos :S en el foro de Diseño web en Foros del Web. aqui va mi caso amigos, explico que sucedio antes: tenia un dominio .com durante 2 años, www.site.com luego de la buena respuesta he cambiado mi ...
  #1 (permalink)  
Antiguo 02/10/2010, 21:37
 
Fecha de Ingreso: octubre-2010
Mensajes: 1
Antigüedad: 7 años, 2 meses
Puntos: 0
no me funciona rewriterule en segundo nivel de archivos :S

aqui va mi caso amigos, explico que sucedio antes:

tenia un dominio .com durante 2 años, www.site.com

luego de la buena respuesta he cambiado mi dominio a un dominio territorial de tipo www.site.com.mx en el mismo hosting.

no se mucho y el cambio lo hice de la siguiente manera:

1.- asigne las dns del mismo hosting del .com al nuevo dominio .com.mx

2.- Yo queria establecer el .com.mx como default de mi cpanel, entonces llame a mi hosting y me lo cambiaron, ahora al entrar al cpanel aparece en dominio principal el .com.mx

3.- Eso que hice en el paso de atras, me descompuso TODOS mis scripts que uso en ciertas partes del sitio!, dejo de funcionar:
*wordpress
*joomla
*el guestbook
*xml generator
*desenlazo mis emails y perdi los ultimos no descargados
*horde no recibia nada
*galeria de fotos
*los links internos llamando a urls de tipo www.site.com/media/audio/one.mp3 no funcionaban, LAMENTE no usar links tipo: "media/audio/one.mp3"
*las imagenes no se mostraban
*estadisticas

entonces modifique varios html, php, css, links y variables en mysql y añadi el nuevo dominio al hotlink y funciono todo perfecto, excepto el FANTASTICO DELUXE que no me reconoce las instalaciones y no he logrado enseñarle que la instalacion no esta en el .com sino en el .com.mx

4.- Otro problema, lidiar con google con:
*las herramientas de webmaster
*analytics
*adwords
*adsense
*website optimizer
problemas con yahoo sites, msn, y demas links

5.- Este punto me esta matando:

algunas paginas me muestran no encontrado 404, ya no puedo acceder a mi sitio del modo www.sitio.com:2082 ahora es con www.sitio.com.mx:2082.

he añadido como dominio apuntado (parking) el .com con redireccion al .com.mx
he añadido una redireccion 301 permanente del .com al nuevo .com.mx

y asi me ha solucionado varios problemas,

pero al probar en google poniendo

site:www.site.com

y hay muchas paginas indexadas aun del .com

he probado

site:www.site.com.mx

y ya aparecen muchos resultados

GRAN PROBLEMA CON REWRITERULE:

mi sitio principal esta construido en html, pero tienen doble idioma, espanol e ingles:

www.sitio.com.mx (espanol)

www.sitio.com.mx/en/ (ingles)

ahora todas las redirecciones de tipo siguiente funcionan:

Código:
RewriteEngine on

Options All

RewriteCond %{HTTP_HOST} ^site.com$ [OR]
RewriteCond %{HTTP_HOST} ^www.site.com$
RewriteRule ^/?$ "http\:\/\/www\.site\.com\.mx\/" [R=301,L]

RewriteCond %{HTTP_HOST} ^.*$
RewriteRule ^prueba\.html$ "http\:\/\/www\.site\.com\.mx\/prueba\.html" [R=301,L]
PERO al poner las lineas para redireccionar en el idioma ingles, NO funciona ninguno!

Código:
RewriteEngine on

Options All

RewriteCond %{HTTP_HOST} ^site.com$ [OR]
RewriteCond %{HTTP_HOST} ^www.site.com$
RewriteRule ^en\/contact\.html$ "http\:\/\/www\.site\.com\.mx\/en\/contact\.html" [R=301,L]
[R=301,L]
de la manera anterior, NO FUNCIONA la redireccion! :(

he copiado el .htaccess que genera cpanel en el home principal (/home/misitio/public_html/.htaccess) y sobreescribido el .htaccess del contenido en ingles en /home/misitio/public_html/en/.htaccess y sigue sin redireccionar :S

en resumen no funciona redireccionar lo siguiente:

www.site.com/en/contact.html --------> www.site.com.mx/en/contact.html

eso NO funciona :S

alguna sugerencia??

Etiquetas: nivel, rewriterule
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:17.