Foros del Web » Creando para Internet » Diseño web »

No muestra imagenes Pagina web

Estas en el tema de No muestra imagenes Pagina web en el foro de Diseño web en Foros del Web. Buenas, El dia de hoy tengo un problema con una aplicacion web que tengo hecha en netbeans 6.9 con JSP's y HTML, tengo en mi ...
  #1 (permalink)  
Antiguo 22/07/2011, 12:03
 
Fecha de Ingreso: julio-2010
Mensajes: 23
Antigüedad: 7 años
Puntos: 0
Pregunta No muestra imagenes Pagina web

Buenas,

El dia de hoy tengo un problema con una aplicacion web que tengo hecha en netbeans 6.9 con JSP's y HTML, tengo en mi maquina el servidor TomCat 7.0.14 y funciona bien, creo entonces en mi proyecto web, en el diseño ocupo imagenes *.jpg, y si lo ejecuto desde netbeans corre todo bien, pero cuando monto mi proyecto web en el servidor, copiando la carpeta "web" que esta dentro de "build" en el proyecto web a la carpeta "webApps" de Tomcat y pongo "http://localhost:8080/web/" me ejecuta la web pero no me muestra las imagenes que tengo en el diseño, funciona todo bien excepto las imagenes del diseño, solo me salen los nombres que les doy pero la imagen no se muestra ¿que puedo hacer? ¿que estoy aciendo mal?

De antemano gracias por su respuesta...
  #2 (permalink)  
Antiguo 22/07/2011, 12:53
Avatar de maycolalvarez
Colaborador
 
Fecha de Ingreso: julio-2008
Ubicación: Caracas
Mensajes: 12.120
Antigüedad: 9 años
Puntos: 1530
Respuesta: No muestra imagenes Pagina web

si estás usando rutas absolutas no te aparecerán las imágenes, has de usar rutas relativas
__________________
¡Por favor!: usa el highlight para mostrar código
El que busca, encuentra...
  #3 (permalink)  
Antiguo 23/07/2011, 12:14
 
Fecha de Ingreso: julio-2010
Mensajes: 23
Antigüedad: 7 años
Puntos: 0
Exclamación Respuesta: No muestra imagenes Pagina web

gracias por responder....ammmmm.... mira como mencione antes, en la carpeta de mi proyecto tengo estas carpetas build, dist, nproject, src, test, web entonces en la carpeta web tengo una carpeta "imagenes"donde guardo las imagenes que utilizo en el diseño y estan mis *.jsp y *.html y otras dos carpetas META-INF Y WEB-INF, bien, entonces en las rutas de mis archivos jsp y html utilizo esta ruta:


<img src="imagenes/nombre_de_mi_imagen.jpg" width="1000" height="143" alt="top">

hace un rato leí por ahí que tal vez es por que el nombre de mis imágenes contiene "ñ" pero no lo e probado....


Gracias por tu respuesta...

Etiquetas: diseño, html, imagenes, muestra
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:30.