Foros del Web » Creando para Internet » Diseño web »

un par de dudas basicas

Estas en el tema de un par de dudas basicas en el foro de Diseño web en Foros del Web. bueno para empezar acabo de terminar mi primera pagina web y ya la tngo colgada www.murrenmurkina.com (esta en finlandes conq.... no la entiendo ni yo ...
  #1 (permalink)  
Antiguo 22/04/2008, 04:16
 
Fecha de Ingreso: diciembre-2007
Mensajes: 210
Antigüedad: 10 años
Puntos: 3
un par de dudas basicas

bueno para empezar acabo de terminar mi primera pagina web y ya la tngo colgada www.murrenmurkina.com (esta en finlandes conq.... no la entiendo ni yo jeje) bueno mis dudas son:
-Eso del doctype es fundamental? es q yo no lo tngo y si es fundamental x favor como q pongo en el?
-xq no me valida el xhtml? x el doctype? ya que el css esta falidado y solo no me valida lo del el scroll y lo entiendo xq es internet explorer codec como kien dice.
-lo siento pero se me enpiezan a ocurrir mas ya no sera un par solo XD,- os gusta el diseno? es q soy super amateur jjeje y mierda se me ha olvidaqde la otra pregunta con mi memoria de moskito. bueno no pasa nada las preguntare cuando tenga respuestas de estas.
lo siento x mi incopeteencia pero.......ESTOY APRENDIENDO!!
GRACIAS DE ANTEMANO AL QUE CONTESTE
  #2 (permalink)  
Antiguo 22/04/2008, 09:41
 
Fecha de Ingreso: octubre-2006
Ubicación: Murcia - España
Mensajes: 336
Antigüedad: 11 años, 1 mes
Puntos: 6
Re: un par de dudas basicas

Acabo de ver el código fuente de tu página y si que tienes puesto el doctype.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Si el xhtml no te valida es porque tienes bastantes errores. He visto que te falta cerrar algunas cosas correctamente como las imágenes y algún que otro tag.

También has repetido la etiqueta html un par de veces.

El diseño no es que sea la leche, pero para el nivel que dices tener tampoco lo veo feo.

Un sugerencia, leete unos manuales de css y mejora esa maquetación ;)
  #3 (permalink)  
Antiguo 22/04/2008, 09:46
Avatar de Eleazan  
Fecha de Ingreso: abril-2008
Ubicación: Ibiza
Mensajes: 1.879
Antigüedad: 9 años, 8 meses
Puntos: 325
Re: un par de dudas basicas

Te falta poner el encode o.O (charset)


en mi caso es:
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

Pero yo uso HTML 4.01 transitional..... no sé como será con xhtml :)
  #4 (permalink)  
Antiguo 22/04/2008, 17:15
 
Fecha de Ingreso: diciembre-2007
Mensajes: 210
Antigüedad: 10 años
Puntos: 3
gracias

eeemmm pues si si q tenia un doctype jiji pero solo en la primera pagina sorry and thanks (pero es que las demas estan con include so... solo deberia ponerlo en la primera pagina???)
mmm lo de varios <html> ¿sera xq los incluyo con php? y solo deberia incluir lo q seria a partir del body?
y otra pregunta mas y ya me callo es html xhtml o que carajo es(con prdon)?? es q tampoco se muy bien la diferencia, entendia q xhtml es cuando es con css sino era html(lo siento por mi ignorancia un cursito de xhtml y css en finlandes sin entender una polla no da para mucho )

joder mecago en la mar mas preguntas , como cierro las imagenes?
y gracias EOURUS si te ha gustado la web ya me he leido algunos manualitos de desarrollosweb.com pero bueno segire leyendo ya q me gusta este mundillo mas que el de desarrollar softwares o ewso parece y x cierto lo del charset????? agradeceria cualkiera de las rewspuestas posibles jeje ya xq son muchas no espero todas de un tiron y de camino en cuanto tnga tiempo le preguntare a sangoogle q me ayuda mucho

GRACIAS Eleazan Y Eourus x todo!!!!!
  #5 (permalink)  
Antiguo 24/04/2008, 17:11
 
Fecha de Ingreso: diciembre-2007
Mensajes: 210
Antigüedad: 10 años
Puntos: 3
Re: un par de dudas basicas

ola por favor una manita con lo mio q seguro q aki los pros sabeis q pasa lo explicare mas claro y mejor, kiero validar mi html pero en l apagina del w3 ni sikiera me la leen no me dicen los fallos ni nada, antes tenia un monton de fallos con eso de varios html y eso pero ya los he corregido por favor me gustaria segir con los estandares pero para eso tengo q saber si lo estoy haciendo bien hasta ahora o no y si es q no q seguramente lo sera pues... corregirlo jiji bueno espero q algien me ayude xq x lo que veo mucha gente lee este post pero no comenta (la verdad yo me he tirado mucho tiempo solo leyendo pero con mi minima experiencia tampoko tenia nada q aportar ni tengo aun creo jejeje)gracias de nuevo al alma caritativa q conteste aunque sea para saludar solo
  #6 (permalink)  
Antiguo 28/04/2008, 07:48
 
Fecha de Ingreso: diciembre-2007
Mensajes: 210
Antigüedad: 10 años
Puntos: 3
Re: un par de dudas basicas

bueno me respondere a mi mismo otra vez aber q pasa. tenia mucho errores pero ahora tngo muchisimos menos y sige sin validarme supongo q mi doctype o mi http-equiv estao mal este segundo no tngo xq nose cual poner y nose si copiar el q me han puesto o q , y ne el doctype nose si es xhtml o html la verdad jejeje www.murenmurkina.com si algien me puede ayudar lo agradeceria mucho porque kiero dar por zanjada ya esta web q es para minovia y empezar otra para mi(haber si algun diita la termino jejeje xq la di x terminada hace un tiempo pero.... q si errores q si no valida la foto de cabecera no cambiaba en opera espero q ahora si....... el favicon no sale en explorer 6 pero en los demas navegadores y en el 7 si mmm... bueno pleaaasseeee ayuda!!!!! q kiero empesar otra web)
  #7 (permalink)  
Antiguo 28/04/2008, 10:17
Avatar de daPhyre
Colaborador
 
Fecha de Ingreso: marzo-2008
Ubicación: [email protected] (Redirects to 127.0.0.1)
Mensajes: 2.404
Antigüedad: 9 años, 9 meses
Puntos: 142
Re: un par de dudas basicas

Parece que tu parte ha sido olvidada. Ya la tuviste que rescatar tres veces del olvido y aun así no te contestan...

bueno, para cerrar una etiqueta en general es así: <p>parrafo</p> (O sea, le pones el / en la contraparte). Para cerrar uno que no tenga contraparte, se hace así:
<br />
<img src"link.jpg" />
(Pon en / al final)

En cuanto a HTML y XHTML, la diferencia es que el segundo es XML+HTML, cosa que aun no es muy usada, al menos yo no lo uso y no me he metido bien en el tema, por lo que quizá prefieras usar HTML 4.0 para validarlo, que es caso lo mismo, pero sin XML, que creo no lo usas tú. No tiene nada que ver con el CSS, pues este se usa desde HTML 2.0 o 3.0, no estoy seguro.

Aun no checo tu página, por lo que no se que más puedas tener, y la verdad no soy un gran experto en el tema. En cuanto al favicon... siempre ha dado problemas, yo tampoco he podido usarlo bien x-x

Suerte! Ojalá alguien más pueda echarte una cuerda más larga para las últimas dudas que tienes.

Editado: Abrí tu página, pero me lanza un error 500 que no la encuentra. Checa si no pasa algo por ahi y ya luego le checo de nuevo. Suerte.
__________________
<signs>daPhyre</signs>
Jugaa.me


Adios al dolor de cabeza de IE...
  #8 (permalink)  
Antiguo 30/04/2008, 06:28
 
Fecha de Ingreso: diciembre-2007
Mensajes: 210
Antigüedad: 10 años
Puntos: 3
Re: un par de dudas basicas

yaya gracias ya me valida ahora aki esta la duda:
http://www.forosdelweb.com/f53/cierre-div-maligno-580899/

metete ahi veras eso si q es un fallo q aun nadie sabe el porque
gracias de antemano
  #9 (permalink)  
Antiguo 30/04/2008, 09:29
Avatar de daPhyre
Colaborador
 
Fecha de Ingreso: marzo-2008
Ubicación: [email protected] (Redirects to 127.0.0.1)
Mensajes: 2.404
Antigüedad: 9 años, 9 meses
Puntos: 142
Re: un par de dudas basicas

Yo ya he estado ahi... El cuadro es una imagen, ¿No? ¿No sería mejor usar el DIV con un border a su rededor?
__________________
<signs>daPhyre</signs>
Jugaa.me


Adios al dolor de cabeza de IE...
  #10 (permalink)  
Antiguo 01/05/2008, 08:31
 
Fecha de Ingreso: diciembre-2007
Mensajes: 210
Antigüedad: 10 años
Puntos: 3
Re: un par de dudas basicas

el cuadro de los menus? bueno submenus? no no es una imagen es un div lo que pasa que es de tamaño fijoy tampoko me interesa cambiarlo xq como ver aki http://localhost/NEW%20MURREN/index.php?opc=tuotteet si se hace mas grande le menu se come al perro jjejej y no quedaria bonito no? bueno muchas gracia por visitar el </div> maligno q por cierto sigue sin tener solucion
thanks.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:18.