Foros del Web » Creando para Internet » Diseño web »

Pequeño "descuadre" cuando uso el tag <a>

Estas en el tema de Pequeño "descuadre" cuando uso el tag <a> en el foro de Diseño web en Foros del Web. Hola a todos, Tengo el siguiente problema: Tengo una cabecera de mi web en la que tengo imágenes que enlazan con las distintas páginas de ...
  #1 (permalink)  
Antiguo 16/06/2009, 05:36
 
Fecha de Ingreso: octubre-2007
Mensajes: 16
Antigüedad: 10 años, 2 meses
Puntos: 1
Pequeño "descuadre" cuando uso el tag <a>

Hola a todos,

Tengo el siguiente problema: Tengo una cabecera de mi web en la que tengo imágenes que enlazan con las distintas páginas de mi sitio. El problema es que tengo las imágenes totalmente ajustadas a una tabla, para guardar un formato visualmente, pero cuando le pongo los enlaces, hacen que las imágenes me "suban" un poco, por lo que hay una mínima separación entre la imagen y el final de la tabla, pero se nota mucho porque son colores muy diferentes.

Mi código es algo así:

<table border="0" cellspacing="0" cellpadding="0" valign="bottom">
<tr>
<td>
<a href="javascript:nuevo();" style="text-decoration:none;border: 0px; ">
<img src='im1.gif' border="0">
</a>
</td>
<td>
<a href="javascript:viejo();" style="text-decoration:none;border: 0px; ">
<img src='im2.gif' border="0">
</a>
</td>
</tr>
</table>

Si quito el enlace y dejo sólo las imágenes me sale perfectamente, pero al ponerle los enlaces hacen que mi imágenes tengan una pequeña separación dentro de la celta.

Espero haberme explicado... Gracias y un saludo.
  #2 (permalink)  
Antiguo 16/06/2009, 06:08
Avatar de hades87  
Fecha de Ingreso: diciembre-2007
Ubicación: Barcelona - España
Mensajes: 3.194
Antigüedad: 10 años
Puntos: 68
Respuesta: Pequeño "descuadre" cuando uso el tag <a>

puedes ponerles un margin:0, para evitar esa separación o hacer bien las cosas y diseñar con HTML y CSS.
__________________
No diseñes usando tablas.
  #3 (permalink)  
Antiguo 16/06/2009, 06:39
 
Fecha de Ingreso: octubre-2007
Mensajes: 16
Antigüedad: 10 años, 2 meses
Puntos: 1
Respuesta: Pequeño "descuadre" cuando uso el tag <a>

Hola y gracias por responder.

Programo con HTML y CSS, pero en este caso concretamente me interesa que no haya separación, no en los demás, así que pongo el estilo directamente.

He probado a ponerle margin:0 en el estilo del tag <a>, pero no obtengo ninguna diferencia.

¿Alguna otra idea? Gracias.
  #4 (permalink)  
Antiguo 16/06/2009, 06:41
Avatar de hades87  
Fecha de Ingreso: diciembre-2007
Ubicación: Barcelona - España
Mensajes: 3.194
Antigüedad: 10 años
Puntos: 68
Respuesta: Pequeño "descuadre" cuando uso el tag <a>

Y si pruebas a ponérselo a la tabla. Con lo que decía de html y css es a NO USAR TABLAS para maqueatar una web y usar divs.
__________________
No diseñes usando tablas.
  #5 (permalink)  
Antiguo 16/06/2009, 06:56
 
Fecha de Ingreso: octubre-2007
Mensajes: 16
Antigüedad: 10 años, 2 meses
Puntos: 1
Respuesta: Pequeño "descuadre" cuando uso el tag <a>

Ah vale, tengo que usar tablas forzosamente, así que no tengo muchas opciones.

He probado a ponérselo a la tabla también y nada, no cambia absolutamente nada.

Gracias por responder tan pronto.
  #6 (permalink)  
Antiguo 16/06/2009, 07:30
Colaborador
 
Fecha de Ingreso: junio-2007
Mensajes: 5.798
Antigüedad: 10 años, 6 meses
Puntos: 538
Respuesta: Pequeño "descuadre" cuando uso el tag <a>

Sin código css es aventurar, pero quizás un "line-height" o ""vertical-align"
Porque supongo que tienes algún tipo de "reset" en tu css (* {margin:0, padding:0; position: relative;"} y utilizas un DOCTYPE válido.
__________________
Por una web con mucho estilo
+++ CUENTA ABANDONADA. ¿la quieres? +++
  #7 (permalink)  
Antiguo 16/06/2009, 08:01
 
Fecha de Ingreso: octubre-2007
Mensajes: 16
Antigüedad: 10 años, 2 meses
Puntos: 1
Respuesta: Pequeño "descuadre" cuando uso el tag <a>

Pues sí, he probado con line-height:0 (en el tag <a>) y ya sí me lo alinea como yo quiero.

Gracias por vuestra ayuda.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:26.