Foros del Web » Creando para Internet » Diseño web »

Porque me da error una de estas formas?

Estas en el tema de Porque me da error una de estas formas? en el foro de Diseño web en Foros del Web. Hola, Tengo un mar de dudas, estoy diseñando una pagina que me la tiene que generar un script cgi en perl. Basicamente la duda es ...
  #1 (permalink)  
Antiguo 18/11/2009, 11:59
 
Fecha de Ingreso: noviembre-2005
Mensajes: 32
Antigüedad: 12 años
Puntos: 0
Porque me da error una de estas formas?

Hola,

Tengo un mar de dudas, estoy diseñando una pagina que me la tiene que generar un script cgi en perl. Basicamente la duda es que la pagina de una forma no me larga error en iexplorer (lo que sigue es de un archivo html puro):

Cita:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<HTML>
<HEAD>
<TITLE></TITLE>
<META NAME="Generator" CONTENT="TextPad 4.6">
<META NAME="Author" CONTENT="?">
<META NAME="Keywords" CONTENT="?">
<META NAME="Description" CONTENT="?">
</HEAD>

<BODY BGCOLOR="#FFFFFF" TEXT="#000000" LINK="#FF0000" VLINK="#800000" ALINK="#FF00FF" BACKGROUND="?">
<legend>Foto n° 1</legend>
<form action="scripts/ajaxupload.php?filename=name&maxSize=9999999999&ma xW=200&fullPath=$folder/&relPath=$dir/&colorR=255&colorG=255&colorB=255&maxH=300" method="post">
<p><input type="file" name="name" onchange="ajaxUpload(this.form,'scripts/ajaxupload.php?filename=name&maxSize=9999999999&ma xW=500&fullPath=$folder/&relPath=$dir/&colorR=255&colorG=255&colorB=255&maxH=500&F=1','u pload_area1','Subiendo archivo.<BR> Espere por favor...<BR><img src=\'images/progress.gif\' width=\'16\' height=\'16\' vspace=\'40\' border=\'0\' >','<img src=\'images/error.gif\' width=\'16\' height=\'16\' border=\'0\' > Error in Upload, check settings and path info in source code.'); return false;" /></p>
<noscript><p><button type="submit">Subir imagen</button></p></noscript>
</form><BR><BR><BR>
</BODY>
</HTML>
pero si lo larga en esta otra (aclaro, esta es generada en el cgi escrito en perl):

Cita:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<HTML>
<HEAD>
<TITLE></TITLE>
<META NAME="Generator" CONTENT="TextPad 4.6">
<META NAME="Author" CONTENT="?">
<META NAME="Keywords" CONTENT="?">
<META NAME="Description" CONTENT="?">
</HEAD>

<BODY BGCOLOR="#FFFFFF" TEXT="#000000" LINK="#FF0000" VLINK="#800000" ALINK="#FF00FF" BACKGROUND="?">
<fieldset>
<legend>Foto n° 1</legend>
<form action="scripts/ajaxupload.php?filename=name&maxSize=9999999999&ma xW=200&fullPath=/Imagenes/RN/&relPath=C:\Jana2\html\Imagenes\RN/&colorR=255&colorG=255&colorB=255&maxH=300" method="post">
<p><input type="file" name="name" onchange="ajaxUpload(this.form,'scripts/ajaxupload.php?filename=name&maxSize=9999999999&ma xW=500&fullPath=/Imagenes/RN/&relPath=C:\Jana2\html\Imagenes\RN/&colorR=255&colorG=255&colorB=255&maxH=500&F=1','u pload_area1','Subiendo archivo.<BR> Espere por favor...<BR><img src='images/progress.gif' width='16' height='16' vspace='40' border='0' >','<img src='images/error.gif' width='16' height='16' border='0' > Error in Upload, check settings and path info in source code.'); return false;" /></p>
<noscript><p><button type="submit">Subir imagen</button></p></noscript>
</form>
</fieldset><BR><BR><BR>
</BODY>
</HTML>
Parece que al tirarme la pagina, el cgi me modifica algunas cosas, pero no se exactamente que es lo que le afecta al codigo html para que me tire un error en la barra de estado del tipo:
Se esperaba ')'

cuando veo que el parentesis de cierre existe en los dos casos

Gracias por las ayudas
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:08.