Foros del Web » Creando para Internet » Diseño web »

Porque W3C no me valída mi stio?

Estas en el tema de Porque W3C no me valída mi stio? en el foro de Diseño web en Foros del Web. Buenas tardes. Yo diseñe mi nueva Web y deseo validar mi sitio pero no logro hacerlo, me sale este error y la verdad no veo ...
  #1 (permalink)  
Antiguo 27/09/2007, 13:58
Avatar de ceaped  
Fecha de Ingreso: febrero-2004
Mensajes: 2.078
Antigüedad: 13 años, 10 meses
Puntos: 9
Pregunta Porque W3C no me valída mi stio?

Buenas tardes.

Yo diseñe mi nueva Web y deseo validar mi sitio pero no logro hacerlo, me sale este error y la verdad no veo nada malo:

Validation Output: 1 Error
Line 35, Column 26: there is no attribute "height".
<table width="500" height="500" align="center">✉
You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.


Si me peden ayudar y decirme que es o que puedo hacer.

Otra pregunta, luego de validar el sitio que se debe hacer para colocar que el sitio está validado?.

Gracias por su ayuda
__________________
Diseñador Gráfico publicitario
  #2 (permalink)  
Antiguo 27/09/2007, 14:41
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Re: Porque W3C no me valída mi stio?

podriamos ver la URL del sitio y así poder decirte porque no te valida.
  #3 (permalink)  
Antiguo 27/09/2007, 15:40
Avatar de ceaped  
Fecha de Ingreso: febrero-2004
Mensajes: 2.078
Antigüedad: 13 años, 10 meses
Puntos: 9
Re: Porque W3C no me valída mi stio?

Hola DragonX. Gracias por tu interés. Claro mi URL es:

http://www.mascreatividad.net
__________________
Diseñador Gráfico publicitario
  #4 (permalink)  
Antiguo 27/09/2007, 15:56
Avatar de JavierB
Colaborador
 
Fecha de Ingreso: febrero-2002
Ubicación: Madrid
Mensajes: 25.052
Antigüedad: 15 años, 9 meses
Puntos: 771
Re: Porque W3C no me valída mi stio?

Hola ceaped

Prueba usando Css:

<table style="width:500px; height:500px">

Saludos,
  #5 (permalink)  
Antiguo 28/09/2007, 07:08
Avatar de ceaped  
Fecha de Ingreso: febrero-2004
Mensajes: 2.078
Antigüedad: 13 años, 10 meses
Puntos: 9
Re: Porque W3C no me valída mi stio?

Holass.

Ya hice lo que dijiste y ok.
Me esta saliendo otro error (utf-8).
Yo pongo en la opción "Encoding=iso-8859-1" y me la valida pero saliendome el mismo erro utf-8.

Que dobo hacer para arreglar esto?
Y cuando sea validada yo como pongo ese famoso icono en mi sitio que diga que esta validada?

Gracias por su ayuda
__________________
Diseñador Gráfico publicitario
  #6 (permalink)  
Antiguo 28/09/2007, 15:29
Avatar de ceaped  
Fecha de Ingreso: febrero-2004
Mensajes: 2.078
Antigüedad: 13 años, 10 meses
Puntos: 9
Re: Porque W3C no me valída mi stio?

Hola descubrí que era lo que no me permitía validar mi sitio.
Era unos comentarios que tenía al inicio de ella...por eso me salía un error utf-8....el cual no se porque.

Tenía esto al comienzo:

<!-- + + + + + + + + + + + + + + + + -->
<!-- comentarios -->
<!-- mas comentarios -->
<!-- mas comentarios -->
<!-- mas comentarios -->
<!-- + + + + + + + + + + + + + + + + -->

Porque si son comentarios no los lee el validador?
__________________
Diseñador Gráfico publicitario
  #7 (permalink)  
Antiguo 30/09/2007, 02:03
 
Fecha de Ingreso: septiembre-2007
Mensajes: 184
Antigüedad: 10 años, 2 meses
Puntos: 4
Re: Porque W3C no me valída mi stio?

Cita:
Iniciado por ceaped Ver Mensaje
Hola descubrí que era lo que no me permitía validar mi sitio.
Era unos comentarios que tenía al inicio de ella...por eso me salía un error utf-8....el cual no se porque.

Tenía esto al comienzo:

<!-- + + + + + + + + + + + + + + + + -->
<!-- comentarios -->
<!-- mas comentarios -->
<!-- mas comentarios -->
<!-- mas comentarios -->
<!-- + + + + + + + + + + + + + + + + -->

Porque si son comentarios no los lee el validador?
Los comentarios nunca deben ir al principio de la página, antes de lo que es la declaración DOCTYPE, ya que puede traer problemas de renderización, puede entrar tu página en modo quirk, y según el tipo de htlm o xhtlm que uses no podrás validarla.

Usa los comentarios en otro sitio, lo primero que debe leer un navegador o un validador es el DOCTYPE, así te ahorraras esos problemas.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:19.