Foros del Web » Creando para Internet » Diseño web »

Probelma con scroll en servidor

Estas en el tema de Probelma con scroll en servidor en el foro de Diseño web en Foros del Web. Buenas, escribo por .... bueno, cosas raras a mas no poder, que me traen frito. Tengo instalado el pack Appserv (con apache, php 6 y ...
  #1 (permalink)  
Antiguo 02/10/2008, 10:50
 
Fecha de Ingreso: septiembre-2008
Mensajes: 3
Antigüedad: 9 años, 2 meses
Puntos: 0
Probelma con scroll en servidor

Buenas, escribo por .... bueno, cosas raras a mas no poder, que me traen frito.

Tengo instalado el pack Appserv (con apache, php 6 y mysql).

Cree unas webs con el dreamweaver, y para poder verlas, luego lasabro con el firefox y/o el IE.

Problema: En el servidor local los scrolls que tienen mi paginas (scrolls personalizados, los hizo un amigo) se ven y funcionan perfectamente, pero al subir la informacion al servidor, abres la pagina y !!sorpresa¡¡¡ todo esta perfecto, excepto que los scrolls no son mas que una bonita decoracion, porque no se mueven ni se puede mover el contenido de la pagina para ver el final.


Alguien sabe a que puede derbse eso por favor?¿ :S porque lo veo perectamente en el localhost y en interneet nada de nada?¿

Gracias por vuestro tiempo :)
  #2 (permalink)  
Antiguo 02/10/2008, 10:53
Avatar de skatomundo  
Fecha de Ingreso: junio-2002
Ubicación: Santiago - CL
Mensajes: 2.532
Antigüedad: 15 años, 5 meses
Puntos: 125
Respuesta: Probelma con scroll en servidor

Hola,

Podríamos ver aquella web o algún enlace para ver algo de los scroll y chequear el código.

saludos,
  #3 (permalink)  
Antiguo 02/10/2008, 11:12
 
Fecha de Ingreso: septiembre-2008
Mensajes: 3
Antigüedad: 9 años, 2 meses
Puntos: 0
Respuesta: Probelma con scroll en servidor

Perdon jeje se me olvido poner los enlaces:

Esta es la web: http://www.washback.es

La pagina una arquitectura modular (separa la web en partes mas manejables)

TODAS las paginas que constituyen la web, tienen este codigo al final, el pie de pagina
</div>
<?php include("inc/bowob_scroll.php"); ?>
</div>
<div id="pie">
<a href="http://www.cinic.es/" target="_blank"><div id="pie_enlace"></div></a>
</div>
</div>
</div>
</body>
</html>

Como veis, el pie de pagina llama a la funcion bowob_scroll.php que controla (con otro javascript) el scroll.

En ninguna parte de las paaginas se hace referencia a nada que no este dentro de sus carpetas correspondientes, asi que al cogerlo y moverlo (subirlo al servidor) no deberia haber ningun problema, pero.,.. lo hay, porque en la web no consigo que se mueva el dicoso scroll :S
  #4 (permalink)  
Antiguo 02/10/2008, 12:22
Avatar de skatomundo  
Fecha de Ingreso: junio-2002
Ubicación: Santiago - CL
Mensajes: 2.532
Antigüedad: 15 años, 5 meses
Puntos: 125
Respuesta: Probelma con scroll en servidor

A través de Firebug en FF:

dice lo siguiente:
syntax error
en la función:

function bowob_objeto(objeto)
return document.getElementById(objeto)


puede ser que por eso no funciona...

saludos,
  #5 (permalink)  
Antiguo 02/10/2008, 12:40
 
Fecha de Ingreso: septiembre-2008
Mensajes: 3
Antigüedad: 9 años, 2 meses
Puntos: 0
Respuesta: Probelma con scroll en servidor

Si, aproveche que con el internet explorer te ofrece pasarle un debug a la pagina ( con el debugger que el mismo internet 7 trae) y me marca esa linea....


El problema, es que yo no he tocado para nada el codigo del scroll (ya que no lo hice yo), pero el caso, es que hace poco, mientras acababa los cambios, el scroll SI que funcionaba. la web estaba en una carpeta temporal, hasta que estuviera acabada y pudiera sacarse fuera como dios manda, pero al copiar/pegar para sacar los arvchivos de esa carpeta, el scroll dejo de funcionar.

Porque¿?, pues ni idea, porque las carpetas y subcarpetas han sido mantenidas tal cual, sin cambios, ni siquiera he metido archivos nuevos, o cambiado sus nombres....por eso estoy tan extrañado :s

Pero en fin mirare a ver si encuentro el maldito fallo en el javascript... aunque ya me estoy quedando ciego de tanto mirarlo.

Gracias po la respuesta :), si se os ocurre algo mas avisad xDD.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:17.