Foros del Web » Creando para Internet » Diseño web »

Problema acceder a mi sitio

Estas en el tema de Problema acceder a mi sitio en el foro de Diseño web en Foros del Web. Hola, he implementado una aplicación web que se compone de una base de datos hecha en mysql y una aplicación para usarla hecha en php ...
  #1 (permalink)  
Antiguo 10/09/2007, 12:51
 
Fecha de Ingreso: febrero-2007
Mensajes: 138
Antigüedad: 10 años, 10 meses
Puntos: 0
Problema acceder a mi sitio

Hola, he implementado una aplicación web que se compone de una base de datos hecha en mysql y una aplicación para usarla hecha en php y javascript. He usado un servidor apache y phpMyAdmin para administrar la base de datos. Lo he programado todo con dreamweaver y configuré un sitio en mi portatil para acceder él localmente, es decir, ponía en el navegador http://localhost/miStio/Autentificac...tificacion.php y accedia a la página principal de mi base de datos, y a partir de ahi trabajaba con ella. Pero ahora he instalado todo igual en un servidor y al acceder a mi aplicación pongo (ip del servidor: 172.20.0.200):
http://172.20.0.200/miSitio/Autentif...tificacion.php y al meter un login y un password correcto se me abre directamente http://localhost/miSitio/Autentifica...tificacion.php
y ya después meto otra vez el login y el password y ya sí me accede a la aplicación, pero ese 'paso intermedio' de cambiar la ip del servidor por localhost no sé por qué lo hace.

Además he intentado acceder desde un pc desde una red local al servidor para manejar la aplicación, ya que hay que trabajar así, y me pasa exactamente igual, me cambia la ip por localhost y no me abre nada ¿por qué me pasa esto?

Es la primera aplicación que hago en mi vida y estoy un poco verde, si me pudiérais echar una mano os lo agradeceria.

Muchas gracias, 1 saludo
  #2 (permalink)  
Antiguo 11/09/2007, 07:14
Avatar de bookmaster  
Fecha de Ingreso: febrero-2002
Ubicación: Toledo
Mensajes: 976
Antigüedad: 15 años, 10 meses
Puntos: 67
Re: Problema acceder a mi sitio

Asegurate de que al validar el usuario y ser correcto, no le tengas peusta la ruta absoluta, si es así tendrias que ponerle la ruta relativa.

Ruta absoluta: http://localhost/login
Ruta relativa: /login

Lo mismo es eso que lo tienes puesto en absoluta.
__________________
Decir si te a funcionado la respuesta es ¡GRATIS!. Por favor indicarlo.
http://www.lohacemosweb.net
http://tutoriales.lohacemosweb.net
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:37.