Foros del Web » Creando para Internet » Diseño web »

Problema con acceso a sitio utilizando IP y hostname

Estas en el tema de Problema con acceso a sitio utilizando IP y hostname en el foro de Diseño web en Foros del Web. Buen día. Antes de comentarles mi problema, quisiera felicitar a todos los que hacen posible que esta comunidad nos ayude cuando se nos presenta un ...
  #1 (permalink)  
Antiguo 24/03/2011, 18:13
 
Fecha de Ingreso: marzo-2011
Mensajes: 2
Antigüedad: 6 años, 8 meses
Puntos: 0
Pregunta Problema con acceso a sitio utilizando IP y hostname

Buen día.

Antes de comentarles mi problema, quisiera felicitar a todos los que hacen posible que esta comunidad nos ayude cuando se nos presenta un problema, en varias ocasiones me han sacado d eun buen apuro.

Ahora sí mi problema:

Tengo un sitio en la intranet en el cual, mediante un javascript, abre una nueva ventana que oculta las barras de menu, herramientas, direccion y estatus y funciona correctamente siempre y cuando accese a él mediante el nombre del servidor, esto es con una url del siguiente tipo:

http://miservidor/MySitio/

pero si acceso a él utilizando la IP (que es como debe de hacerlo por normas de la institución) no oculta nada, por ejemplo

http://172.1.1.1/MySitio/

El codigo con el que hago esto es el siguiente:

Código:
window.open('principal.asp', '_blank', 'location=no,menubar=no,status=no,toolbar=no,directories=no,top=0,left=0,height=' + window.screen.height  + ',width=' + window.screen.width  + ',scrollbars=1,toolbar=no,resizable=yes', true);
Alguien podría darme alguna pista de por que sucede??? Hay algo que se pueda hacer???

De antemano, les agradezco mucho su atención
  #2 (permalink)  
Antiguo 24/03/2011, 20:30
Avatar de maycolalvarez
Colaborador
 
Fecha de Ingreso: julio-2008
Ubicación: Caracas
Mensajes: 12.120
Antigüedad: 9 años, 4 meses
Puntos: 1530
Respuesta: Problema con acceso a sitio utilizando IP y hostname

predeterminadamente en casi todos los OS el 127.1.1.1 está registrado como el host local, para averiguar la ip del servidor necesitas ejecutar desde el mismo en el terminal ipconfig (windows) o ifconfig (*NIX - GNU/Linux)
__________________
¡Por favor!: usa el highlight para mostrar código
El que busca, encuentra...

Última edición por maycolalvarez; 25/03/2011 a las 14:00 Razón: corregido. 172 a 127
  #3 (permalink)  
Antiguo 25/03/2011, 12:04
 
Fecha de Ingreso: marzo-2011
Mensajes: 2
Antigüedad: 6 años, 8 meses
Puntos: 0
Respuesta: Problema con acceso a sitio utilizando IP y hostname

Bueno, la ip que puse era solo un ejemplo, no considero apropiado poner la IP correcta. Pero no es la que se identifica como localhost (que segun yo seria la 127.0.01)

Saludos
  #4 (permalink)  
Antiguo 25/03/2011, 13:53
Avatar de maycolalvarez
Colaborador
 
Fecha de Ingreso: julio-2008
Ubicación: Caracas
Mensajes: 12.120
Antigüedad: 9 años, 4 meses
Puntos: 1530
Respuesta: Problema con acceso a sitio utilizando IP y hostname

cierto, no me habia fijado el el 172, sorry, tienes algún proxy en la red?
__________________
¡Por favor!: usa el highlight para mostrar código
El que busca, encuentra...

Etiquetas: hostname, ip
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:36.