Foros del Web » Creando para Internet » Diseño web »

Problema con HotLink y reproductor FLV en Firefox

Estas en el tema de Problema con HotLink y reproductor FLV en Firefox en el foro de Diseño web en Foros del Web. Saludos amigos tengo un pequeño problema a ver si pueden ayudarme. Estoy integrando un reproductor FLV en mi Web ( JW FLV MEDIA PLAYER ) ...
  #1 (permalink)  
Antiguo 06/11/2008, 18:32
Avatar de David_dfd  
Fecha de Ingreso: febrero-2005
Ubicación: Tenerife
Mensajes: 311
Antigüedad: 12 años, 9 meses
Puntos: 2
Problema con HotLink y reproductor FLV en Firefox

Saludos amigos tengo un pequeño problema a ver si pueden ayudarme.

Estoy integrando un reproductor FLV en mi Web ( JW FLV MEDIA PLAYER ) y todo perfecto.

Genero el codigo y es el siguiente:

Código PHP:
<script type='text/javascript' src='/embed/swfobject.js'></script>

  <div id='preview'>This div will be replaced</div>

  <script type='text/javascript'>
  var s1 = new SWFObject('/embed/player.swf','ply','470','320','9','#ffffff');
  s1.addParam('allowfullscreen','true');
  s1.addParam('allowscriptaccess','always');
  s1.addParam('wmode','opaque');
  s1.addParam('flashvars','file=http://content.bitsontherun.com/videos/qyehIiBT.flv&image=http://content.bitsontherun.com/thumbs/qyehIiBT.jpg&controlbar=over&duration=34&fullscreen=true&stretching=fill');
  s1.write('preview');
</script> 
El tema es que yo los .FLV los quiero alojar en mi servidor, entonces cambio la ruta a mi servidor y listo. Pero el fallo esta en cuando activo Hotlink para evitar que usen estos FLV desde otra web.

En Internet Explorer no me da problemas, pero en firefox sale el reproductor pero jamas carga el video.

Se que este es el fallo porque he eliminado el hotlink y funciona en firefox tambien.

El codigo que incluyo en el .htaccess para el Hotlink es el siguiente:

Código:
RewriteEngine on
RewriteCond %{HTTP_REFERER} !^http://dominio.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://dominio.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.dominio.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.dominio.com$ [NC]
RewriteRule .*\.(flv|swf)$ http://www.dominio.com/HotLink.html [R,NC]
Necesito usar el Hotlink porque ya lo he quitado y otras webs usan mis archivos, por lo que no puedo quitar esta "proteccion".

¿¿Alguien puede ayudarme?? Muchas gracias.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:25.