Foros del Web » Creando para Internet » Diseño web »

Problema con IE

Estas en el tema de Problema con IE en el foro de Diseño web en Foros del Web. Buenas, estoy haciendo una web en php y tengo problemas con Internet Explorer. En mozilla me funciona pefecta, pero en IE, el texto se me ...
  #1 (permalink)  
Antiguo 23/07/2008, 06:43
 
Fecha de Ingreso: mayo-2008
Mensajes: 117
Antigüedad: 9 años, 6 meses
Puntos: 0
Exclamación Problema con IE

Buenas, estoy haciendo una web en php y tengo problemas con Internet Explorer. En mozilla me funciona pefecta, pero en IE, el texto se me pone a la derecham, mientras que en mozilla, se queda perfecto debajo del Header.

Tabajo con CSS, así que no entiendo pel problema. Seá poque llamo al header con includes?

Alguien me puede ayudar?

Gracias!
  #2 (permalink)  
Antiguo 23/07/2008, 07:33
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Respuesta: Problema con IE

podríamos ver tu página o en su defecto el código?
  #3 (permalink)  
Antiguo 23/07/2008, 08:09
 
Fecha de Ingreso: mayo-2008
Mensajes: 117
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: Problema con IE

Cita:
Iniciado por DragonX Ver Mensaje
podríamos ver tu página o en su defecto el código?
La página es esta:

Código:
http://www.dibuenosdias.es/choco/
  #4 (permalink)  
Antiguo 23/07/2008, 08:19
Avatar de DragonX
Colaborador
 
Fecha de Ingreso: mayo-2002
Ubicación: Funkyland
Mensajes: 8.339
Antigüedad: 15 años, 6 meses
Puntos: 153
Respuesta: Problema con IE

tenes tres columnas, dos de ellas con un width:195px y otra con width:140px explorer siempre tiene conflictos con las medidas, probá haciendo las dos primeras de (por decir algo) 180px y fijate!



Edito: Además mira bien tu código que tenes tags duplicados, dos heads, etc....
  #5 (permalink)  
Antiguo 23/07/2008, 08:47
 
Fecha de Ingreso: mayo-2008
Mensajes: 117
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: Problema con IE

Lo primero es que gracias por responder DragonX!

Lo que pasa es que si les cambio el tamaño a las columnas se me descentra todo. Además no hay dos heads, sino solo uno, el que pone <head_body> solo es el inlcude del flash.
  #6 (permalink)  
Antiguo 23/07/2008, 10:55
 
Fecha de Ingreso: febrero-2008
Ubicación: Barcelona
Mensajes: 39
Antigüedad: 9 años, 9 meses
Puntos: 0
Respuesta: Problema con IE

si quieres hacer que todo quede centrado pienso que deberias darle un ancho a la columna como lo hicistes pero colocandole margenes auto, asi ella siempre mantendra el ancho q le des y dejara el resto de la ventana como margen y quedara centrada, por lo menos asi resolvi yo problemas parecidos que tube, espero que te sirva de ayuda.
  #7 (permalink)  
Antiguo 23/07/2008, 12:46
 
Fecha de Ingreso: mayo-2008
Mensajes: 117
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: Problema con IE

Me podrías poner un ejemplo "gnzlo", por favor?

Gracias de antemano
  #8 (permalink)  
Antiguo 23/07/2008, 16:24
 
Fecha de Ingreso: mayo-2008
Mensajes: 117
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: Problema con IE

He pobado lo de poner los maregenes en auto, y también lo de poner los maregenes a 180 pero se queda igual. El problema no es que pasa solo en la página principal sino también en las demás páginas.

Alguien sabe porque??? Además es un problema porque ya la tenía acabada y la iba a entrega y ahora me sucede esto.

Gracias
  #9 (permalink)  
Antiguo 23/07/2008, 17:00
Avatar de Mikmoro
Colaborador
 
Fecha de Ingreso: octubre-2006
Ubicación: K-pax
Mensajes: 7.228
Antigüedad: 11 años, 2 meses
Puntos: 279
Respuesta: Problema con IE

En principio, tal y como te dice DragonX, no debes repetir el DOCTYPE y toda la cabecera del documento. Esto te ocurre porque los includes que estás incrustando son documentos completos con cabecera y todo.

Creo que deberías dejar los documentos que vas a incluir sin cabecera, ni body ni nada, sólo el contenido directamente. Sí te aseguro que IE se vuelve loco con eso. Una vez arreglado, podemos ver con CSS por qué ocurre lo de la columna.

Mikel.
  #10 (permalink)  
Antiguo 23/07/2008, 17:21
 
Fecha de Ingreso: mayo-2008
Mensajes: 117
Antigüedad: 9 años, 6 meses
Puntos: 0
Respuesta: Problema con IE

Al final lo he conseguido!

El problema era del include que hacia referencia con el include. El problema erá que el flash estaba embebido y alineado al centro, jejeje.

Me he pasado media tarde comprobando CSS y al final esulta que ea el flash, QUe claro, como erá el archivo anteior al texto, se quedaba alineado a la derecha.

Gracias a todos!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:39.