Foros del Web » Creando para Internet » Diseño web »

Problema con imágenes en DreamWeaver

Estas en el tema de Problema con imágenes en DreamWeaver en el foro de Diseño web en Foros del Web. Hola!! Tengo un problema gordo con Dreamweaver MX 2004. Cuando inserto una imagen se ve bien, pero al subirla por FTP al servidor del alojamiento, ...
  #1 (permalink)  
Antiguo 01/09/2008, 13:28
 
Fecha de Ingreso: septiembre-2008
Mensajes: 12
Antigüedad: 9 años, 3 meses
Puntos: 0
Problema con imágenes en DreamWeaver

Hola!! Tengo un problema gordo con Dreamweaver MX 2004. Cuando inserto una imagen se ve bien, pero al subirla por FTP al servidor del alojamiento, en el propio programa la imagen de dreamweaver como que desaparece y sale como un cuadrado grisáceo como si fuera un objeto flash. Es extraño, porque esto no me lo hacía antes, y si cierro y vuelvo a abrir sale la imagen, pero al guardar me ocurre lo mismo.

Es horrible, porque ya no puedo subir imágenes a la web, ya que sale como si no existe esa imagen (fondo blanco con cruz roja)

¿Qué puede pasar?

Gracias y un saludo!
  #2 (permalink)  
Antiguo 01/09/2008, 14:02
Avatar de skatomundo  
Fecha de Ingreso: junio-2002
Ubicación: Santiago - CL
Mensajes: 2.532
Antigüedad: 15 años, 5 meses
Puntos: 125
Respuesta: Problema con imágenes en DreamWeaver

Tienes algo de código para verificar como haces la referencia de la imágen.

saludos.
  #3 (permalink)  
Antiguo 01/09/2008, 14:33
 
Fecha de Ingreso: septiembre-2008
Mensajes: 12
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: Problema con imágenes en DreamWeaver

<a href="#" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Boton_Actualidad','','/images/but1r_modificada.gif',1)"><img src="/images/but1_modificada.gif" name="Boton_Actualidad" width="103" height="27" border="0"></a><a href="/Opinion.htm" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Enlace_Opinion','','/images/but1r_opinion.gif',1)"><img src="/images/but1_opinion.gif" name="Enlace_Opinion" width="103" height="27" border="0"></a><a href="/Videos.html" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Enlace_videos','','/images/but1r_videos.gif',1)"><img src="/images/but1_videos.gif" name="Enlace_videos" width="103" height="27" border="0"></a><a href="Formacion.html" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Formacion','','../../images/but1r_formacion.gif',1)"><img src="../../images/but1_formacion.gif" name="Formacion" width="103" height="27" border="0"></a><a href="Juegos.html" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swap

Te pongo todo porque son imágenes similares. Me dan problemas las 2 últimas.
Gracias!
  #4 (permalink)  
Antiguo 01/09/2008, 15:31
Avatar de skatomundo  
Fecha de Ingreso: junio-2002
Ubicación: Santiago - CL
Mensajes: 2.532
Antigüedad: 15 años, 5 meses
Puntos: 125
Respuesta: Problema con imágenes en DreamWeaver

Hola

La ruta de acceso a la imágen:
src="/images/but1_modificada.gif" intenta quitar "/" antes de "images"
quedando así
src="images/but1_modificada.gif"

Lo mismo en la función: MM_swapImage

Código PHP:
<a href="#" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Boton_Actualidad','','images/but1r_modificada.gif',1)"><img src="images/but1_modificada.gif" name="Boton_Actualidad" width="103" height="27" border="0"></a
  #5 (permalink)  
Antiguo 01/09/2008, 15:55
 
Fecha de Ingreso: septiembre-2008
Mensajes: 12
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: Problema con imágenes en DreamWeaver

Hola!! Ya está solucinado: MIL GRACIAS!!! El problema era eso que antes, en las 2 últimas imágenes había un: ../../, y solo he dejado /, y VA DE LUJO!! La próxima vez mirare el código, esque es la primera vez que lo leía (sabía que existía pero usaba el editor gráfico) Muchas gracias!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:26.