Foros del Web » Creando para Internet » Diseño web »

problema con tildes

Estas en el tema de problema con tildes en el foro de Diseño web en Foros del Web. Hola amigos, tengo el siguiente problema con las tildes en uno d emis sitios, y surgio cuando lo migre de servidor. Resulta que tengo un ...
  #1 (permalink)  
Antiguo 02/08/2010, 10:45
Avatar de kalvinman  
Fecha de Ingreso: octubre-2006
Ubicación: Bogota Colombia
Mensajes: 849
Antigüedad: 11 años, 2 meses
Puntos: 22
Pregunta problema con tildes

Hola amigos, tengo el siguiente problema con las tildes en uno d emis sitios, y surgio cuando lo migre de servidor.

Resulta que tengo un Db donde las tablas tienen esta codificacion
latin1_spanish_ci
las tildes me salen asi
"Marà a Clara Bulla"

los archivos .php tienen esta codificacion
charset=Latin1"

que puedo hacer para que se muestren correctamente las tildes en la web????
  #2 (permalink)  
Antiguo 02/08/2010, 20:40
Avatar de juanito1712  
Fecha de Ingreso: mayo-2010
Ubicación: Valencia
Mensajes: 1.108
Antigüedad: 7 años, 7 meses
Puntos: 66
Respuesta: problema con tildes

el mejor arreglo que he encontrado para esto es...

todo en utf-8:

las paginas codificada en utf-8

las tablas en utf8_general_ci

ahora bien...

no podrás usar php my admin por ejemplo para editar la base, pero eso no deberia ser problema en un principio, ya que seguramente la web tendra sus formularios para editar la base de datos, te explico como va esto

guardarias desde un formulario en tu web "María"

en la base de datos se guardaria "Marà a"

pero al recuperar desde otra pagina obtendrias de nuevo "María"


este es el mejor arreglo que he conseguido encontrar para eso

si alguien sabe algo mejor los dos estariamos agradecidos de saberlo

Etiquetas: tildes
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:20.