Foros del Web » Creando para Internet » Diseño web »

problema con tíldes en variábles GET

Estas en el tema de problema con tíldes en variábles GET en el foro de Diseño web en Foros del Web. hola, estoy haciendo una web de noticias y he dejado que los links de las noticias sean de esta forma: www.dominio.com/titulo-de-la-noticia-id con la intencion de ...
  #1 (permalink)  
Antiguo 28/01/2011, 15:48
 
Fecha de Ingreso: septiembre-2009
Mensajes: 306
Antigüedad: 8 años, 3 meses
Puntos: 10
problema con tíldes en variábles GET

hola,
estoy haciendo una web de noticias y he dejado que los links de las noticias sean de esta forma: www.dominio.com/titulo-de-la-noticia-id con la intencion de mejorar el posicionamiento en buscadores, el problemaes cuando el titulo de la noticia lleva alguna tilde, en la barra de vinculos del browser aparece bien el titulo con su tilde, pero cuando quiero recuperar esa variable para buscar la noticia en la base de datos me da un error, por ejemplo si el link incluye la palabra "ilustracíon" el valor de esa palabra en la variable GET es " Ilustración" lo que hace que no encuentre la noticia en la base de datos.

Alguna idea de como puedo solucionar esto?
__________________
Mantente al tanto del acontecer Turistico nacional
Visita el Parque Bicentenario El Salvador
  #2 (permalink)  
Antiguo 28/01/2011, 17:09
Avatar de jomaruro
Colaborador
 
Fecha de Ingreso: junio-2002
Ubicación: Naboo
Mensajes: 5.442
Antigüedad: 15 años, 5 meses
Puntos: 361
Respuesta: problema con tíldes en variábles GET

Hola:

Creo que sería mejor que utilizaras algún lenguaje de programación, como PHP, para sustituir los caracteres "extraños" tipo acentos y ñ para sustituirlos por las vocales sin acentos y las ñ por la n para evitarte problemas.

Saludos.

Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:43.