Foros del Web » Creando para Internet » Diseño web »

Problema al Insertar EasyGallery en HTML [Solucionado]

Estas en el tema de Problema al Insertar EasyGallery en HTML [Solucionado] en el foro de Diseño web en Foros del Web. Hola, estoy desarrollando una web, y me gustó mucho el aspecto de EasyGallery http://wingnut.freitagmorgen.de/ Viendo la galería desde su directorio todo está ok: http://localhost/alu/galeria/EasyGallery.php El ...
  #1 (permalink)  
Antiguo 24/07/2008, 16:23
 
Fecha de Ingreso: mayo-2005
Ubicación: Vimianzo. A Coruña
Mensajes: 230
Antigüedad: 12 años, 6 meses
Puntos: 1
Problema al Insertar EasyGallery en HTML [Solucionado]

Hola, estoy desarrollando una web, y me gustó mucho el aspecto de EasyGallery http://wingnut.freitagmorgen.de/

Viendo la galería desde su directorio todo está ok: http://localhost/alu/galeria/EasyGallery.php

El problema me viene cuando la intento acoplar a mi página, ya que no quedaría bien tener toda la página con su estructura, y que el visitante tuviera que ver la imágenes en una página con un fondo blanco y sin estrucutra...

El problema es que al poner el include de la galería en mi web, tal y como explica el autor en su web:

Código:
<div class="container"> 
 <div class="navigation"><a href="index.html" title="Inicio">Empresa</a><a href="prodPvc.html" title="Empresa">Productos</a><a href="index.html" title="Productos">Galería </a><a href="index.html" title="Galería">Contacto</a>
      <div class="clearer"><span></span></div>
 </div>
 <div class="main">  
 
   <div class="content">
     <h3>Galería de Imágenes</h3>
     <?php include("./galeria/EasyGallery.php"); ?>
   </div>
  <div class="clearer"><span></span></div>
 </div>
</div>
Al hacer esto, las imágenes no hacen ese efecto de aumentar, tal y como se ve en la web del autor, y al pulsar sobre ellas, en vez de cargarse y abrirse en una especie de ventana superpuesta, tipo flash(se puede ver en la web del autor), pues carga la imagen en una ventana con fondo blanco...
Y claro, así la galería pierde todo su "encanto".

Luego he probado a ponerla en un Iframe:

Código:
<div class="container"> 
 <div class="navigation"><a href="index.html" title="Inicio">Empresa</a><a href="prodPvc.html" title="Empresa">Productos</a><a href="index.html" title="Productos">Galería </a><a href="index.html" title="Galería">Contacto</a>
      <div class="clearer"><span></span></div>
 </div>
 <div class="main">  
 
   <div class="content">
     <h3>Galería de Imágenes</h3>
     <iframe src="http://localhost/alu/galeria/EasyGallery.php" width="531" height="500" scrolling="auto" frameborder="0" transparency>
        <p>Texto alternativo para navegadores que no aceptan iframes.</p>
      </iframe>
   </div>
  <div class="clearer"><span></span></div>
 </div>
</div>
Así si que funciona correctamente, pero queda "cutre" ver la galería "ahí adentro", que además cuando se pulsa sobre la imagen, la visualización flash, muestra la imagen muy pequeña por tener que adaptarse al iFrame....

Sabeis porqué puede estar ocurriendo esto??? Porqué no funciona el efecto Zoom y la ventana superpuesta tipo Flash al hacer el include??

Lo que me he fijado, que cuando uso el include, que es cuando falla, al pasar el ratón sobre una de las imágenes, que tendrían que hacer el efecto Zoom, el IE7 muestra en la barrada de notificaciones: Error en la página.
Hago doble clic en la notificación y dice esto:
Línea: 220
Carácter: 5
Error: Argumento no válido
Código: 0
Dirección URL: http://localhost/alu/galeria.php

El caso es que la página galeria.php no tiene más de 64 líneas de código...

He probado también con firefox 2 y 3 tampoco funciona...

Gracias por toda vuestra ayuda!

Un Saludo!

----------------------------------------------------------------------------------------------

He encontrado la solución.
Aunque el autor de la galería, en su web no dice nada de eso, la solución para que funcione el scrip que aument la imagen al pichar sobre ella es:
Agregar esto en el HEAD de la página:
Código:
<script type="text/javascript" language="javascript" src="micarpeta/lytebox/lytebox.js"></script>
<link rel="stylesheet" href="micarpeta/lytebox/lytebox.css" type="text/css" media="screen" />  
 
Y para que funcione el aumente de imagen al pasar el ratón sobre ellas, la página tiene que tener esto:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

Yo tenía esto:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
y no funcionaba...

Gracias y un Saludo!

Última edición por Baldur; 25/07/2008 a las 12:10
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:39.