Foros del Web » Creando para Internet » Diseño web »

Problema al instalar web en servidor

Estas en el tema de Problema al instalar web en servidor en el foro de Diseño web en Foros del Web. Hola, he implementado una aplicación web que se compone de una base de datos hecha en mysql y una aplicación para usarla hecha en php ...
  #1 (permalink)  
Antiguo 10/09/2007, 15:00
 
Fecha de Ingreso: febrero-2007
Mensajes: 138
Antigüedad: 10 años, 10 meses
Puntos: 0
Problema al instalar web en servidor

Hola, he implementado una aplicación web que se compone de una base de datos hecha en mysql y una aplicación para usarla hecha en php y javascript. He usado un servidor apache y phpMyAdmin para administrar la base de datos. Lo he programado todo con dreamweaver y configuré un sitio en mi portatil para acceder él localmente, es decir, ponía en el navegador http://localhost/miSitio/Autentifica...tificacion.php y accedia a la página principal de mi base de datos, y a partir de ahi trabajaba con ella. Pero ahora he instalado todo igual en un servidor y al acceder a mi aplicación pongo (ip del servidor: 172.26.0.200):
http://172.26.0.200/miSitio/Autentif...tificacion.php y al meter un login y un password correcto me sale el warning:

Warning: mysql_connect() [function.mysql-connect]: Host '172.26.0.200' is not allowed to connect to this MySQL server in C:\server\web\miSitio\Otros\conexion.php on line 6

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in C:\server\web\miSitio\Otros\conexion.php on line 9

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in C:\server\web\miSitio\Autentificacion\control.php on line 8
Host '172.26.0.200' is not allowed to connect to this MySQL serve

¿Por qué?

Además he intentado acceder desde un pc desde una red local al servidor para manejar la aplicación, ya que hay que trabajar así, y me pasa exactamente igual, me cambia la ip por localhost y no me abre nada ¿por qué me pasa esto?
  #2 (permalink)  
Antiguo 11/09/2007, 03:07
Avatar de kaninox  
Fecha de Ingreso: septiembre-2005
Ubicación: In my House
Mensajes: 3.591
Antigüedad: 12 años, 3 meses
Puntos: 49
Re: Problema al instalar web en servidor

pues y en el server local 127.0.0.1 pasa lo mismo...
pues es solo error de codigo
linea 6 conexion.php
linea 9 en conexion.php
y 8 en control.php
__________________
Gokuh Salvo al mundo. PUNTO!!!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:34.