Foros del Web » Creando para Internet » Diseño web »

Problema de salida de pagina web

Estas en el tema de Problema de salida de pagina web en el foro de Diseño web en Foros del Web. Hola, Tengo un problema nuevo en mi sitio web que antes no aparecia en el browser de Internet Explorer: Uso algunos script cgi escritos en ...
  #1 (permalink)  
Antiguo 30/12/2009, 17:30
 
Fecha de Ingreso: noviembre-2005
Mensajes: 32
Antigüedad: 12 años
Puntos: 0
Problema de salida de pagina web

Hola,

Tengo un problema nuevo en mi sitio web que antes no aparecia en el browser de Internet Explorer:
Uso algunos script cgi escritos en perl y en una salida tengo que hacer lo siguiente para guardar una modificación de imagen:

print "Content-type: image/pjpeg\n\n";

Bien, luego de este paso de modificación me tiene que mandar una pagina de finalización del procedimiento diciendo que la modificación a concluido y gracias. Por lo tanto tengo que imprimir lo siguiente antes de enviar la pagina modelo html:

print "Content-type: text/html\n\n";

Y el resultado es que me sale la pagina web con todo el codigo en texto plano, pero no puedo dejar de poner antes el print "Content-type: image/pjpeg\n\n"; (con esto se solucionaria) porque no me guardaría la imagen o daria error.
Aclaro, esto antes no ocurria con las viejas versiones de internet explorer y es a partir de la version 8.

Como se podria solucionar eso? o tengo que preguntar a los tecnicos de IExplorer.

Gracias por ayudar.

Luis
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:25.