Foros del Web » Creando para Internet » Diseño web »

problema visualización web al subir a servidor

Estas en el tema de problema visualización web al subir a servidor en el foro de Diseño web en Foros del Web. Hola. Ante todo me disculpo si no es este el foro adecuado, he hecho un par de búsquedas por algún otro, pero no tenía claro ...
  #1 (permalink)  
Antiguo 03/12/2008, 05:12
 
Fecha de Ingreso: marzo-2008
Mensajes: 5
Antigüedad: 9 años, 8 meses
Puntos: 0
problema visualización web al subir a servidor

Hola. Ante todo me disculpo si no es este el foro adecuado, he hecho un par de búsquedas por algún otro, pero no tenía claro dónde preguntar.

El problema es el siguiente: una web que se ve bien en modo local en Explorer (ver
pero no al subirla al servidor en ese navegador (ver http://www.dasotec.es/)

Doy más datos: la web fue creada en un MAc con Rapidweaver y se veia bien en Firefox pero descolocada en Explorer; la he modificado yo en un PC con Dreamweaver hasta que se veia bien en ambos navegadores y le he pasado a la persona que la creó, que tiene menos idea aún que yo ;) los archivos modificados (el index.html y dos archivos .css)
En su MAC ve la web perfectamente en modo local, al igual que yo.
Pero la ha subido al servidor, desde ese MAC, y se vuelve a descolocar.
Desde mi desconocimiento no entiendo porqué en modo local sí y al subir al servidor no.

¿Alguien puede ayudar?
Gracias y un saludo
  #2 (permalink)  
Antiguo 04/12/2008, 13:08
 
Fecha de Ingreso: julio-2008
Mensajes: 39
Antigüedad: 9 años, 5 meses
Puntos: 0
Respuesta: problema visualización web al subir a servidor

[FONT="Georgia"]Postea los css por favor...

1. primero porque tu div que dice con id="gradtop" y id ="topbar"en vez de colocarle width:"3000px" (supongo que es para q se mire a lo largo de la pagina) seria mejor que le dieras una posicion absoluta por ejemplo en tu css, IMPORTANTE tus imagenes son como patterns entonces solo corta un pedazito y que se repita:

Código:
#topbar{
background:"la ruta de tu imagen optimizada" repeat-x;
width:100%; /*esto hace que este en toda la pagina*/
height:16px;
position:absolute;
top:0;
left:0;
z-indez:1;
}
#gradtop{
background:"la ruta de tu imagen optimizada" repeat-x;
height:348px;
width:100%; /*esto hace que este en toda la pagina*/
position:absolute;
top:16px;
left:0;
z-index:2;
}
2. tu container es de 750px.... y tu marco total de aproximadamente 900px ES POR ESO QUE EL DIV SE BAJA y estan colicionando tus reglas de css... deberias revisar mejor, tienes muchos errores... perdona que te lo diga...

3. a contentContainer mejor dale un float right en vez de un margin-left... y luego a tus breadcrumbs dale un clear:right para que quede hasta abajo...

Disculpa que no pueda enumerarte todos los cambios que le deberias hacer pero si es por eso, y firefox (por ser, tan bueno y amigable), hace que tus divs salgan bien, a pesar de todo... :D

Última edición por tunait; 04/12/2008 a las 14:37
  #3 (permalink)  
Antiguo 05/12/2008, 02:35
 
Fecha de Ingreso: marzo-2008
Mensajes: 5
Antigüedad: 9 años, 8 meses
Puntos: 0
Respuesta: problema visualización web al subir a servidor

Hola! Gracias por contestar, sí, imagino que está lleno de errores, ya comenté, el que la hizo tiene menos idea que yo, que tengo poquísima. Me pidió si podía arreglar aunque fuera el hecho de que la foto y el texto que hay debajo bajaban al fondo de la página en Explorer. Ahora repasaré todo eso que dices. Entonces, ¿no es tan raro que se vea bien en local y mal al subirlo??
Saludos
  #4 (permalink)  
Antiguo 05/12/2008, 02:48
 
Fecha de Ingreso: junio-2004
Mensajes: 616
Antigüedad: 13 años, 6 meses
Puntos: 25
Respuesta: problema visualización web al subir a servidor

Cita:
Iniciado por irinamo Ver Mensaje
Hola! Gracias por contestar, sí, imagino que está lleno de errores, ya comenté, el que la hizo tiene menos idea que yo, que tengo poquísima. Me pidió si podía arreglar aunque fuera el hecho de que la foto y el texto que hay debajo bajaban al fondo de la página en Explorer. Ahora repasaré todo eso que dices. Entonces, ¿no es tan raro que se vea bien en local y mal al subirlo??
Saludos
A veces es un simple problema de mayúsculas/minúsculas.

En los servidores, que son UNIX sí son case-sensitive y a lo mejor en local no. Así que si en el código está puesto imagen.jpg y el fichero se llama imagen.JPG no la encuentra. Y esto para para todo: desde CSS, ficheros JavaScript, etc...

Habría que revisar que coinciden los nombres a nivel mayúsculas/minúsculas de los ficheros en el código y en el servidor.

Esta suele ser la causa más frecuente.

Un saludo de,
eContento
__________________
eContento
- Mis artículos, tutoriales y labs
- Mis jsfiddles
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:30.