Foros del Web » Creando para Internet » Diseño web »

Problemas al centrar una tabla en Explorer y Firefox

Estas en el tema de Problemas al centrar una tabla en Explorer y Firefox en el foro de Diseño web en Foros del Web. Hola. Mi problema es que en ocasiones no se me alinean en el mismo punto las capas o tablas dependiendo si se abren con Explorer ...
  #1 (permalink)  
Antiguo 14/02/2007, 09:06
 
Fecha de Ingreso: febrero-2007
Mensajes: 1
Antigüedad: 10 años, 10 meses
Puntos: 0
Problemas al centrar una tabla en Explorer y Firefox

Hola.

Mi problema es que en ocasiones no se me alinean en el mismo punto las capas o tablas dependiendo si se abren con Explorer o Firefox. Intento unificar los márgenes de Body o ajustar el Css pero el error persiste. Para clarificar la cuestión os pongo un ejemplo en el que sí queda correctamente alineado (algo encontrado por casualidad) en los dos navegadores y otro ejemplo en el que no. No veo la diferencia.

- Ejemplo 1: aquí queda todo perfecto, la tabla queda en el mismo punto independientemente del navegador usado. Es una tabla resultante de la partición de una imagen en Image Ready.

<BODY BGCOLOR=#E4E4E4 LEFTMARGIN=0 TOPMARGIN=0 MARGINWIDTH=0 MARGINHEIGHT=0>
<!-- ImageReady Slices (xxxxxxx.psd) -->
<TABLE WIDTH=638 BORDER=0 CELLPADDING=0 CELLSPACING=0 align="center">
<TR>
<TD>
<IMG SRC="Images/index_01.jpg" WIDTH=382 HEIGHT=340 ALT="" /></TD>
<TD>
<IMG SRC="Images/index_02.jpg" WIDTH=256 HEIGHT=340 ALT="" /></TD>
</TR>
<TR>
<TD COLSPAN=2>
<IMG SRC="Images/index_03.jpg" WIDTH=638 HEIGHT=169 ALT="" /></TD>
</TR>
<TR>
<TD COLSPAN=2>
<IMG SRC="Images/index_04.jpg" WIDTH=638 HEIGHT=225 ALT="" /></TD>
</TR>
<TR>
<TD COLSPAN=2>
<IMG SRC="Images/index_05.jpg" WIDTH=638 HEIGHT=145 ALT="" /></TD>
</TR>
</TABLE>
<!-- End ImageReady Slices -->
</BODY>
</HTML>

- Ejemplo 2: es una tabla creada en dreamweaver directamente con una imagen en la única celda que contiene y centrada. Aparentemente tiene los mismos atributos que el ejemplo 1, pero su posición difiere medio centímetro a la derecha entre Explorer y firefox.


<body BGCOLOR=#E4E4E4 LEFTMARGIN=0 TOPMARGIN=0 MARGINWIDTH=0 MARGINHEIGHT=0>
<table width="200" border="0" cellspacing="0" cellpadding="0" align="center">
<tr>
<th scope="col"><img src="file:///C|/Carlos/Chorradas/el_chema_ok.jpg" width="350" height="250" /></th>
</tr>
</table>

</body>
</html>

Si alguien pudiera resolver este misterio (para mí), quedaría enormemente agradecido.

Un saludo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:40.