Foros del Web » Creando para Internet » Diseño web »

¿Problemas de codificación?

Estas en el tema de ¿Problemas de codificación? en el foro de Diseño web en Foros del Web. Hola a todos! Les comento. Tengo un problema y no se exactamente cual. Tengo un sitio donde cada archivo tiene, al parecer, un caracter al ...
  #1 (permalink)  
Antiguo 04/10/2007, 09:36
Avatar de c0lo  
Fecha de Ingreso: julio-2005
Ubicación: Buenos Aires
Mensajes: 281
Antigüedad: 12 años, 4 meses
Puntos: 1
Pregunta ¿Problemas de codificación?

Hola a todos!

Les comento. Tengo un problema y no se exactamente cual.
Tengo un sitio donde cada archivo tiene, al parecer, un caracter al comienzo del documento que me está dando problemas a la hora de validar el html y de visualizarlo en IExplorer, por ejemplo.

En éste ultimo, si veo el código fuente desde el mismo, se nota el caracter (un cuadradito ^^) problemático, cosa que en firefox no sucede, ni influye!
Está claro que el caracter está, porque a la hora de validar mi código, se envia esto antes del doctype y me da error:

Cita:
1. Byte-Order Mark found in UTF-8 File.
The Unicode Byte-Order Mark (BOM) in UTF-8 encoded files is known to cause problems for some text editors and older browsers. You may want to consider avoiding its use until it is better supported.
Cita:
1. Error Line 1, Column 0: character "" not allowed in prolog.
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
Esto me sucede con todos los archivos. Si hago un include en la mitad del código, se nota este caracter también...

Por último les comento que el charset está en utf-8 y los archivos supongo que también . La ñ y los tildes (ñ; á; é; í; ó; ú), se ven perfectamente.

Probé con varios editores ya y no logro resolver nada!! Seguramente me falta saber algo para entender el problema...

Gracias por su ayuda.

Saludos!!
__________________
Nuestro amo juega al esclavo // de esta tierra que es una herida
que se abre todos los días // a pura muerte, a todo gramo.
Violencia es mentir.
  #2 (permalink)  
Antiguo 04/10/2007, 09:50
 
Fecha de Ingreso: diciembre-2003
Mensajes: 1.583
Antigüedad: 14 años
Puntos: 13
Re: ¿Problemas de codificación?

Ese error quiere decir que tu archivo está guardado con una codificación "UTF-8 con BOM". Algunos editores de texto agregan un caracter al principio cuando guardas el archivo de esta forma. Y para peor, algunos navegadores son capaces de interpretar ese caracter y mostrarlo como contenido (explorer por ejemplo).

Lo que tienes que hacer es guardar el archivo como UTF-8 sin BOM (me imagino que tu editor te da esa opción).
__________________
El conocimiento es libre: Movimiento por la Devolución
  #3 (permalink)  
Antiguo 04/10/2007, 10:31
Avatar de c0lo  
Fecha de Ingreso: julio-2005
Ubicación: Buenos Aires
Mensajes: 281
Antigüedad: 12 años, 4 meses
Puntos: 1
Re: ¿Problemas de codificación?

Hola frijolerou, estuve viendo la opción de guardarlo sin BOM y me acordé que el notepad++ tiene eso. En realidad no sé, dice "Mostrar como UTF-8 (sin BOM)". En fin, guardé todos los archivos con eso activado y nada.

¿Qué otro editor tiene esa opción? ¿Para linux cuál puede ser? Para windows también me sirve de momento, necesito arreglarlo lo mas rápido posible!

Muchas gracias!
Saludos!
__________________
Nuestro amo juega al esclavo // de esta tierra que es una herida
que se abre todos los días // a pura muerte, a todo gramo.
Violencia es mentir.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Tema Cerrado




La zona horaria es GMT -6. Ahora son las 19:09.