Foros del Web » Creando para Internet » Diseño web »

Problemas con algunos caracteres

Estas en el tema de Problemas con algunos caracteres en el foro de Diseño web en Foros del Web. Hola estoy programando un sitio web, pero me encuentro con que algunos navegadores no interpretan bien los acentos ni las "ñ" ni "!". ¿a que ...
  #1 (permalink)  
Antiguo 29/07/2008, 06:35
 
Fecha de Ingreso: julio-2008
Mensajes: 15
Antigüedad: 9 años, 5 meses
Puntos: 0
Problemas con algunos caracteres

Hola estoy programando un sitio web, pero me encuentro con que algunos navegadores no interpretan bien los acentos ni las "ñ" ni "!".

¿a que puede deberse? y ¿como se puede solucionar?


Un saludo gracias
  #2 (permalink)  
Antiguo 29/07/2008, 06:55
 
Fecha de Ingreso: junio-2004
Mensajes: 616
Antigüedad: 13 años, 6 meses
Puntos: 25
Respuesta: Problemas con algunos caracteres

Se debe al juego de caracteres.

En HTML debes indicar qué juego de caracteres se debe emplear para leer la web. El navegador, cuando encuentra esa etiqueta, se adapta sólo a dicho juego de caracteres.

En castellano, el típico es ISO-8859-1 aunque ya se recomienda usar UTF-8, pero eso implica que debes tener cuidado en la codificación si escribes directamente en HTML.

Código:
<meta content="text/html; charset=iso-8859-1" http-equiv="Content-Type" />
Otro tema es que puedes usar entidades HTML.

Así, la Ñ se muestra como &Ntilde;
y la ñ se muestra como &ntilde;

Un saludo,
eContento
__________________
eContento
- Mis artículos, tutoriales y labs
- Mis jsfiddles
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:21.