Foros del Web » Creando para Internet » Diseño web »

Problemas con Spry en exploradores

Estas en el tema de Problemas con Spry en exploradores en el foro de Diseño web en Foros del Web. Qué tal? Bueno, acudo a los expertos para ver si me pueden ayudar: hice un menú desplegable, que en Dreamweaver CSS3 se llaman Spry Asset ...
  #1 (permalink)  
Antiguo 04/12/2008, 18:49
Avatar de kmzero  
Fecha de Ingreso: octubre-2008
Mensajes: 43
Antigüedad: 9 años, 2 meses
Puntos: 0
Problemas con Spry en exploradores

Qué tal? Bueno, acudo a los expertos para ver si me pueden ayudar:
hice un menú desplegable, que en Dreamweaver CSS3 se llaman Spry Asset

El código en la página es el siguiente:
En el head, la parte que tiene que ver con esto es:
<!--
@import url("SpryAssets/SpryTabbedPanels.css");
body {
margin-left: 0px;
margin-top: 0px;
}
a:link {
color: #FFFFFF;
}
-->

Para que lo vean en acción es: http://www.englishconnections.com.ar/creators.html

El error en IE dice: "Spry is undefined" y muestra todas las capas superpuestas, en vez de ocultar y permitir la acción del usuario.

En Mozilla, se ve igual, pero no puedo captar cuál es el error......

Gracias por tomarse el tiempo de leer!!
  #2 (permalink)  
Antiguo 05/12/2008, 01:51
 
Fecha de Ingreso: noviembre-2008
Ubicación: Gijón, Asturias
Mensajes: 30
Antigüedad: 9 años, 1 mes
Puntos: 0
Respuesta: Problemas con Spry en exploradores

En principio debe haber una carpeta en el directorio donde está el .html que usa este código que se llame "SpryAssets" y dentro de ella el archivo "SpryTabbedPanels.css". Puede que dicha carpeta o fichero no exista en tu sitio. Compruébalo y nos cuentas. A lo mejor te parece una respuesta muy obvia (típica del servicio técnico de Telecable). La verdad es que no conozco esa tecnología "Spry Asset" de la que hablas. Hala a pasarlo bien
  #3 (permalink)  
Antiguo 09/12/2008, 20:47
Avatar de kmzero  
Fecha de Ingreso: octubre-2008
Mensajes: 43
Antigüedad: 9 años, 2 meses
Puntos: 0
Respuesta: Problemas con Spry en exploradores

Ja ja! gracias igual por la respuesta...Hace bien ver que alguien responde.
Bueno, sí está mi carpeta Spry Asset y los archivos de estilo correspondiente: he subido todo correctamente. El caso es que la primera vez que lo probé funcionó bien y luego, tras los cambios definitivos, nada!! es desesperante!

A lo mejor es un error de mi terminal.... Podría alguien entrar al vínculo que dejé ycomprobar si funciona?
(Spry asset se llama según Adobe Dreamweaver Cs3 los antiguos menúes desplegables)
  #4 (permalink)  
Antiguo 17/12/2008, 12:57
Avatar de kmzero  
Fecha de Ingreso: octubre-2008
Mensajes: 43
Antigüedad: 9 años, 2 meses
Puntos: 0
Respuesta: Problemas con Spry en exploradores

Bueno ya lo resolv÷i:
he aqu÷i el problema: había un código viejo de otro spry que se superponía en el head.....hay que leer con detenimiento el código, siempre es la mejor solución.

saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:58.