Foros del Web » Creando para Internet » Diseño web »

[Resuelto] Problema con htaccess

Estas en el tema de [Resuelto] Problema con htaccess en el foro de Diseño web en Foros del Web. Hola, no se si esto ira aqui, a ver si me pueden ayudar... En el htaccess tengo esto: RewriteRule ^([a-z-]{3,16})$ ./index.php?b=$1 [L,QSA] RewriteRule ^([a-z-]{3,16})/$ ./index.php?a=$1 ...
  #1 (permalink)  
Antiguo 28/08/2009, 20:51
 
Fecha de Ingreso: abril-2008
Mensajes: 61
Antigüedad: 9 años, 8 meses
Puntos: 1
[Resuelto] Problema con htaccess

Hola, no se si esto ira aqui, a ver si me pueden ayudar...

En el htaccess tengo esto:

RewriteRule ^([a-z-]{3,16})$ ./index.php?b=$1 [L,QSA]
RewriteRule ^([a-z-]{3,16})/$ ./index.php?a=$1 [L,QSA]
RewriteRule ^$ ./index.php [L,QSA]

Pero... al ir a /contacto, en el index.php siempre me dice que $_GET['a']='contacto'; cuendo deberia estar vacio (seria _GET['b']='contacto';)
Ademas ahora que me fijo, si pongo /contacto/ me dice que $_GET['a']=1; :S

Llevo desde las 2 y media buscando lo que sucede, probe a cambiar el orden de las lineas tanto en php como en htaccess, fui palabra por palabra pero nah

Que carajo hago mal?

EDITO: Me equivoque de archivo, estaba modificando otro .httacess xD Muy triste :(

Última edición por carlos-; 29/08/2009 a las 00:09 Razón: Resuelto!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:11.