Foros del Web » Creando para Internet » Diseño web »

reviosoin de web

Estas en el tema de reviosoin de web en el foro de Diseño web en Foros del Web. Hola [email protected] Estoy terminando, por fin, la web en la que he estado trabajando bastante tiempo y me surgen varios problemas, pero el qu emás ...
  #1 (permalink)  
Antiguo 23/01/2009, 05:33
 
Fecha de Ingreso: enero-2008
Mensajes: 133
Antigüedad: 9 años, 10 meses
Puntos: 1
reviosoin de web

Hola [email protected]
Estoy terminando, por fin, la web en la que he estado trabajando bastante tiempo y me surgen varios problemas, pero el qu emás me preocupa es el siguiente:
-solo en Firefox,opera,chrome, etc no en IE
en la página de productos y servicios->Exterior e interior hay una presentación de fotos que se llama ligthbox que al cargar queda por detrás del flas que hay justo arriba. no se por que puede ser ya que en las páginas de Hotel NH... y VIVIR sin dormir esa misma presentacion no pasa eso.

a ver si alguien me puede ayudar con este problema.

las paginas son :
http://www.telefonica.net/web2/9esti...s/Exterior.htm
http://www.telefonica.net/web2/9esti...s/interior.htm
http://www.telefonica.net/web2/9esti...inas/VIVIR.htm (en esta tampooc carga el flash y tampoco se porque es)
http://www.telefonica.net/web2/9esti...aginas/NH.html

gracias por vuestro tiempo
  #2 (permalink)  
Antiguo 23/01/2009, 08:02
Avatar de gVenom  
Fecha de Ingreso: julio-2008
Ubicación: Costa Rica
Mensajes: 1.455
Antigüedad: 9 años, 5 meses
Puntos: 53
Respuesta: reviosoin de web

Saludos.

Segun revise tus enlaces, el problema de la página donde no ves el flash es esta línea de código:
Código HTML:
<script src="../../Scripts/AC_RunActiveContent.js" type="text/javascript"></script> 
En tus otras páginas llamas al archivo AC_RunActiveConten.js desde un nivel menos que en este, o sea, cambia esa linea por esta:
Código HTML:
<script src="../Scripts/AC_RunActiveContent.js" type="text/javascript"></script> 
Para el problema de lightbox con flash, la solución a este problema es sencilla, pero primero hay que explicar un poco del funcionamiento del reproductor de flash.
Los diferentes modos
A partir de la versión 6 del reproductor, Macromedia (ahora Adobe) introdujo lo que se le conoce como el wmode, este parámetro le dice al reproductor de que forma pintar el contenido de la película, existen tres modos.

Window es el modo por default, utilizando este modo el reproductor optimiza el dibujado, lamentablemente con este modo seleccionado la animación siempre esta sobre todos los demás objetos del sitio.
Opaque permite el manejo de la propiedad z-index, pasando el control del dibujado al explorador, de esta manera es posible poner elementos sobre las animación flash.
Transparent permite poner transparente el fondo de la película, y a su vez nos permite manipular la pila del orden, se recomienda utilizar el modo anterior a este si no es necesario poner transparencia al fondo de la animación.
La solución
Con esto en mente el código para insertar una película flash que pueda ser manipulada en la pila del orden quedaria de la siguiente manera.
Código HTML:
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="800" height="150" id="banner" align="middle">
    <param name="allowScriptAccess" value="sameDomain" />
    <param name="wmode" value="transparent" />
    <param name="movie" value="wp-content/themes/pulso/images/banner.swf" />
    <param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />
    <embed wmode="transparent" src="wp-content/themes/pulso/images/banner.swf" quality="high" bgcolor="#ffffff" width="800" height="150" name="banner" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object> 
Es importante mencionar que únicamente se le agrega este parámetro al codigo generado por flash.
Código HTML:
<param name="wmode" value="transparent" /> 
Y dentro de la etiqueta <embed> se le agrega esta propiedad
wmode="transparent"
Con esto es suficiente para solucionar este pequeño y molesto bug.

suerte
__________________
"Al que venciere y guardare mis obras hasta el fin, yo le daré autoridad sobre las naciones."
Apocalipsis 2: 26
Servicios para Pymes http://dst.co.cr
  #3 (permalink)  
Antiguo 23/01/2009, 13:35
 
Fecha de Ingreso: enero-2008
Mensajes: 133
Antigüedad: 9 años, 10 meses
Puntos: 1
Respuesta: reviosoin de web

Lo siento amigo pero el wmode no funciona ademas he estado leyendo acerca de este metodo y da muchos problemas con firefox y con rendimiento de la pelicula(relentiza) ver este enlace http://www.dandolachapa.com/2006/10/...o-al-infierno/ parece que adobe no da soluciones para esto...
al final lo he logtrado incrustando el flash comn dreamweaver mx2004 y me ha funcionado a la primera, este es el código:

Cita:
<div id="flash" style="position:absolute; left: 209px; top: 134px; width: 600px; visibility: visible; z-index: 1; overflow: visible;">
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="600" height="138">
<param name="movie" value="../flash/intro_productos_Escena%201.swf" />
<param name="quality" value="high" />
<embed src="../flash/intro_productos_Escena%201.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="600" height="138"></embed>
</object>
</div>
gracias por todo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:07.