Foros del Web » Creando para Internet » Diseño web »

Servidor no descarga archivos correctamente

Estas en el tema de Servidor no descarga archivos correctamente en el foro de Diseño web en Foros del Web. Buenas. Hice una página web de torrents y me ha surgido un problema a la hora de descargar algunos de estos archivos: En Mozilla Firefox, ...
  #1 (permalink)  
Antiguo 29/07/2007, 20:40
 
Fecha de Ingreso: noviembre-2006
Mensajes: 166
Antigüedad: 11 años
Puntos: 4
Pregunta Servidor no descarga archivos correctamente

Buenas.
Hice una página web de torrents y me ha surgido un problema a la hora de descargar algunos de estos archivos:
En Mozilla Firefox, cuando pulso sobre el enlace de descarga, en algunos casos el archivo en vez de descargarse se abre en la misma página, lo cual se llena ésta de código ilegible. El problema, que ocurre con estos archivos en concreto, en servidores de otras web no ocurre.

En esta, la que hice yo, sale el error:
http://www.tustorrents.com/torrents/Spectral.Vs.Generation.%5BMULTI3%5D%5BPS2CD%5D%5BW wW.GamesTorrents.CoM%5D.t3100.torrent

Y en esta otra la descarga se lanza con normalidad:
http://www.gamestorrents.com/torrents_tor/Spectral.Vs.Generation.%5BMULTI3%5D%5BPS2CD%5D%5BW wW.GamesTorrents.CoM%5D.t3100.torrent

¿Pueden decirme el problema por el cual ocurre esto? ¿Puede ser de la configuración de Apache?
  #2 (permalink)  
Antiguo 30/07/2007, 07:42
AlvaroG
Invitado
 
Mensajes: n/a
Puntos:
Re: Servidor no descarga archivos correctamente

Puede ser, sí. Por defecto los archivos desconocidos se mandan como text/plain (texto normal) y por lo tanto el navegador lo interpreta como tal, y lo muestra en la pantalla.

Si tenés acceso al httpd.conf, tenés que agregar una línea como

AddType application/x-bittorrent .torrent

Si no tenés acceso al httpd.conf, tenés 2 opciones:
1.- poner lo mismo en el .htaccess y probar si funciona
2.- poner a los archivos .torrent a que se interpreten como PHP, y hacer que PHP envíe la cabecera
Content-Type: application/x-bittorrent

y luego el contenido del archivo.


Saludos.
  #3 (permalink)  
Antiguo 30/07/2007, 08:02
 
Fecha de Ingreso: noviembre-2006
Mensajes: 166
Antigüedad: 11 años
Puntos: 4
Re: Servidor no descarga archivos correctamente

Gracias alvlin por la respuesta.

Probaré con lo que me has dicho a ver que tal.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:18.