Foros del Web » Creando para Internet » Diseño web »

Tengo un script de video que requiere de PHP CLI, MEncoder, MPlayer, FFMpeg, FLVTool2

Estas en el tema de Tengo un script de video que requiere de PHP CLI, MEncoder, MPlayer, FFMpeg, FLVTool2 en el foro de Diseño web en Foros del Web. ¿Esas librerías son estándar e independientes del servidor? La meta es crear una carpeta que contengas estas librerías para que el script trabaje apropiadamente. Ya ...
  #1 (permalink)  
Antiguo 25/08/2009, 12:10
Avatar de romel_inc  
Fecha de Ingreso: diciembre-2007
Ubicación: Venezuela-monagas
Mensajes: 285
Antigüedad: 10 años
Puntos: 14
Tengo un script de video que requiere de PHP CLI, MEncoder, MPlayer, FFMpeg, FLVTool2

¿Esas librerías son estándar e independientes del servidor?
La meta es crear una carpeta que contengas estas librerías para que el script trabaje apropiadamente.

Ya que como trabajó en xp y el servidor es linux.

Se me presenta la siguiente duda que para cada sistema operativo debo armar un paquete diferente de librerías requeridas por el script.

Lo ideal de esto es que podría usar cualquier hosting. Local y comercial, en cualquier sistema operativo donde estos servidores se ejecuten. Para un script que requiera de estas librerías.
__________________
Lo que se usar (JAVA, Spring MVC, IntelliJ IDEA , GAE, CakePHP, Bootstrap, Underscorejs, jQuery, HTML5, CSS3, JSON, Ajax, Prototype), Aprendiendo a usar Angularjs y Git.
  #2 (permalink)  
Antiguo 25/08/2009, 13:18
Avatar de Triby
Mod on free time
 
Fecha de Ingreso: agosto-2008
Ubicación: $MX->Gto['León'];
Mensajes: 9.741
Antigüedad: 9 años, 4 meses
Puntos: 2113
Respuesta: Tengo un script de video que requiere de PHP CLI, MEncoder, MPlayer, FFMpe

Es muy raro que encuentres un servidor con todos esos programas instalados, a menos que sea dedicado o VPS, principalmente por el consumo de recursos (memoria y procesador) al realizar conversiones y, para garantizar el correcto funcionamiento, lo ideal es realizar la instalacion de cada programa en el equipo donde lo necesites. En Ubuntu la instalacion es casi automatica.
__________________
- León, Guanajuato
- GV-Foto
  #3 (permalink)  
Antiguo 25/08/2009, 16:03
Avatar de romel_inc  
Fecha de Ingreso: diciembre-2007
Ubicación: Venezuela-monagas
Mensajes: 285
Antigüedad: 10 años
Puntos: 14
Respuesta: Tengo un script de video que requiere de PHP CLI, MEncoder, MPlayer, FFMpe

Cita:
Iniciado por Triby Ver Mensaje
Es muy raro que encuentres un servidor con todos esos programas instalados

De hecho conozco uno. Algo económico. http://www.cirtexhosting.com/ que cumple con los requerimientos del script. Pero se paga en dólares. Y para mi sale costoso Ahora.

Y como este proyecto esta verde todavía.

Lo que estoy evaluando es de disponer de una carpeta cuyo contenido este formado por las librerías necesarias. La cual se ubicara junto con el script. Con el fin de independizar el script del hosting.

Y como uso xp para trabajar. Y el servidor esta en linux. Mi duda es si las librerías cambian según el sistema operativo.

Básicamente busco es la base para poder empezar a personalizar el script y necesitó usarlo localmente en mi pc. Ya que según mis investigaciones hay una distribución para linux y otra para win32. Siendo esta ultima muy poco documentada.

Y me confundo. Al armar la carpeta con las librerías.
__________________
Lo que se usar (JAVA, Spring MVC, IntelliJ IDEA , GAE, CakePHP, Bootstrap, Underscorejs, jQuery, HTML5, CSS3, JSON, Ajax, Prototype), Aprendiendo a usar Angularjs y Git.
  #4 (permalink)  
Antiguo 25/08/2009, 16:33
 
Fecha de Ingreso: abril-2009
Mensajes: 371
Antigüedad: 8 años, 7 meses
Puntos: 22
Respuesta: Tengo un script de video que requiere de PHP CLI, MEncoder, MPlayer, FFMpe

si, obviamente

windows usa archivos .dll que tienen formato PE y linux usa .so que tienen formato ELF, ademas de las diferencias que crea el compilador en si

tecnicamente puedes meter esas librerias en una carpeta y llamarlas desde tu codigo, pero dudo mucho que un hosting compartido te deje hacer eso - no soy experto en PHP (hace por lo menos 6 años que no uso php) pero imagino que tendra el concepto de nivel de seguridad de codigo implementado y que por tanto no te dejara

aunque a saber... pruebalo y nos cuentas xD
  #5 (permalink)  
Antiguo 25/08/2009, 18:05
Avatar de romel_inc  
Fecha de Ingreso: diciembre-2007
Ubicación: Venezuela-monagas
Mensajes: 285
Antigüedad: 10 años
Puntos: 14
Respuesta: Tengo un script de video que requiere de PHP CLI, MEncoder, MPlayer, FFMpe

Muchas gracias, era la respuestas que buscaba en cierta forma, también creo lo que dices acerca de que un hosting compartido no me dejaría implementar tal cosa. Pero tampoco pretendo que lo haga. Básicamente solo para pruebas lo intentaría hasta terminar las metas básicas para luego mudarlo al sitio de producción.

Muchas gracias. Amigo. mpeg y Triby
__________________
Lo que se usar (JAVA, Spring MVC, IntelliJ IDEA , GAE, CakePHP, Bootstrap, Underscorejs, jQuery, HTML5, CSS3, JSON, Ajax, Prototype), Aprendiendo a usar Angularjs y Git.
  #6 (permalink)  
Antiguo 25/08/2009, 18:21
 
Fecha de Ingreso: abril-2009
Mensajes: 371
Antigüedad: 8 años, 7 meses
Puntos: 22
Respuesta: Tengo un script de video que requiere de PHP CLI, MEncoder, MPlayer, FFMpe

mirando un poco la documentacion de php puedes encontrar info sobre la funcion dl que permite cargar extensiones de forma dinamica si SAFE_MODE esta desactivado

pero tambien pone que en php5 esta deprecated y que en php6 quitan esa funcion (y creo que para hacer algo similar se necesitara editar el php.ini en php6)
  #7 (permalink)  
Antiguo 26/08/2009, 05:05
Avatar de romel_inc  
Fecha de Ingreso: diciembre-2007
Ubicación: Venezuela-monagas
Mensajes: 285
Antigüedad: 10 años
Puntos: 14
Respuesta: Tengo un script de video que requiere de PHP CLI, MEncoder, MPlayer, FFMpe

En win32 o xp. Las siguientes librerías ffmpeg, FLVTool2, MEncoder, MPlayer. Las agrupe desde:

Ffmpeg
http://ffmpeg.arrozcru.org/builds/
=========================
Win32 Binaries:
ffmpeg-r16537-gpl-static-win32.tar.bz2
ffmpeg-r16537-gpl-shared-win32.tar.bz2
==========================

FLVTool2
http://rubyforge.org/projects/flvtool2/
http://rubyforge.org/frs/?group_id=1096&release_id=9694
===========================
flvtool2-1.0.6.zip
===========================

MPlayer y Mencoder
http://www.mplayerhq.hu/MPlayer/releases/win32/
====================================
MPlayer-mingw32-1.0rc1.zip
====================================

Para PHP CLI

Use http://www.php-cli.com/
=======================
C:\php\php.exe
=======================
Del mismo servidor.

///////////////////////////////////////////////////////////////////////////////////////////////////////////////

Ahora tengo un problema más el cual es de encontrar los codecs correctos para mplayer
El error se muestra a continuación Formats Error (could not find ldd binary)!

Mi duda ahora es que el script este esperando otro tipo de codecs específicamente codecs para linux

Según este masaje el cual hace referencia a los “ldd”
http://lists.mplayerhq.hu/pipermail/...st/055068.html
__________________
Lo que se usar (JAVA, Spring MVC, IntelliJ IDEA , GAE, CakePHP, Bootstrap, Underscorejs, jQuery, HTML5, CSS3, JSON, Ajax, Prototype), Aprendiendo a usar Angularjs y Git.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:01.