Foros del Web » Creando para Internet » Diseño web »

Variables Session en intranet

Estas en el tema de Variables Session en intranet en el foro de Diseño web en Foros del Web. Tengo una web que utiliza variables session donde entre otras cosas se almacena el nombre del usuario tras la validación. La página estubo en internet ...
  #1 (permalink)  
Antiguo 11/08/2008, 06:07
 
Fecha de Ingreso: marzo-2006
Mensajes: 12
Antigüedad: 11 años, 9 meses
Puntos: 0
Variables Session en intranet

Tengo una web que utiliza variables session donde entre otras cosas se almacena el nombre del usuario tras la validación. La página estubo en internet y funciona correctamente. Igualmente ocurria puesto en una intranet. El problema ocurre en que una vez terminada la coloque en el servidor con windows 2003 server y al activar el asesor de contenido en los usuarios ocurre lo siguiente. Si conectan a la copia que esta en internet funciona OK, pero si conectan cpn el IIS en el servidor con W2003 server, una vez que entran las variables session siempre estan con el valor "" con lo que son usuarios invitados y no con su código

Creo que es un problema detectado por Microsoft y la solución que pone es quitar las variables session pero tendría que modificar toda la web. La otra solucion es deshabilitar el asesor de contenido de los pcs pero eso es inviable.

¿ Alguien me puede ayudar con una solución operativa ?

Gracias
  #2 (permalink)  
Antiguo 11/08/2008, 08:58
 
Fecha de Ingreso: marzo-2006
Mensajes: 12
Antigüedad: 11 años, 9 meses
Puntos: 0
Respuesta: Variables Session en intranet

Acabo de encontrar la solución al problema y la escribo por si le puede servir a alguien

El problema no tiene nada que ver con lo que indica microsoft. Es decir, no existe en principio problema para que los pcs tenga habilitado el asesor de contenido con una página web alojada en un IIS en windows 2003 server.

El caso es que yo iniciaba una variable session en un modulo. Luego la modificaba en otro y partir de ahí lo iba leyendo (sin cambiar) en varios modulos. El caso es que una vez que en el modulo segundo lo modificaba me aparecian 2 variables session con el mismo nombre. No se porque pero así era. Y eso en Internet o en IIS en XP iba perfecto. Ahora no la inicio sino que donde antes se modificaba ahora la creo con el valor apropiado y va OK. No lo entiendo mucho pero así es
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:04.