Foros del Web » Administración de webs » Web Hosting » Servidores Dedicados, VPS y colocación »

Actualizar a ultima version de PHP

Estas en el tema de Actualizar a ultima version de PHP en el foro de Servidores Dedicados, VPS y colocación en Foros del Web. Hola amigos, tengo el siguiente problema. Necesito cambiar a una version de PHP 5.3.0 o superior, en estos momentos dispongo de la version 5.2.4-2ubuntu5.12. Tengo ...
  #1 (permalink)  
Antiguo 16/11/2011, 04:36
 
Fecha de Ingreso: mayo-2010
Mensajes: 38
Antigüedad: 4 años, 3 meses
Puntos: 0
Actualizar a ultima version de PHP

Hola amigos,

tengo el siguiente problema. Necesito cambiar a una version de PHP 5.3.0 o superior, en estos momentos dispongo de la version 5.2.4-2ubuntu5.12.
Tengo un servidor VPS, con Ubuntu version ubuntu-8.04-x86 y Plesk v9.5.3.

Alguna idea de como empezar.

Un saludo y gracias!

Última edición por dandarway; 16/11/2011 a las 04:58
  #2 (permalink)  
Antiguo 16/11/2011, 05:08
 
Fecha de Ingreso: junio-2010
Mensajes: 120
Antigüedad: 4 años, 2 meses
Puntos: 4
Respuesta: Actualizar a ultima version de PHP

Hola, haciendo un upgrade a Ubuntu 10.04 LTS te debería actualizar solo a PHP 5.3

# apt-get dist-upgrade
__________________
Servidores VPS SSD : Máxima potencia a precio reducido.
Planes Reseller WHM y cPanel
  #3 (permalink)  
Antiguo 16/11/2011, 05:30
 
Fecha de Ingreso: mayo-2010
Mensajes: 38
Antigüedad: 4 años, 3 meses
Puntos: 0
Respuesta: Actualizar a ultima version de PHP

Cita:
Iniciado por vpsdeploy Ver Mensaje
Hola, haciendo un upgrade a Ubuntu 10.04 LTS te debería actualizar solo a PHP 5.3

# apt-get dist-upgrade
Desconozco completamente como debo proceder.
Tengo varias webs publicadas en el servidor y no quisiera tener problemas en la actualización.
Es necesario actualizar la versión de Ubuntu? Quizá esto entrañe más riesgo, no sería mejor actualizar únicamente la versión de PHP?
  #4 (permalink)  
Antiguo 16/11/2011, 08:45
 
Fecha de Ingreso: diciembre-2010
Ubicación: En Una casa
Mensajes: 8
Antigüedad: 3 años, 7 meses
Puntos: 0
Respuesta: Actualizar a ultima version de PHP

Mas bien seria saber que tan estable es la version 5.3 de php, si es estable me han dicho mejor que espere.

Porque si no te puede pasar que algunas webs no funcionen, tambien deves saber si tu panel esta actualizado, con actualizar el SO es mas que suficiente .
  #5 (permalink)  
Antiguo 16/11/2011, 16:33
 
Fecha de Ingreso: mayo-2010
Mensajes: 38
Antigüedad: 4 años, 3 meses
Puntos: 0
Respuesta: Actualizar a ultima version de PHP

He estado investigando un poco acerca del tema...
He dado con una serie de links que me han ayudado un poco a comprender el problema:
http://www.simmonsconsulting.com/200...er-to-php-528/
https://help.ubuntu.com/community/Re...es/CommandLine
http://doc.ubuntu-es.org/Apt

En estos momentos tengo la siguiente información en mi "sources.list":
Código:
deb http://archive.ubuntu.com/ubuntu hardy main restricted universe
deb http://archive.ubuntu.com/ubuntu hardy-updates main restricted universe
deb http://archive.ubuntu.com/ubuntu hardy-security main restricted universe

## This is a temporary appended by Autoinstaller for
## specify source of product's packages for APT.
deb http://autoinstall.plesk.com/ubuntu/PSA_9.5.3 hardy all
NOTA: es posible que contenga algún error ya que lo he tenido que transcribir.

De esos repositorios, sólo se puede extraer la version 5.2.4-2ubuntu5 (la que tengo). Por tanto, aunque actualice no podré obtener una versión superior de la que ya tengo.

Entonces me imagino que el problema reside en encontrar un repositorio de confianza que ofrezca la versión de PHP que busco. Por ejemplo:
Código:
deb http://ppa.launchpad.net/tarkus/ubuntu hardy main
deb-src http://ppa.launchpad.net/tarkus/ubuntu hardy main
Estos repositorios tienen la versión 5.2.10, que no es la busco pero ya nos estamos acercando.
He encontrado a gente que dice haber instalado php 5.3.5 desde aqui:
http://www.dotdeb.org/category/php/
Pero parece que alli se encuentren repositorios para Debian, no Ubuntu.

En fin, menudo quebradero de cabeza para alguien que desconocía completamente este mundo.

Alguien puede arrojar algo de luz?

Gracias!
  #6 (permalink)  
Antiguo 16/11/2011, 16:39
 
Fecha de Ingreso: mayo-2010
Mensajes: 38
Antigüedad: 4 años, 3 meses
Puntos: 0
Respuesta: Actualizar a ultima version de PHP

Me contesto a mi mismo...
Cita:
Iniciado por http://www.dotdeb.org/about/
The packages from Dotdeb should work on Ubuntu, but no additional support will be provided.
Alguien ha actualizado Hardy desde este repositorio?

Etiquetas: php, servidor, vps, ultimo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:21.
SEO by vBSEO 3.3.2