Foros del Web » Administración de Sistemas » Cloud Computing »

Servidor Linux/Plesk no recibo correos

Estas en el tema de Servidor Linux/Plesk no recibo correos en el foro de Cloud Computing en Foros del Web. Hola tengo un servidor linux , con parallels plesk 10. Creo cuentas de correo asociadas a un dominio , a la hora de enviar mails ...
  #1 (permalink)  
Antiguo 16/09/2011, 11:41
 
Fecha de Ingreso: octubre-2004
Mensajes: 5
Antigüedad: 15 años, 1 mes
Puntos: 1
Servidor Linux/Plesk no recibo correos

Hola tengo un servidor linux , con parallels plesk 10. Creo cuentas de correo asociadas a un dominio , a la hora de enviar mails desde esos correos con horde no tengo problemas, pero cuando me mando mails a esas cuentas de correos estos nunca llegan....

Alguien sabe que problema puedo tener y alguna idea de como solucionarlo?

Muchas gracias
  #2 (permalink)  
Antiguo 16/09/2011, 16:18
Avatar de Apolo
Colaborador
 
Fecha de Ingreso: abril-2003
Ubicación: ubicado
Mensajes: 7.961
Antigüedad: 16 años, 8 meses
Puntos: 109
Respuesta: Servidor Linux/Plesk no recibo correos

Cita:
Iniciado por murk23 Ver Mensaje
Alguien sabe que problema puedo tener y alguna idea de como solucionarlo?
Pues ni idea. No hay mucho adivino por aquí.

Pero además de perder el tiempo con esa frase anterior, agrego lo siguiente:

Podrías empezar por confirmar si el respectivo registro MX del dominio está bien configurado. Tienes herramientas en la web como www.verdns.com para comprobarlo. También desde la consola de comandos puedes hacerlo, con el comando dig.

Podrías mencionar el dominio y así ya habría un elemento concreto para analizar y poder comentarte algo.

Podrías mencionar si los mensajes que envías desde fuera se devuelven o si misteriosamente se los traga el servidor de destino, es decir, tu servidor. Si los mensajes se devuelven, generalmente allí hay pistas del error. Podrías copiar y pegar esos mensajes de devolución.

Si los mensajes no se devuelven, a lo mejor el servidor de destino sí los está recibiendo pero podría ser que los esté enviando a /dev/null. En ese caso, busca en el log del servicio de correo, para encontrar qué esta ocurriendo. Si en Plesk no han cambiado mucho las cosas, te servirá esta ruta y comando:

tail -f /usr/local/psa/var/log/maillog

Y por último, pero no menos importante, podrías pedirle soporte a tu proveedor de hosting, si necesitas asistencia en temas como estos.

__________________
Planes VPS en el mundo > DirectorioVPS
Visita los foros de hosting de ComunidadHosting
  #3 (permalink)  
Antiguo 22/09/2011, 09:21
 
Fecha de Ingreso: octubre-2004
Mensajes: 5
Antigüedad: 15 años, 1 mes
Puntos: 1
Respuesta: Servidor Linux/Plesk no recibo correos

Gracias por tu respuesta:

Tengo un servidor dedicado de 1and1 , asi que no dispongo de soporte y me toca buscarme la vida.

Basicamente he creado dos correos:

1 mediante plesk: [email protected]
1 mediante el servidor de correo de 1 and 1: [email protected]

Los dos pueden enviar correos pero no los reciben, cuando mando correos a estas direcciones solo recibo un mail de error en el de [email protected] El mensaje es:

This is an automatically generated Delivery Status Notification.

Delivery to the following recipients failed.

[email protected]


Respecto a la configuracion MX del dominio:

en mis DNS tengo: Webbrokers.es. MX (10) mail.Webbrokers.es.
en el estudio de dns mediante la pagina que me aportas:

T+0.84s Performing email checks
T+0.89s WEBBROKERS.ES has an MX record for MX01.1AND1.ES, priority 20
T+1.09s SMTP server on MX01.1AND1.ES port 25 responded OK
T+1.09s WEBBROKERS.ES has an MX record for WEBBROKERS.ES, priority 10
T+1.50s SMTP server on WEBBROKERS.ES port 25 responded OK

Por ultimo el maillog me da una sucecion de estos errores:

82]ERR: LOGIN FAILED, ip=[::ffff:58.213.133.82]
Sep 22 15:44:24 s15534236 pop3d: Connection, ip=[::ffff:58.213.133.82]
Sep 22 15:44:30 s15534236 pop3d: IMAP connect from @ [::ffff:58.213.133.82]checkmailpasswd: FAILED: aaliyah - short names not allowed from @ [::ffff:58.213.133.82]ERR: LOGIN FAILED, ip=[::ffff:58.213.133.82]

toqueteando comandos pues tengo tambien logs como este:

[[email protected] ~]# cat /usr/local/psa/var/log/maillog | grep -o 'to=.*@webbrokers.*'
to=<[email protected]> proto=ESMTP helo=<mbulk.1and1.com>
to=<[email protected]> proto=ESMTP helo=<bay0-omc4-s13.bay0.hotmail.com>
to=<[email protected]> proto=ESMTP helo=<bay0-omc4-s19.bay0.hotmail.com>
to=<[email protected]> proto=ESMTP helo=<bay0-omc4-s22.bay0.hotmail.com>

[[email protected] ~]# cat /usr/local/psa/var/log/maillog | grep -o 'to=.*@.*' | sed 's/to=.*@//' | sort | uniq -c | sort -rn | head 2 s15534236.onlinehome-server.info>, relay=none, delay=0.02, delays=0/0.01/0/0, dsn=5.0.0, status=bounced (User unknown in virtual alias table)
1 yahoo.es>, relay=mx2.mail.eu.yahoo.com[77.238.184.241]:25, delay=2.1, delays=0.04/0.01/1.6/0.38, dsn=2.0.0, status=sent (250 ok dirdel)
1 yahoo.com.ar>, relay=127.0.0.1[127.0.0.1]:10027, delay=1.6, delays=0.58/0.33/0.65/0.05, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 9BAB0FFFAF0)
1 yahoo.com.ar>, relay=127.0.0.1[127.0.0.1]:10027, delay=1.1, delays=0.41/0.23/0.39/0.06, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as BD28DFFFAFD)
1 yahoo.com.ar>, relay=127.0.0.1[127.0.0.1]:10027, delay=0.87, delays=0.21/0.1/0.49/0.06, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as CEAD4FFFAF6)
1 yahoo.com.ar>, relay=127.0.0.1[127.0.0.1]:10027, delay=0.65, delays=0.13/0.01/0.44/0.07, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as AB83DFFFAF1)
1 yahoo.com.ar>, relay=127.0.0.1[127.0.0.1]:10027, delay=0.36, delays=0.13/0.01/0.14/0.07, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as CA60BFFFAF7)
1 yahoo.com.ar>, relay=127.0.0.1[127.0.0.1]:10027, delay=0.2, delays=0.06/0.01/0.08/0.05, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as E09FEFFFAFD)
1 yahoo.com.ar>, relay=127.0.0.1[127.0.0.1]:10027, delay=0.19, delays=0.04/0.01/0.08/0.06, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 6AEBCFFFAF0)
1 yahoo.com.ar>, relay=127.0.0.1[127.0.0.1]:10027, delay=0.19, delays=0.03/0.01/0.08/0.07, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 60AF2FFFAF0)
[[email protected] ~]#

Alguna pista de que es lo que esta fayando?
  #4 (permalink)  
Antiguo 22/09/2011, 16:41
Avatar de Apolo
Colaborador
 
Fecha de Ingreso: abril-2003
Ubicación: ubicado
Mensajes: 7.961
Antigüedad: 16 años, 8 meses
Puntos: 109
Respuesta: Servidor Linux/Plesk no recibo correos

Cita:
Iniciado por murk23 Ver Mensaje
Tengo un servidor dedicado de 1and1 , asi que no dispongo de soporte y me toca buscarme la vida
Es lo que tiene contratar un servicio barato y sin soporte, sobre todo si no dominas la administración de sistemas.

Cita:
Iniciado por murk23 Ver Mensaje
Basicamente he creado dos correos:

1 mediante plesk: [email protected]
1 mediante el servidor de correo de 1 and 1: [email protected]
No, no. O lo uno o lo otro, pero no puedes tener dos registros MX que apuntan a servidores diferentes para un mismo dominio, a menos que sepas muy bien lo que estás haciendo y tengas conocimientos avanzados en el tema.

Primero define cuál servicio de correo quieres usar, si el que tienes en tu servidor Plesk o si el que mencionas de 1and1.

Si vas a usar el 1and1, obviamente tendrás que acudir a ellos por soporte, pues supongo que nadie más que ellos tienen acceso a sus servidores para solucionar tus inconvenientes.
__________________
Planes VPS en el mundo > DirectorioVPS
Visita los foros de hosting de ComunidadHosting
  #5 (permalink)  
Antiguo 23/09/2011, 09:20
 
Fecha de Ingreso: octubre-2004
Mensajes: 5
Antigüedad: 15 años, 1 mes
Puntos: 1
Respuesta: Servidor Linux/Plesk no recibo correos

Cita:
Iniciado por Apolo Ver Mensaje
No, no. O lo uno o lo otro, pero no puedes tener dos registros MX que apuntan a servidores diferentes para un mismo dominio, a menos que sepas muy bien lo que estás haciendo y tengas conocimientos avanzados en el tema.

Primero define cuál servicio de correo quieres usar, si el que tienes en tu servidor Plesk o si el que mencionas de 1and1.

Si vas a usar el 1and1, obviamente tendrás que acudir a ellos por soporte, pues supongo que nadie más que ellos tienen acceso a sus servidores para solucionar tus inconvenientes.
Gracias atacare por ahi, supongo que ahora mismo me inclinare por usar el de 1and1. Supongo que probablemente el problema con el de 1and1 debe ser que mi registro MX no apunta a ellos sino apunta a mi propio servidor i este tiene algun problema de configuracion. Apuntando el registro MX a su servidor de correo probablemente deberia funcionar sin problemas no?

de todas formas con algun otro dominio que tengo seguire peleandome con mi propio servidor de correo ya que quiero saber bien como funciona ^^

Cita:
Iniciado por Apolo Ver Mensaje
Es lo que tiene contratar un servicio barato y sin soporte, sobre todo si no dominas la administración de sistemas.
Si tienes razon , pero tambien me gusta aprender y solucionar yo mismo los problemas, en general y llevo muchos años trabajando con ellos en contadas ocaciones realmente he necesitado ayuda. Pero esta claro que sin conocimientos adecuados un servidor sin soporte puede ser un infierno y salirte mucho mas caro.

Eso si, en su favor dire que la calidad de sus servicios son excelentes y que en muchas empresas con soporte he tenido millones de problemas y que con ellos en general estoy muy tranquilo.

Esque un servidor dedicado con soporte es muy caro pra alguien como yo que como mucho en un año pido una vez ayuda para algo. Aunque hay que entender que hay mucha gente que abusa de los soportes y que destroza su servidor cada 4 dias y claro tienen que poner un precio al soporte bastante elebado.

PD: Gracias por tus respuestas , aunque no hayamos solucionado el problema si que me han ayudado bastante en aclarar ideas , practicar con el servidor y en aprender cosillas ;)

Etiquetas: correos, linux, plesk, servidor, servidores-dedicados-vps-y-colocación
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:03.