Foros del Web » Bases de Datos » PostgreSQL »

PostgreSQL + PostGIS

Estas en el tema de PostgreSQL + PostGIS en el foro de PostgreSQL en Foros del Web. ¡Hola! Estoy empezando con PostgreSQL y PostGIS para hacer mi proyecto fin de carrera, lo que necesito es hacer una conversión de .shp (shapefiles) a ...
  #1 (permalink)  
Antiguo 05/12/2006, 03:41
tox
 
Fecha de Ingreso: diciembre-2006
Mensajes: 1
Antigüedad: 7 años, 9 meses
Puntos: 0
PostgreSQL + PostGIS

¡Hola! Estoy empezando con PostgreSQL y PostGIS para hacer mi proyecto fin de carrera, lo que necesito es hacer una conversión de .shp (shapefiles) a una base de datos PostGIS, tengo bastantes dudas, voy a enumerarlas para explicarlas lo mejor posible:

Lo que tengo hecho hasta ahora es lo siguiente:
En mi pc (con Windows XP) tengo instalado PostgreSQL y la ampliación PostGIS, ahora para hacer la conversión .shp -> PostGIS se que existe el siguiente comando: "shp2pgsql" con el que la conversión es automática.
Con pgAdminIII cree una base de Datos según la plantilla "template_postgis" ¿Si la bbdd está hecha según esta plantilla se supone que ya es una base de datos espacial?

A partir de ahora:
si quiero convertir los .shp -> postGIS ¿lo puedo hacer desde pgAdminIII? o tengo que trabajar desde linea de comandos.
Me podriais enumerar unos pasos lo más detallados posible especificando en que carpeta me tengo que colocar para ejecutar "shp2pgsql" o si tengo que conectarme a la base de datos con mi usuario,y en que carpeta tengo que colocar los .shp.

Muchas gracias por vuestra ayuda. Un saludo
  #2 (permalink)  
Antiguo 17/12/2006, 22:42
Avatar de PeterQB  
Fecha de Ingreso: diciembre-2006
Ubicación: La eterna primavera
Mensajes: 39
Antigüedad: 7 años, 9 meses
Puntos: 0
Re: PostgreSQL + PostGIS

Para convertir los archivos shape, es correcto lo haces con el programa shp2pgsql.exe, recuerda que si instalaste el postgis dentro de postgresql, el shp2pgsql te permite crear una tabla espacial con el archivo shp, por ejemplo . " shp2pgsql.exe c:\......shp\ciudades.shp ciudades >ciudades.sql "

Con esta instruccion importas el archivo shape ciudades.shp en la tabla ciudades que se crea y lo ultimo '>ciudades.sql' te crea un script .sql que importas desde el pgadmin, o podrias ejecutarlo directamente con el plsql desde consola.

La importacion debe de hacerse en consola. La tabla se crea cuando ejecutas el script dentro del pgadmin. Espero y te sirva, saludos!!!!!
  #3 (permalink)  
Antiguo 10/01/2007, 13:10
 
Fecha de Ingreso: enero-2007
Mensajes: 1
Antigüedad: 7 años, 8 meses
Puntos: 0
Pregunta Re: PostgreSQL + PostGIS

Hola a todos...

Soy nueva en el foro...

Tengo el siguiente inconveniente... No sé como instalar la extensión PostGis de PostgreSQL en Win XP. He consultado varios tutoriales y todos están orientados bajo Linux. Ya he descargado el Software de PostGis, pero no sé como comenzar...

Alguno me podría dar una manito..
  #4 (permalink)  
Antiguo 15/01/2007, 15:52
 
Fecha de Ingreso: enero-2007
Mensajes: 4
Antigüedad: 7 años, 8 meses
Puntos: 0
PostgreSQL + PostGIS

Hola a todos en el foro...

hace un poco menos de un mes estoy viendo el tema de Postgres y Postgis sobre linux y aun no tengo claro algunos temas.
Por ejemplo tengo un base de datos y 8 tablas en ella, forman un mapa que contiene una especie de datos eléctricos y catastros como subestaciones, manzanas, parques, acometidas y demas, pero no sé como dibujar un cuadrado que este a 0.5Km de una subestacion y mostrar en una nueva tabla la información de las 8 tablas capturadas en ese cuadrado, la idea mas básica que tengo es crear un cuadrado(poligono)a partir de 4 coordenadas
(X,Y), una vez creado el polígono debo usar la función within, también la función GeomFromText('POLYGON(<puntos>)', srid).
Pero... ¿Como hago para dibujar ese polígono que este a 0.5Km de una subestacion?

Gracias de antemano por la atención prestada

posdata: si me equivoqué en enviar mi pregunta por que aun no veo una opción de "agregar pregunta al foro" o algo asi
  #5 (permalink)  
Antiguo 02/02/2007, 09:39
 
Fecha de Ingreso: febrero-2007
Mensajes: 2
Antigüedad: 7 años, 7 meses
Puntos: 0
Re: PostgreSQL + PostGIS

Lo mejor que podés hacer es usar Qgis, que tiene un plugin para importar
archivos shp y te lleva de la mano
  #6 (permalink)  
Antiguo 05/08/2009, 10:42
 
Fecha de Ingreso: julio-2006
Mensajes: 1
Antigüedad: 8 años, 2 meses
Puntos: 0
Respuesta: PostgreSQL + PostGIS

Estimdos:
Yo he trabajado con Postgreslq y PostGis en Linux y el mismo no me ha dado ningun tipo de problemas, ahora necesariamente tengo que hacerlo en XP y cuando quiero instalar sea con el Stack Builder o con el instalador de Postgis para Postgresql 8.3 me da el siguiente error:

"Output folder: C:\DOCUME~1\Project\CONFIG~1\Temp\postgis_installe r
PostGIS has to be installed to the PostgreSQL folder."

Y no me deja avanzar en la instalación.
Si me pueden ayudar se los agradezco.
Saludos
  #7 (permalink)  
Antiguo 10/08/2009, 10:55
 
Fecha de Ingreso: agosto-2009
Mensajes: 1
Antigüedad: 5 años, 1 mes
Puntos: 0
Respuesta: PostgreSQL + PostGIS

hola que tal, soy nueva en este foro y necesito ayuda........


estoy instalando postgres y postgis en solaris en una zona sun Sparc, pero
tengo un error con la instalacion de postgis:

copiar los archivos a /opt

descomprimir

gunzip flex_2_5.gz
gunzip gcc_3_4_.gz
gunzip libiconv.gz
gunzip make_3_8.gz


agregar paketes
pkgadd -d flex... (/usr/local/doc/flex/examples/manual/numbers.lex)

Installation of <SMCflex> was successful.
Installation of <SMCgcc> was successful.
Installation of <SMCliconv> was successful.
Installation of <SMCmake> was successful.




agregar gcc al PATH
vi /etc/profile

PATH=PATH:/usr/local/bin (PATH=.:/opt/postgres/8.4-community/lib/64:/opt/postgres/8.4-community/bin/64:$PATH:/usr/local/bin
)


cargar el nuevo valor de la variable
source /etc/profile


copiar postgis a opt
cp postgis_.gz /opt

desempaketar

POSTGIS

cp postgis-1.3.6.tar.gz /opt/

cd /opt/

gunzip postgis-1.3.6.tar.gz
tar -xvf postgis-1.3.6.tar

cd postgis-1.3.6/
./configure

*******************************
SUMMARY
-------------------------------------------------------

HOST_OS: solaris2.10

PGSQL: /opt/postgres/8.4-community/bin/64/pg_config
ICONV: 1 -liconv

PORTNAME: solaris
PREFIX: /usr/postgres/8.4
EPREFIX: ${prefix}
DOC: /usr/postgres/8.4/doc/contrib
DATA: ${datarootdir}
MAN: ${datarootdir}/man
BIN: /opt/postgres/8.4-community/bin/64
EXT: /opt/postgres/8.4-community/lib/64 (\$$libdir)
-------------------------------------------------------


****************************************

make

**************************************
make -C lwgeom
make[1]: Entering directory `/opt/postgis-1.3.6/lwgeom'
cpp -P -traditional-cpp -DUSE_VERSION=84 lwpostgis.sql.in | sed -e 's:@MODULE_FILENAME@:\$libdir/liblwgeom:g;s:@POSTGIS_VERSION@:1.3 USE_GEOS=0 USE_PROJ=0 USE_STATS=1:g;s:@POSTGIS_SCRIPTS_VERSION@:1.3.6:g; s/@POSTGIS_BUILD_DATE@/2009-08-06 18:43:58/g' | grep -v '^#' > ../lwpostgis.sql
cpp -P -traditional-cpp -DUSE_VERSION=84 lwpostgis.sql.in | sed -e 's#@MODULE_FILENAME@#\$libdir/liblwgeom#g;s#@POSTGIS_VERSION@#1.3 USE_GEOS=0 USE_PROJ=0 USE_STATS=1#g;s#@POSTGIS_SCRIPTS_VERSION@#1.3.6#g; s/@POSTGIS_BUILD_DATE@/2009-08-06 18:43:58/g' | grep -v '^#' > ../regress/lwpostgis.sql
/usr/bin/perl ../utils/postgis_proc_upgrade.pl ../lwpostgis.sql > ../lwpostgis_upgrade.sql
gcc -DUSE_VERSION=84 -DPOSTGIS_LIB_VERSION='"1.3.6"' -DPOSTGIS_VERSION='"1.3 USE_GEOS=0 USE_PROJ=0 USE_STATS=1"' -DPOSTGIS_SCRIPTS_VERSION='"1.3.6"' -DPOSTGIS_BUILD_DATE='"2009-08-06 18:43:58"' -I/opt/postgres/8.4-community/include/server -DAUTOCACHE_BBOX=1 -DUSE_STATS -Wall -g -O2 -fPIC -fexceptions -c -o measures.o measures.c

*******************************

***pero al final de este mensaje mando errores:

///////////////////////////////////////////////////
/8.4-community/lib/64 -lpq -o pgsql2shp
ld: fatal: file /opt/postgres/8.4-community/lib/64/libpq.so: wrong ELF class: ELFCLASS64
ld: fatal: File processing errors. No output written to pgsql2shp
collect2: ld returned 1 exit status
make[1]: *** [pgsql2shp] Error 1
make[1]: Leaving directory `/opt/postgis-1.3.6/loader'
make: *** [loaderdumper] Error 2
////////////////////////////////////////////////////////

bash-3.00# make install
make -C lwgeom
make[1]: Entering directory `/opt/postgis-1.3.6/lwgeom'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/opt/postgis-1.3.6/lwgeom'
make -C loader
make[1]: Entering directory `/opt/postgis-1.3.6/loader'
gcc -g -Wall -I.. -DUSE_ICONV -DUSE_VERSION=84 -DPOSTGIS_VERSION='"1.3.6"' shpopen.o dbfopen.o getopt.o PQunescapeBytea.o pgsql2shp.o -liconv -L/opt/postgres/8.4-community/lib/64 -lpq -o pgsql2shp
ld: fatal: file /opt/postgres/8.4-community/lib/64/libpq.so: wrong ELF class: ELFCLASS64
ld: fatal: File processing errors. No output written to pgsql2shp
collect2: ld returned 1 exit status
make[1]: *** [pgsql2shp] Error 1
make[1]: Leaving directory `/opt/postgis-1.3.6/loader'
make: *** [loaderdumper] Error 2
bash-3.00#

lo anterior son los pasos y comandos ke ia aplike..


espero alguien me pueda ayudar, porfavor, el tiempo se me agota y tengo ke terminar sin errores.... ayudaaaaaaaaaaaaaaaaaaaaaaaaa
  #8 (permalink)  
Antiguo 21/11/2009, 09:54
 
Fecha de Ingreso: septiembre-2005
Ubicación: Medellin
Mensajes: 215
Antigüedad: 9 años
Puntos: 0
Respuesta: PostgreSQL + PostGIS

Saludos a ver si por ahí derecho me colaboran con algo, tengo mis archivos de base de datos dbf y los archivos shp, como los adjunto a mi base de datos?
__________________
JU4N35
  #9 (permalink)  
Antiguo 22/04/2010, 09:37
 
Fecha de Ingreso: abril-2010
Mensajes: 1
Antigüedad: 4 años, 4 meses
Puntos: 0
Respuesta: PostgreSQL + PostGIS

ld: fatal: file /opt/postgres/8.4-community/lib/64/libpq.so: wrong ELF class: ELFCLASS64
Esta avisando que la libreria esta compilada para 64 Bits, probablemente estas intentando compilarla para 32 bits, te recomiendo que pruebes pasarle los parametros a configure para que compile con 64 en vez de 32 o que uses la distribucion de postgres de 32 bits.

EJ ./configure CFLAGS="-m64" CPPFLAGS="-m64" CXXFLAGS="-m64", por ahi algun parametro esta de mas en el ejemplo pero mas vale que falte a que sobre en este caso segun creo.
  #10 (permalink)  
Antiguo 15/07/2010, 00:57
 
Fecha de Ingreso: julio-2010
Mensajes: 1
Antigüedad: 4 años, 2 meses
Puntos: 0
Respuesta: PostgreSQL + PostGIS

Hola buenas!
Soy nuevo con esto del Postgre y Postgis y a la hora de istalar el Postgis se quedo bloqueada la instalación y no consigo que se desbloquee nunca. El resto de aplicaciones se istalan sin problemas, Postgre 8.4 y phpadmin. La versión de Posgis es la 1.4.

Alguien tiene alguna idea de porqué se me puede bloquear??

Aparte de eso mi objetivo sería convertir archivos shp. a Postgis; es necesario que cuente con esta herramienta o habría alguna otra opción de hacer la conversión??

Gracias por adelantado a todos!!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 22:13.
SEO by vBSEO 3.3.2