Foros del Web » Programación para mayores de 30 ;) » Bases de Datos General » PostgreSQL »

problema con las versiones

Estas en el tema de problema con las versiones en el foro de PostgreSQL en Foros del Web. Hola amigos les pido una ayuda me cambiaron la version de Postgre de 8.2 a la 9.0 y tengo problema con algunas consultas por ejemplo ...
  #1 (permalink)  
Antiguo 31/10/2012, 06:57
Avatar de petoko  
Fecha de Ingreso: noviembre-2007
Ubicación: talcahuano chile
Mensajes: 173
Antigüedad: 13 años, 11 meses
Puntos: 0
problema con las versiones

Hola amigos les pido una ayuda
me cambiaron la version de Postgre de 8.2 a la 9.0 y tengo problema con algunas consultas
por ejemplo postgre 9.0 no me reconoce esto en mi consulta
Código:
convert(nombreclase, 'UTF8', 'LATIN1')
alguen sabe como puedo solucionarlo?
por si es necesario pego un ejemplo de una consulta completa
Código:
SELECT 
	periodo, clasedeord, 				 
	case when nombreclase is null then clasedeord else convert(nombreclase, 'UTF8', 'LATIN1')||' - '||clasedeord end as puesto, replace(sum(consm3),'.',',') as consumo_m3,
	 replace(sum(prodm3),'.',',') as produccion_m3, replace(case when sum(consm3)>0 then sum(prodm3)/sum(consm3)*100 else 0 end,'.',',') as rendimiento 
FROM 
	tbl_resumen_consumo_produccion 
LEFT JOIN 
	mae_claorden ON clasedeord=clase 
WHERE 
	periodo='201210' AND clasedeord like '%' AND fecha BETWEEN '2012-10-01' AND '2012-10-30' AND turno like '%' 
GROUP BY 
	periodo, clasedeord, nombreclase 
ORDER BY 
	periodo, clasedeord
  #2 (permalink)  
Antiguo 31/10/2012, 08:01
Avatar de huesos52
Colaborador
 
Fecha de Ingreso: febrero-2009
Ubicación: Manizales - Colombia
Mensajes: 5.980
Antigüedad: 12 años, 8 meses
Puntos: 360
Respuesta: problema con las versiones

Pero que error te saca la consulta?
PostgreSQL a diferencia de productos Windows no hace este tipo de cosas.

Muestranos el error que te genera cada consulta.

saludos
__________________
Without data, You are another person with an opinion.
W. Edwads Deming
  #3 (permalink)  
Antiguo 31/10/2012, 08:13
Avatar de petoko  
Fecha de Ingreso: noviembre-2007
Ubicación: talcahuano chile
Mensajes: 173
Antigüedad: 13 años, 11 meses
Puntos: 0
Respuesta: problema con las versiones

este error me da al correr la consulta en pg_admin

Código:
ERROR:  no existe la función convert(character varying, unknown, unknown)
LINE 3: ...ase when nombreclase is null then clasedeord else convert(no...
                                                             ^
HINT:  Ninguna función coincide en el nombre y tipos de argumentos. Puede desear agregar conversión explícita de tipos.

********** Error **********

ERROR: no existe la función convert(character varying, unknown, unknown)
SQL state: 42883
Hint: Ninguna función coincide en el nombre y tipos de argumentos. Puede desear agregar conversión explícita de tipos.
Character: 89
  #4 (permalink)  
Antiguo 31/10/2012, 08:24
Avatar de huesos52
Colaborador
 
Fecha de Ingreso: febrero-2009
Ubicación: Manizales - Colombia
Mensajes: 5.980
Antigüedad: 12 años, 8 meses
Puntos: 360
Respuesta: problema con las versiones

Parece estar mas relacionado con un problema de codificación.

Mira este post http://blog.e-shell.org/134

Es probable que la 8.2 tenga una codificacion diferente a la 9.0.

saludos
__________________
Without data, You are another person with an opinion.
W. Edwads Deming
  #5 (permalink)  
Antiguo 08/11/2012, 08:17
Avatar de petoko  
Fecha de Ingreso: noviembre-2007
Ubicación: talcahuano chile
Mensajes: 173
Antigüedad: 13 años, 11 meses
Puntos: 0
Respuesta: problema con las versiones

todavía no lo puedo solucionar....alguien sabe que puedo hacer?

Etiquetas: postgre, versiones
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:49.