Foros del Web » Bases de Datos » Oracle »

Problema ejecutar forms en Oracle Developer 10g

Estas en el tema de Problema ejecutar forms en Oracle Developer 10g en el foro de Oracle en Foros del Web. Hola: Tengo instalado Oracle10g developer en una PC con XP, no estoy en red, estoy trabajando en mi casa. He podido diseñar un form, no ...
  #1 (permalink)  
Antiguo 04/01/2008, 13:36
 
Fecha de Ingreso: enero-2008
Mensajes: 29
Antigüedad: 6 años, 7 meses
Puntos: 0
Problema ejecutar forms en Oracle Developer 10g

Hola:
Tengo instalado Oracle10g developer en una PC con XP, no estoy en red, estoy trabajando en mi casa. He podido diseñar un form, no tengo problema de conexion a la base de datos ni con el Listener, se compila bien pero a la hora de lanzarlo lo unico que visualizo en en navegar (Internet Explorer 6) son estas dos palabras: ORACLE FORMS

Lo he intentado de varias maneras, manipulando el puerto pero nada. Estoy usando este url: http://127.0.0.1:1521/forms90/f90servlet

Que pasa?

Gracias
  #2 (permalink)  
Antiguo 04/01/2008, 16:19
 
Fecha de Ingreso: enero-2008
Mensajes: 2
Antigüedad: 6 años, 7 meses
Puntos: 0
Re: Problema ejecutar forms en Oracle Developer 10g

Preguinto: sobre su pc si se ejecuta correctamente la forma que ha desarrollado?
  #3 (permalink)  
Antiguo 05/01/2008, 06:19
 
Fecha de Ingreso: junio-2007
Mensajes: 873
Antigüedad: 7 años, 2 meses
Puntos: 42
Re: Problema ejecutar forms en Oracle Developer 10g

¿ No te falta el nombre del fmx ?
  #4 (permalink)  
Antiguo 07/01/2008, 02:18
Avatar de kikolice  
Fecha de Ingreso: marzo-2004
Mensajes: 1.510
Antigüedad: 10 años, 5 meses
Puntos: 7
Re: Problema ejecutar forms en Oracle Developer 10g

a veces pasa que la configuracion de seguridad de internet explorer no deja executar a jinitiator, o como estas en 10g debes de tener activado el oc4j y no lo esta, tal vez por ahi valla
__________________
Blogzote.com :-) Mi blog
  #5 (permalink)  
Antiguo 07/01/2008, 23:38
 
Fecha de Ingreso: enero-2008
Mensajes: 29
Antigüedad: 6 años, 7 meses
Puntos: 0
Re: Problema ejecutar forms en Oracle Developer 10g

Cita:
Iniciado por jsanlucas Ver Mensaje
Hola:
Tengo instalado Oracle10g developer en una PC con XP, no estoy en red, estoy trabajando en mi casa. He podido diseñar un form, no tengo problema de conexion a la base de datos ni con el Listener, se compila bien pero a la hora de lanzarlo lo unico que visualizo en en navegar (Internet Explorer 6) son estas dos palabras: ORACLE FORMS

Lo he intentado de varias maneras, manipulando el puerto pero nada. Estoy usando este url: http://127.0.0.1:1521/forms90/f90servlet

Que pasa?

Gracias
  #6 (permalink)  
Antiguo 08/01/2008, 00:01
 
Fecha de Ingreso: enero-2008
Mensajes: 29
Antigüedad: 6 años, 7 meses
Puntos: 0
Re: Problema ejecutar forms en Oracle Developer 10g

Hola a toda la comunidad:

Gracias por prestar atencion a mi peticion.

Mi problema persiste.
Voy a tratar de explicar mejor la situacion de este mi problema.

En primer lugar, la PC es una pentium 4 con XP, con suficiente capacidad, tanto en RAM como velocidad y espacio en disco, eso sí, con una sola unidad de disco, o sea, C:, por lo que en la misma maquina tengo instalado Oracle DB 10g y Oracle Developer Suite 10g, en carpetas separadas o diferentes. (C:\oracle_home y C:\oracle_developer)

Despues de algunos obstaculos, quedó bien el listener del developer porque sí puedo conectarme perfectamente a la BD desde Forms en tiempo de diseño.

El OC4J Instance está levantado y abierto durante el tiempo de diseño y ejecucion.

Después de hacer mi Form de ejemplo, se compila sin problema y lo quiero ejecutar con el icono del semaforo en verde pasa lo siguiente con Internet Explorer (ver.7):

"Para ayudar a proteger su seguridad, IE impidio que esta pagina web
ejecutara scripts o controles activex que podrian obtener acceso al equipo. Haga
clic aqui para ver opciones..."

Cuando habilito la opcion "Permitir contenido bloqueado" muestra en la pantalla la siguiente linea:

"ORACLE FORMS."

Cierro I.E. y regreso al Forms.
Cuando ejecuto nuevamente mi form de ejemplo, visualizo sólo el siguiente código en la pantalla:

<html> <head> ORACLE FORMS.</head>
<body onload="document.pform.submit();" >
<form name="pform" action="http://localhost:1521/forms90/f90servlet" method="POST">
<input type="hidden" name="form" value="C:\MyAplicacion\frmInicio2.fmx">
<input type="hidden" name="userid" value="SYSTEM/MASTER@orcl">
<input type="hidden" name="obr" value="yes">
<input type="hidden" name="array" value="YES">
</form> </body></html>


Por su comprension y ayuda, gracias.
  #7 (permalink)  
Antiguo 11/06/2008, 18:46
 
Fecha de Ingreso: junio-2008
Mensajes: 1
Antigüedad: 6 años, 2 meses
Puntos: 0
Respuesta: Re: Problema ejecutar forms en Oracle Developer 10g

Estimados buenas tardes, tengo exactamente el mismo problema que jsanlucas, por favor si alguien conoce como se soluciona aguardamos comentarios

muchas gracias

Dario
  #8 (permalink)  
Antiguo 12/06/2008, 00:33
Avatar de kikolice  
Fecha de Ingreso: marzo-2004
Mensajes: 1.510
Antigüedad: 10 años, 5 meses
Puntos: 7
Respuesta: Re: Problema ejecutar forms en Oracle Developer 10g

Cita:
Iniciado por jsanlucas Ver Mensaje
<html> <head> ORACLE FORMS.</head>
<body onload="document.pform.submit();" >
<form name="pform" action="http://localhost:1521/forms90/f90servlet" method="POST">
<input type="hidden" name="form" value="C:\MyAplicacion\frmInicio2.fmx">
<input type="hidden" name="userid" value="SYSTEM/MASTER@orcl">
<input type="hidden" name="obr" value="yes">
<input type="hidden" name="array" value="YES">
</form> </body></html>


Por su comprension y ayuda, gracias.
a mi me suena que va por el puerto el problema, comentabas que lo cambiaste al 1521 pero ese el de la base de datos, si no mal recuerdo el del applet de forms es el 8888 o algo asi
__________________
Blogzote.com :-) Mi blog
  #9 (permalink)  
Antiguo 19/06/2008, 11:17
 
Fecha de Ingreso: junio-2008
Ubicación: D.F.
Mensajes: 62
Antigüedad: 6 años, 2 meses
Puntos: 1
Respuesta: Problema ejecutar forms en Oracle Developer 10g

Que Tal,

Una vez que has levantado tu Base de Datos y tu oc4j. y tu forma no se visualiza si no solo el mensaje de ORACLE FORMS. Solo puede haber un par de situaciones por la que esto ete sucediendo

1.- Checa la configuaración de los parámetros en el Archivo formsweb.cfg.

2.- No se si tengas bien tu máquina virtual de java. Porque tu problema es que
no puedes ver el Applet que muestra tu pantalla.

3.- Este problema inclusive te lo puede estar causando que en tu forma no
tengas ningún elemento navegable. Por lo tanto forms solo inicia y se sale y
al final no vez mas que Oracle Forms.

Espero que alguna de estas tres situaciones pueda resolver tu problema

Saludos.
  #10 (permalink)  
Antiguo 24/12/2010, 22:07
 
Fecha de Ingreso: diciembre-2010
Mensajes: 3
Antigüedad: 3 años, 8 meses
Puntos: 0
Respuesta: Problema ejecutar forms en Oracle Developer 10g

Que tal Oscar!

Estuve leyendo el Foro ya que tengo el mismo inconveniente ...quisiera saber que es lo que debo chekar en el archivo formsweb.cfg.
Y que debo darme cuenta en la maquina virtual de java.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:15.
SEO by vBSEO 3.3.2