Foros del Web » Programando para Internet » Ruby »

Problemas Gem

Estas en el tema de Problemas Gem en el foro de Ruby en Foros del Web. Que tal, estoy usando Linux ruby y gem Código: [email protected]:~$ ruby -v ruby 1.8.6 (2007-09-24 patchlevel 111) [i486-linux] [email protected]:~$ gem -v 1.3.1 [email protected]:~$ estas son ...
  #1 (permalink)  
Antiguo 18/01/2011, 12:19
 
Fecha de Ingreso: enero-2011
Mensajes: 3
Antigüedad: 9 años, 9 meses
Puntos: 0
Problemas Gem

Que tal, estoy usando Linux ruby y gem
Código:
[email protected]:~$ ruby -v
ruby 1.8.6 (2007-09-24 patchlevel 111) [i486-linux]
[email protected]:~$ gem -v
1.3.1
[email protected]:~$
estas son las versiones, el problema radica que deceo instalar un libreria y lo hago de la siguientem manera
Código:
[email protected]:~$ gem install spyder
Finaliza la instalacion con exito y ahora listo las lib que tengo instaladas
Código:
[email protected]:~$ gem list

*** LOCAL GEMS ***

spider (0.4.4)
[email protected]:~$
pero al correo una aplicacion me dice
Código:
./cewl.rb 
./cewl.rb:58:in `require': no such file to load -- spider (LoadError)
	from ./cewl.rb:58

que podrias estar pasando? si la lib ya esta instalada pero el programa que intento correr no lo localiza
  #2 (permalink)  
Antiguo 23/01/2011, 19:03
Avatar de uokesita  
Fecha de Ingreso: enero-2008
Ubicación: Maracaibo
Mensajes: 214
Antigüedad: 12 años, 9 meses
Puntos: 17
Respuesta: Problemas Gem

la libreria puede estar instalada pero ademas tienes que ¨requerirla¨o añadirla a tu archivo cewl.rb

algo como:
Código ruby:
Ver original
  1. require "spyder"
  #3 (permalink)  
Antiguo 24/01/2011, 18:59
Avatar de jam666  
Fecha de Ingreso: septiembre-2009
Ubicación: Isla De Margarita - Venezuela
Mensajes: 428
Antigüedad: 11 años, 1 mes
Puntos: 39
Respuesta: Problemas Gem

Solo un consejo:

- Deberias actualizar tu version de Ruby:
- Deberias actualizar tu version de Gem:

¡bueno dos en realidad!

¿Que S.O Linux usas?

Saludos
__________________
J.A.M
Jam Blog
  #4 (permalink)  
Antiguo 29/01/2011, 08:48
 
Fecha de Ingreso: enero-2011
Mensajes: 3
Antigüedad: 9 años, 9 meses
Puntos: 0
Respuesta: Problemas Gem

Cita:
Iniciado por uokesita Ver Mensaje
la libreria puede estar instalada pero ademas tienes que ¨requerirla¨o añadirla a tu archivo cewl.rb

algo como:
Código ruby:
Ver original
  1. require "spyder"
SI lo mando ha llamar por eso me marca ese error xD,

CUal es la version mas reciente de ruby y GEM como lo actualizo ? estoy usando ubuntu 8.04

Etiquetas: gem, install
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 00:57.