Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » Drupal »

Bug de Drupal o error mio?

Estas en el tema de Bug de Drupal o error mio? en el foro de Drupal en Foros del Web. Hola gente, resulta que me pasa una cosa muy curiosa. Creo un menu con dos elementos, el primero con un enlace llamado administración que apunta ...
  #1 (permalink)  
Antiguo 17/06/2011, 08:49
Avatar de Dundee  
Fecha de Ingreso: junio-2002
Ubicación: El Médano
Mensajes: 1.310
Antigüedad: 20 años
Puntos: 8
Bug de Drupal o error mio?

Hola gente, resulta que me pasa una cosa muy curiosa.

Creo un menu con dos elementos, el primero con un enlace llamado administración que apunta a dicha sección ; el segundo con otro enlace "crear grupo" que apunta a la creación del nodo "grupo".

Al hacer esto se crea automáticamente como ya sabéis un bloque con el nombre del menú que acabo de crear; púes bien allí le indico que solo dos roles puedan ver ese bloque en la región izquierda ADMINISTRADOR y MANAGER; que son los único roles que quiero que vean este bloque.

¿Que sucede?.
1 El usuario registrado con el rol MANAGER puede ver sin problema el bloque (y acceder a los enlaces que apuntan sus items; ya que tiene permiso para ello) (hasta aquí todo ok).

2 El usuario registrado con el rol ADMINISTRADOR (este tiene TODOS los permisos), no ve dicho bloque y no entiendo porque , ya que el bloque esta configurado para que ambos roles lo vean.

Por si puede ser pos la versión de Drupal , la que tengo es esta:
Drupal core 6.19 (estoy actualizándola en local haber si puede ser por eso, pero me extraña).

Un saludo y gracias de antemano.
__________________
Videotutoriales de Drupal
  #2 (permalink)  
Antiguo 17/06/2011, 12:38
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 12 años, 8 meses
Puntos: 265
Respuesta: Bug de Drupal o error mio?

A mi nunca me tiro ese error. Lo unico q me pasaba es que yo con el usuario 1 (el admin general) no podia ver bloques protegidos para roles porque, apesar de ser el usuario que tiene todos los permisos, no tenia ese rol asignado y Drupal lo ocultaba igual....

Pero al menos a mi nunca me paso eso.

Etiquetas: bug
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:35.