Foros del Web » Creando para Internet » Flash y Actionscript »

Problemas con "wmode transparent" y multiplicar en Firefox

Estas en el tema de Problemas con "wmode transparent" y multiplicar en Firefox en el foro de Flash y Actionscript en Foros del Web. Hola a todos! Estoy armando un sitio en flash y tengo un problema con el modo de fusion multiplicar cuando uso wmode transparent. Solo me ...
  #1 (permalink)  
Antiguo 26/02/2010, 05:51
mda
 
Fecha de Ingreso: mayo-2009
Mensajes: 4
Antigüedad: 11 años, 9 meses
Puntos: 0
Problemas con "wmode transparent" y multiplicar en Firefox

Hola a todos!

Estoy armando un sitio en flash y tengo un problema con el modo de fusion multiplicar cuando uso wmode transparent. Solo me ocurre con firefox, en IE se ve perfecto!

asi esta armado: es una pelicula flash con wmode transparent. Esta pelicula esta ubicada en un div. EN OTROS DIV se ubican dos peliculitas tambien con wmode transparent, y esas dan problemas al ponerle el modo de fusion multiplicar.

O sea, los marcos que ven abajo pertenecen a una pelicula flash, y las dos lamparas son otras peliculas ubicadas encima (en otros divs aparte)

Dejo una captura para que vean cual es el problema

[url=http://www.freeimagehosting.net/][img]http://www.freeimagehosting.net/uploads/5649a49e35.jpg[/img][/url]



son tres pantallas, la primera en IE8, se ve perfecto sin el contorno negro

la segunda en firefox 3.6, se ve una linea en el perfil del objeto (lo marque en rojo para que se vea bien por las dudas).

en la ultima captura les muestro que cuando ese objeto se superpone a otra pelicula flash si se ve bien (ubicada en otro div, o sea, es otra pelicula tambien con wmode transparent) HABLO DE LA PORCION DE LA LAMPARA QUE SE SUPERPONE CON EL MARCO, en esa porcion se ve sin el contorno negro

estoy usando la ultima version del flash player

gracias!! espero que se haya entendido el problema
  #2 (permalink)  
Antiguo 27/02/2010, 08:01
Avatar de ikaroraul  
Fecha de Ingreso: octubre-2006
Ubicación: La Paz
Mensajes: 391
Antigüedad: 14 años, 4 meses
Puntos: 16
Respuesta: Problemas con "wmode transparent" y multiplicar en Firefox

No entendi muy bien tu preguinta... pero usualmente cuando yo quiero usar la propiedad de wmode, transparent, para FF tb debes colocarla aqui:

Código HTML:
 <script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0','width','751','height','311','src','flash/banner_main','quality','high','pluginspage','http://www.macromedia.com/go/getflashplayer','movie','flash/banner_main','wmode','transparent','FlashVars','button=4' ); //end AC code
</script> 
Pd. uso el script que viene on dreamweaver cs3 en esa parte tienes que aumentar la propiedad 'wmode','transparent' asi te funcionara en FF.

Espero haberte ayudado.

SAlu2
__________________
Msn: [email protected]
  #3 (permalink)  
Antiguo 27/02/2010, 19:19
Avatar de loncho_rojas
Colaborador
 
Fecha de Ingreso: octubre-2008
Ubicación: En el mejor lugar del mundo
Mensajes: 2.704
Antigüedad: 12 años, 4 meses
Puntos: 175
Respuesta: Problemas con "wmode transparent" y multiplicar en Firefox

Podrias ir como primer paso a

Archivo/Configuracion de publicacion

File > Publish Settings

Seleccionas como archivo de salida Flash y HTML

vas a la pestañita de HTML, y verificas la opcion

MODO DE VENTANA, que sea Transparente sin ventanas
WMODE>> Transparent

y le das publicar, y veras el codigo fuente del HTML..

Tambien puede modificarlo de manera manual.. lo importante es esta secciones que te marco

Cita:
<noscript>
<object
classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0"
width="840"
height="230"
id="mi-pagina-flash"
align="middle">


<param name="allowScriptAccess" value="sameDomain" />
<param name="allowFullScreen" value="false" />
<param name="movie" value="oscurecer-pagina-con-thickbox-y-lightwindow.swf" />
<param name="quality" value="high" />
<param name="wmode" value="transparent" />
<param name="bgcolor" value="#000000" />

<embed src="el-archivo-flash.swf" quality="high" wmode="transparent" bgcolor="#000000" width="840" height="230" name="mi-pagina-flash" align="middle" allowScriptAccess="sameDomain" allowFullScreen="false" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>
</noscript>
espero te sirva... esta probado en Firefox
__________________
Ayudo con lo que puedo en el foro, y solo en el foro.. NO MENSAJES PRIVADOS.. NO EMAILS NI SKYPE u OTROS.

Antes de hacer un TOPICO piensa si puedes hallarlo en Google o en el Buscador del Foro...

Etiquetas: firefox, multiplicar
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:14.