Foros del Web » Programando para Internet » PHP »

Algo parecido al Appserv

Estas en el tema de Algo parecido al Appserv en el foro de PHP en Foros del Web. Hola a todos. Quisiera saber si existe algún SW que me permita trabajar con Apache, PHP y MySQL, como lo hace el Appserv, pero claro, ...
  #1 (permalink)  
Antiguo 08/05/2006, 09:35
 
Fecha de Ingreso: febrero-2004
Ubicación: Guayaquil
Mensajes: 110
Antigüedad: 13 años, 9 meses
Puntos: 0
Algo parecido al Appserv

Hola a todos.

Quisiera saber si existe algún SW que me permita trabajar con Apache, PHP y MySQL, como lo hace el Appserv, pero claro, trabajando en plataforma windows XP.

Gracias por sus respuestas.
  #2 (permalink)  
Antiguo 08/05/2006, 09:49
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
Iniciado por MarceloWeb
Hola a todos.

Quisiera saber si existe algún SW que me permita trabajar con Apache, PHP y MySQL, como lo hace el Appserv, pero claro, trabajando en plataforma windows XP.

Gracias por sus respuestas.
mm .. Appserv y todos los WAMP (WIndows, Apache, Mysql, PHP) como "pre-instaladores" de todo ese software de servidor funcionan bien en windows XP.

Exactamente igual que si quisieras instalar todo -por separado- en forma manual.

Tienes algún problema concreto con "Appserv"?

Bueno, .. tienes más para que pruebes ...

FoxServ: http://sourceforge.net/projects/foxserv/
PHP Triad: http://sourceforge.net/projects/phptriad/
EasyPHP: http://www.easyphp.org
Appserv: http://www.appservnetwork.com/
e-novative WAMP: http://www.e-novative.info/software/wamp.php
WAMP5: http://www.wampserver.com/

Pero realmente deberías plantearte y aprender a instalarlo manualmente (así tendrás controlo de lo que instalas y solventarás problemas tu mismo):

http://www.maestrosdelweb.com/editorial/phpmysqlap/

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 08/05/2006, 09:53
Avatar de mauled  
Fecha de Ingreso: marzo-2005
Ubicación: Cd. de México.
Mensajes: 3.001
Antigüedad: 12 años, 9 meses
Puntos: 33
De acuerdo

Estoy de acuerdo con CLUSTER en lo que te menciona al final. y complementado su comentario; ademas instalando manualmente podrias de esta forma estar actualizando php y mysql ,y no tendrias que esperar a que el "programa" que bajes los actualize.
  #4 (permalink)  
Antiguo 08/05/2006, 09:53
 
Fecha de Ingreso: febrero-2004
Ubicación: Guayaquil
Mensajes: 110
Antigüedad: 13 años, 9 meses
Puntos: 0
Muchas gracias Cluster.

Respueta muy completa la tuya.
Mi pregunta se originó de que formateé mi pc y ahora tengo XP, con lo cual no se muestran los sitios que he desarrollado, y la versión 2.2.0 del Appserv, no habla de que trabaja con XP, por eso temía no poder desarrollar bajo este nuevo SO.

En todo caso probaré con todas las direcciones que adjuntastes, en caso que el Appserv de algún problema.

Gracias nuevamente.

Saludos.
  #5 (permalink)  
Antiguo 08/05/2006, 10:19
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
Mi pregunta se originó de que formateé mi pc y ahora tengo XP, con lo cual no se muestran los sitios que he desarrollado, y la versión 2.2.0 del Appserv, no habla de que trabaja con XP, por eso temía no poder desarrollar bajo este nuevo SO.
Pero .. una cosa es que una aplicación concreta no funcione .. por diferencias entre la configuración que usabas antes (php.ini .. Apache .. etc) y la que las nuevas versiones de PHP y/o etc. usas.

De hecho .. si alguna vez ubieses instalado PHP y demás "a mano" verías lo que te comento. Es más, cuando uno "programa" en PHP ha de saber "que" configuración de PHP se usa y como programastes. Me refiero a revisar cosas como: "como trabajas las variables externas?" (usas $_POST['variable'] ... etc o sólo $variable?) .. como tienes en tu php.ini: register_globals (on u off) ..

Bueno, ese tipo de "combinaciones" de tu código y de tu "php.ini" van a influir mucho en como se comporte una aplicación en un servidor y en otro. Por eso es -tan- necesario conocer como está y como desarrollastes tu para cierta configuración. Sino .. ahora podrás tocar tu "php.ini" pero en otras ocasiones NO, y tendrás que "programar" en forma más "standard" para que no tengas problemas de "compatibilidad".

Sobre problemas de Apache o de PHP o de Mysql en sí .. todas las versiones en windows que he instaldo desde windows 98 en adelante todas han funcionado correctamente sin problemas. De hecho en Windows XP dá menos problemas por ejemplo Apache 2.x por qué este pretende instalarse como "servicio" y eso en Windows98 no lo trabaja bien (pero esto no es problema de "Apache" .. por ejemplo sino del S.O. )

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:12.