Foros del Web » Programando para Internet » PHP »

Anuncio: Extensión MYSQL de PHP se considera obsoleta

Estas en el tema de Anuncio: Extensión MYSQL de PHP se considera obsoleta en el foro de PHP en Foros del Web. Un manual (en inglés) pero con ejemplos muy claros de cómo migrar de la extensión MySQL a PDO. Muestran primero como lo hacíamos con ext ...

  #31 (permalink)  
Antiguo 03/01/2013, 16:46
Avatar de andresdzphp
Colaborador
 
Fecha de Ingreso: julio-2011
Ubicación: $this->Colombia;
Mensajes: 2.749
Antigüedad: 6 años, 4 meses
Puntos: 793
Respuesta: Anuncio: Extensión MySQL ha sido deprecada

Un manual (en inglés) pero con ejemplos muy claros de cómo migrar de la extensión MySQL a PDO. Muestran primero como lo hacíamos con ext MySQL y como sería con PDO.

PDO Tutorial for MySQL Developers

Cita:
This extension is now deprecated, and deprecation warnings will be generated
when connections are established to databases via mysql_connect(),
mysql_pconnect(), or through implicit connection: use MySQLi or PDO_MySQL
van a salir advertencias al conectar con mysql_connect() o mysql_pconnect().
__________________
Si sabemos como leer e interpretar el manual será mucho más fácil aprender PHP. En lugar de confiar en ejemplos o copiar y pegar - PHP
  #32 (permalink)  
Antiguo 22/01/2013, 00:18
 
Fecha de Ingreso: abril-2008
Ubicación: Barcelona
Mensajes: 99
Antigüedad: 9 años, 7 meses
Puntos: 0
Respuesta: Anuncio: Extensión MySQL ha sido deprecada

¿Qué es más potente, PDO o mysqli?
  #33 (permalink)  
Antiguo 22/01/2013, 10:29
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 5 meses
Puntos: 2122
Respuesta: Anuncio: Extensión MySQL ha sido deprecada

Lee el Manual, cada uno tiene sus Pros y sus contras, al final depende que RDBMS vas a usar más y si piensas en un futuro usar otro RDBMS.

http://us2.php.net/manual/en/mysqlinfo.api.choosing.php

Saludos.
  #34 (permalink)  
Antiguo 22/01/2013, 16:17
 
Fecha de Ingreso: agosto-2012
Ubicación: México
Mensajes: 106
Antigüedad: 5 años, 2 meses
Puntos: 6
Respuesta: Anuncio: Extensión MySQL ha sido deprecada

:/ Estoy aputno de terminar un proyecto web de mi empresa y lo hice con esta API, y no se usar MysqlLi y PO.. uu'
  #35 (permalink)  
Antiguo 23/01/2013, 08:27
Avatar de jonni09lo
Colaborador
 
Fecha de Ingreso: septiembre-2011
Ubicación: Estigia
Mensajes: 1.471
Antigüedad: 6 años, 2 meses
Puntos: 396
Respuesta: Anuncio: Extensión MySQL ha sido deprecada

Cita:
Iniciado por art_rockerd Ver Mensaje
:/ Estoy aputno de terminar un proyecto web de mi empresa y lo hice con esta API, y no se usar MysqlLi y PO.. uu'
Pues mira que a mi parecer y experiencia, es mucho mas comodo usar PDO, cuando estas trabajando con POO y con mysqli cuando estas con estructurado, aunque me siento mil veces mas comodo con PDO

Si necesitas ayuda te puedo colaborar con ello

Saludos
__________________
Haz preguntas inteligentes-Como ser Hacker
No hacer preguntas por mensaje privado. No sólo no es inteligente sino que es egoísta.
  #36 (permalink)  
Antiguo 18/02/2013, 10:54
Avatar de porketero  
Fecha de Ingreso: noviembre-2010
Mensajes: 29
Antigüedad: 7 años
Puntos: 1
Respuesta: Anuncio: Extensión MySQL ha sido deprecada

Lo que no entiendo es el motivo, ¿velocidad, vulnerabilidades?
  #37 (permalink)  
Antiguo 18/02/2013, 11:37
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 5 meses
Puntos: 2122
Respuesta: Anuncio: Extensión MySQL ha sido deprecada

Velocidad, vulnerabilidades y sobre todo que no esta lista ni preparada para las nuevas características de MySQL, necesitaba re-hacerse de 0 y fue lo que hicieron con MySQLi.

Saludos.
  #38 (permalink)  
Antiguo 26/02/2013, 09:58
 
Fecha de Ingreso: julio-2012
Ubicación: Nómoda como un ave
Mensajes: 61
Antigüedad: 5 años, 4 meses
Puntos: 0
Respuesta: Anuncio: Extensión MySQL ha sido deprecada

Pues a desvelarme un poco a actualizar mi sistema.
alguien me deja el link para la version de php 5.5
  #39 (permalink)  
Antiguo 26/02/2013, 10:05
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 5 meses
Puntos: 2122
Respuesta: Anuncio: Extensión MySQL ha sido deprecada

PHP5.5 esta todavía en beta, la última estable es PHP5.4, y ambos los puedes encontrar en la pagina oficial de php.net.

Saludos.
  #40 (permalink)  
Antiguo 26/02/2013, 10:17
 
Fecha de Ingreso: julio-2012
Ubicación: Nómoda como un ave
Mensajes: 61
Antigüedad: 5 años, 4 meses
Puntos: 0
Respuesta: Anuncio: Extensión MySQL ha sido deprecada

Gracias hermano, muy amable.
Saludos.
  #41 (permalink)  
Antiguo 18/04/2013, 10:18
Avatar de uriss  
Fecha de Ingreso: marzo-2013
Mensajes: 14
Antigüedad: 4 años, 8 meses
Puntos: 1
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

Que feo apenas y aprendí a utilizar Mysql. Con php y Ahora resulta que tengo que aprender otro Y con el trabajo que cuesta estar aprendiendo las funciones y las declaraciones. NOOOO Pero ni modo todo sea Para seguir avanzando en esto del desarrollo de BD.
  #42 (permalink)  
Antiguo 18/04/2013, 22:11
Avatar de carlos_belisario
Colaborador
 
Fecha de Ingreso: abril-2010
Ubicación: Venezuela Maracay Aragua
Mensajes: 3.156
Antigüedad: 7 años, 7 meses
Puntos: 460
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

Cita:
Iniciado por uriss Ver Mensaje
Que feo apenas y aprendí a utilizar Mysql. Con php y Ahora resulta que tengo que aprender otro Y con el trabajo que cuesta estar aprendiendo las funciones y las declaraciones. NOOOO Pero ni modo todo sea Para seguir avanzando en esto del desarrollo de BD.
no es que vas a desaprender mysql, lo bonito para quitar lo feo que dices es que vas a usar librerías mejor soportadas para el trabajo con php y mysql, velo como una mejora para tu aprendizaje y si comprendiste la extensión mysql_* mysqli se le asemeja mucho en su forma estructurada, así que no debería de ser problema, saludos
__________________
aprende d tus errores e incrementa tu conocimientos
it's not a bug, it's an undocumented feature By @David
php the right way
  #43 (permalink)  
Antiguo 19/04/2013, 12:36
Avatar de Rafael
Modegráfico
 
Fecha de Ingreso: marzo-2003
Mensajes: 8.946
Antigüedad: 14 años, 8 meses
Puntos: 1801
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

Cita:
Iniciado por uriss Ver Mensaje
Que feo apenas y aprendí a utilizar Mysql. Con php y Ahora resulta que tengo que aprender otro Y con el trabajo que cuesta estar aprendiendo las funciones y las declaraciones. NOOOO Pero ni modo todo sea Para seguir avanzando en esto del desarrollo de BD.
Urris... Lo que entiendo es que simplemente en lugar de uno usas otro (copaido del manual php.net)
Código PHP:
  <?php
// mysqli
$mysqli = new mysqli("example.com""user""password""database");
$result $mysqli->query("SELECT 'Hello, dear MySQL user!' AS _message FROM DUAL");
$row $result->fetch_assoc();
echo 
htmlentities($row['_message']);

// PDO
$pdo = new PDO('mysql:host=example.com;dbname=database''user''password');
$statement $pdo->query("SELECT 'Hello, dear MySQL user!' AS _message FROM DUAL");
$row $statement->fetch(PDO::FETCH_ASSOC);
echo 
htmlentities($row['_message']);

// mysql
$c mysql_connect("example.com""user""password");
mysql_select_db("database");
$result mysql_query("SELECT 'Hello, dear MySQL user!' AS _message FROM DUAL");
$row mysql_fetch_assoc($result);
echo 
htmlentities($row['_message']);
?>
  #44 (permalink)  
Antiguo 17/10/2013, 15:00
Avatar de reborn  
Fecha de Ingreso: febrero-2010
Mensajes: 439
Antigüedad: 7 años, 9 meses
Puntos: 1
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

Hola,
hay algo q no entiendo, mysql se deja de usar como sintaxis de lenguaje y en vez de eso se recurre a mysqli o PDO?
MySQLi seria la nueva version de mysql pero orientada a objetos?
PDO se puede seguir usando con mysql? o tambien queda obsoleto? En el manual dice: 5.4.0 Ya no se da soporte a las bibliotedas cliente de MySQL 4.1 y anteriores

Resumiendo: q se aconseja utilizar HOY en aquellos servidores o entornos con gestor mysql?, no se de estadisticas pero en la mayoria lo siguen utilizando.

Gracias
  #45 (permalink)  
Antiguo 17/10/2013, 15:30
Avatar de andresdzphp
Colaborador
 
Fecha de Ingreso: julio-2011
Ubicación: $this->Colombia;
Mensajes: 2.749
Antigüedad: 6 años, 4 meses
Puntos: 793
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

Lo que está obsoleto son las funciones mysql_* (extensión mysql), no el gestor de bases de datos mysql que se puede manejar ahora con PDO o Mysqli.

Si consultas en el manual PHP funciones como mysql_query encontrarás este tipo de advertencias y que se recomienda usar:

Cita:
Esta extensión está obsoleta a partir de PHP 5.5.0, y será eliminada en el futuro. En su lugar, deberían usarse las extensiones MySQLi o PDO_MySQL.
__________________
Si sabemos como leer e interpretar el manual será mucho más fácil aprender PHP. En lugar de confiar en ejemplos o copiar y pegar - PHP
  #46 (permalink)  
Antiguo 19/11/2013, 07:40
 
Fecha de Ingreso: marzo-2010
Mensajes: 35
Antigüedad: 7 años, 8 meses
Puntos: 1
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

Hola,

¿Se sabe cuánto tiempo, aproximadamente, seguirá funcionando sin problemas la extensión mysql antes de obligatoriamente tener que migrar?

Gracias,

Un saludo
  #47 (permalink)  
Antiguo 19/11/2013, 09:01
Avatar de andresdzphp
Colaborador
 
Fecha de Ingreso: julio-2011
Ubicación: $this->Colombia;
Mensajes: 2.749
Antigüedad: 6 años, 4 meses
Puntos: 793
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

En el momento que actualicen tu PHP a 5.5.0 vas a tener problemas.
__________________
Si sabemos como leer e interpretar el manual será mucho más fácil aprender PHP. En lugar de confiar en ejemplos o copiar y pegar - PHP
  #48 (permalink)  
Antiguo 19/11/2013, 09:08
Avatar de pateketrueke
Modernizr
 
Fecha de Ingreso: abril-2008
Ubicación: Mexihco-Tenochtitlan
Mensajes: 26.399
Antigüedad: 9 años, 7 meses
Puntos: 2526
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

La últimas versiones de PHP ya no incluyen dicho soporte, sin embargo se puede compilar PHP a mano con la opción --with-mysql si se desea tener dicha extensión.

Aunque esto es posible sólo debe usarse de manera temporal en lo que se hace la migración.
__________________
Y U NO RTFM? щ(ºдºщ)

No atiendo por MP nada que no sea personal.
  #49 (permalink)  
Antiguo 13/02/2014, 06:27
Avatar de mili_07  
Fecha de Ingreso: febrero-2012
Mensajes: 58
Antigüedad: 5 años, 9 meses
Puntos: 1
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

Buenas! Una consulta cual creen que es mejor o más recomendable de los dos PDO o mysqli?
A mi me gusta mucho PDO pero me gustaria saber la opinión de otros profesionales... Gracias!
__________________
...Si quieres que tu código funcione y tienes errores, borra todo y vuelve a empezar...
  #50 (permalink)  
Antiguo 13/02/2014, 15:31
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 11 años, 5 meses
Puntos: 2122
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

En pruebas es un poco más rápido MySQLi, pero PDO es más portable, así que todo depende, si quieres un mejor rendimiento (son milisegundos nada de que preocuparse) usa MySQLi, si lo que quieres es portabilidad (moverte entre RDBMS) usa PDO.
  #51 (permalink)  
Antiguo 09/05/2014, 17:55
 
Fecha de Ingreso: marzo-2014
Mensajes: 19
Antigüedad: 3 años, 8 meses
Puntos: 1
Respuesta: Anuncio: Extensión MySQL se considera obsoleta

PDO es todo xD
  #52 (permalink)  
Antiguo 23/07/2014, 01:07
 
Fecha de Ingreso: julio-2014
Mensajes: 6
Antigüedad: 3 años, 4 meses
Puntos: 0
Respuesta: Anuncio: Extensión MYSQL de PHP se considera obsoleta

una pregunta aprendi con el mysql y ahora veo el mysqli por cuestiones de tiempo... se puede usar la extension mysql en el php menor a 5.0 solo para armar una aplicacion rapida para un estudiante amigo mio xD

pregunto porq el 5.0 para arriba me deprecia el mysql y pide el mysqli...

me daria error usar menor a 5.0 o aun se puede usar alguien sabe?
  #53 (permalink)  
Antiguo 25/07/2014, 08:51
Avatar de carlos_belisario
Colaborador
 
Fecha de Ingreso: abril-2010
Ubicación: Venezuela Maracay Aragua
Mensajes: 3.156
Antigüedad: 7 años, 7 meses
Puntos: 460
Respuesta: Anuncio: Extensión MYSQL de PHP se considera obsoleta

lo que tienes que pensar es que cuando vayas subiendo las versiones de php en tu server te va a dar un notice que te va a indicar que la extensión esta obsoleta, ¿es lo que quieres? en teoría en versiones menore a 5.5 no debe dar problema.

De todas maneras mysqli en su modo estructurado es muy parecido a mysql entonces ¿porque no meter de una mysqli y evitar usar libs que se declararon obsoletas? te dejo eso al análisis. Saludos
__________________
aprende d tus errores e incrementa tu conocimientos
it's not a bug, it's an undocumented feature By @David
php the right way

Etiquetas: mysql, sql, anuncios
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Tema Cerrado

SíEste tema le ha gustado a 29 personas




La zona horaria es GMT -6. Ahora son las 11:13.