Foros del Web » Programando para Internet » PHP »

Error con caracteres especiales

Estas en el tema de Error con caracteres especiales en el foro de PHP en Foros del Web. Buenas [email protected] os comento un error bastante raro que me ha salido. Estoy haciendo una web cuyos archivos son todos php, y al lanzar el ...
  #1 (permalink)  
Antiguo 12/11/2007, 03:33
Avatar de Harris  
Fecha de Ingreso: febrero-2007
Mensajes: 132
Antigüedad: 12 años, 11 meses
Puntos: 0
Error con caracteres especiales

Buenas [email protected] os comento un error bastante raro que me ha salido.

Estoy haciendo una web cuyos archivos son todos php, y al lanzar el código html, dependiendo desde dónde lo lance los caracteres especiales como acentos, ñ y demás no aparecen bien.

El problema se produce en el servidor, puesto que el código fuente que le llega al navegador dichos caracteres se transforman en interrogaciones o caractares raros como un cuadrado vacio.

Después también depende desde dónde se envían, si lo hago desde unos includes funciona bien, si lo hago desde otros no.

No depende de la codificación del html porque he probado varias y también a no poner y tampoco funciona.

Todo esto antes no me pasaba, por ello pienso que puede que haya cambiado la configuración del php, pero personalmente no lo he hecho. Sí que he instalado recientemente Joomla, y a lo mejor ha sido él.

Ya sé que se soluciona utilizando los caracteres html como á pero supone un cambio muy grande en el programa, así que quiero evitar hacerlo.

Muchas gracias anticipadas, y ayudadme please.
  #2 (permalink)  
Antiguo 12/11/2007, 03:37
Avatar de Marvin
Colaborador
 
Fecha de Ingreso: febrero-2005
Ubicación: global $Chile->Santiago;
Mensajes: 1.990
Antigüedad: 14 años, 11 meses
Puntos: 80
Re: Error con caracteres especiales

Probaste poniendo el header con la codificacion y el header de los html en su caso ??
Código PHP:
header'Content-Type: text/html;charset=utf-8' ); 
Código HTML:
<META http-equiv=Content-Type content="text/html; charset=utf-8"> 
Suerte
__________________
El que dice "Solo sé que nada sé", esta asumiendo que sabe algo.
Lea las FAQ's!
  #3 (permalink)  
Antiguo 12/11/2007, 04:47
Avatar de Harris  
Fecha de Ingreso: febrero-2007
Mensajes: 132
Antigüedad: 12 años, 11 meses
Puntos: 0
Re: Error con caracteres especiales

Pues lo he probado y no funciona... lo que más raro me parece es que lanzándolo desde diferentes includes a veces funciona bien y otras veces no,

Gracias de todas formas
  #4 (permalink)  
Antiguo 12/11/2007, 11:43
Avatar de Marvin
Colaborador
 
Fecha de Ingreso: febrero-2005
Ubicación: global $Chile->Santiago;
Mensajes: 1.990
Antigüedad: 14 años, 11 meses
Puntos: 80
Re: Error con caracteres especiales

Mmm... si fue despues de la instalacion de joomla podemos intuir que se debe a esto...

Pero dudo que tengas un respaldo de tu instalacion o el phpinfo del anterior para poder revisar si el joomla cambio algo.

Revisa si en las directivas de php.ini hay algo que puedas cambiar para el tratamiento de los caracteres en las paginas interpretadas.

Suerte
__________________
El que dice "Solo sé que nada sé", esta asumiendo que sabe algo.
Lea las FAQ's!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:38.