Foros del Web » Programando para Internet » PHP »

No envía formulario a correo

Estas en el tema de No envía formulario a correo en el foro de PHP en Foros del Web. Hola ! tengo un problema... la verdad que no se si el problema es del lenguaje PHP o de Flash... Yo tengo una página, la ...
  #1 (permalink)  
Antiguo 04/03/2006, 15:56
Avatar de eldiego333  
Fecha de Ingreso: febrero-2006
Mensajes: 45
Antigüedad: 11 años, 10 meses
Puntos: 0
Exclamación No envía formulario a correo

Hola ! tengo un problema... la verdad que no se si el problema es del lenguaje PHP o de Flash...

Yo tengo una página, la cual tiene un formulario hecho en flash. El formualrio anda lo más bien, pero al darle "ENVIAR" no manda nada.... Que puede ser...

Les dejo el código PHP haber si me pueden decir si tiene lagún error, o si es problema de Flash...

Muchas gracias !

Código PHP:
<?PHP
$archivo 
fopen(formulario.csv w);
if (
$archivo) {
$datos=Nombre y apellido:,$nom
Empresa:,$emp
Telefono:,$tel
Direccion postal:,$dirpost
Pais:,$pais
Departamento Ciudad:,$depyciu
E-mail:,$mail;
Asunto:,$asunto
Mensaje:,$mensaje
fputs 
($archivo$datos);
}
echo 
$pulsado;
fclose ($archivo);
?>
<?php
include libmail.php;
$m= new Mail;
$m->Fromformulario321@adinet.com.uy );
$m->Toformulario321@adinet.com.uy );
$m->Subject$nom );
$m->BodyNombre y apellido:,$nom
Empresa:,$emp
Telefono:,$tel
Direccion postal:,$dirpost
Pais:,$pais
Departamento Ciudad:,$depyciu
E-mail:,$mail;
Asunto:,$asunto
Mensaje:,$mensaje );
//$m->Cc( "[email protected]_server.au");
//$m->Bcc( "[email protected]_server.es");
$m->Priority(1) ;
$m->Attachformulario.csvapplication/vnd.ms-excelattachment );
$m->Send();
?>
Saludos
__________________
http://www.teleco.com.uy
  #2 (permalink)  
Antiguo 05/03/2006, 13:11
Avatar de eldiego333  
Fecha de Ingreso: febrero-2006
Mensajes: 45
Antigüedad: 11 años, 10 meses
Puntos: 0
Alguna idea.... ???
__________________
http://www.teleco.com.uy
  #3 (permalink)  
Antiguo 13/03/2006, 16:40
Avatar de eldiego333  
Fecha de Ingreso: febrero-2006
Mensajes: 45
Antigüedad: 11 años, 10 meses
Puntos: 0
Hola devuelta... hace días que sigo trancado con lo mismo y no se cuál es el problema... ...

Alguna idea, link, ayuda... será problema de flash ??
__________________
http://www.teleco.com.uy
  #4 (permalink)  
Antiguo 13/03/2006, 17:17
Avatar de mauled  
Fecha de Ingreso: marzo-2005
Ubicación: Cd. de México.
Mensajes: 3.001
Antigüedad: 12 años, 9 meses
Puntos: 33
A que te refieres a que no te manda nada. Si pudieras ser mas especifico con tu error.
  #5 (permalink)  
Antiguo 13/03/2006, 17:35
okram
Invitado
 
Mensajes: n/a
Puntos:
para el envio del correo estas usando una clase, pero supongo que tal clase trabaja con la funcion mail()... asegurate que tu server tiene el smtp activado, muchos servers gratuitos traen el smtp desactivado, por lo que si utilizas mail() no te mandara ningun error,, pero el mensaje no sera enviado. ademas usa $_POST['variable'] para llamar a las variables enviadas por tu formulario, y no simplemente $variable

http://www.php.net/manual/es/reserved.variables.php

En todo caso, deberias ser mas concreto en la expliacion de tu problema... si no te lanza algun error, lo mas seguro es que no tengas un servidor smtp activo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:34.